2950 pooched?

Unanswered Question
Aug 31st, 2010

Hey there

I am trying to use xmodem to from Hyperterminal to upload a flash file to a switch.
I keep getting the an "invalid arguement" error after it starts the transfer. Any idea as to why or how i can upload this image.

Thanks


copy xmodem: flash:c2950-i6k2l2q4-mz.121-22.EA11.bin

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
vragotha Tue, 08/31/2010 - 12:05

Try this


copy xmodem:c2950-i6k2l2q4-mz.121-22.EA11.bin flash:c2950-i6k2l2q4-mz.121-22.EA11.bin

Siddharth Chand... Tue, 08/31/2010 - 12:09

Hello,


a. This error is seen typically when either:


'flash_int' command is not entered before doing xmodem or its a bad or corrupt flash.


b. Before doing Xmodem:


switch: flash_init
Initializing Flash...
flashfs[0]: 21 files, 2 directories
flashfs[0]: 0 orphaned files, 0 orphaned directories
flashfs[0]: Total bytes: 7741440
flashfs[0]: Bytes used: 4499456
flashfs[0]: Bytes available: 3241984
flashfs[0]: flashfs fsck took 7 seconds.
...done initializing flash.
Boot Sector Filesystem (bs:) installed, fsid: 3
Parameter Block Filesystem (pb:) installed, fsid: 4

switch: load_helper
switch:

c. Now try Xmodem procedure.
The complete xmodem procedure is documented here:
http://tools.cisco.com/squish/74bC1



Sid Chandrachud
Cisco Tac



blakecrossley Tue, 08/31/2010 - 12:20

Hi there I cant even get into flash_init. When it starts all sorts of weird characters appear. I tried all of the suggestions above except deleting the current flash. Not sure how to especially when I cannot execute the flash_init!

blakecrossley Tue, 08/31/2010 - 12:28

switch: flash_init

Initializing Flash...

flashfs[0]: 320 files, 5 directories

flashfs[0]: 0 orphaned files, 0 orphaned directories

flashfs[0]: Total bytes: 7741440

flashfs[0]: Bytes used: 5509120

flashfs[0]: Bytes available: 2232320

flashfs[0]: flashfs fsck took 7 seconds.

...done initializing flash.

Boot Sector Filesystem (bs:) installed, fsid: 3

Parameter Block Filesystem (pb:) installed, fsid: 4

úíííííííííííí

Siddharth Chand... Tue, 08/31/2010 - 14:51

Hello,


This looks like a corrupted flash.

You might have to get the switch replaced.


Sid Chandrachud

Cisco TAC

Actions

This Discussion