Call Manager Attendant Console - initialization of call control fails

Unanswered Question
Aug 31st, 2010
User Badges:

We migrated from some older 7925 servers awhile ago but had not removed them from the Servers list  (System-->Servers).  When I removed them it seems this broke the attendant console program??? - I get the error "Initialization of Call Control Failed.  Retrying...".  So now the operators cannot use it to transfer calls and they are not too happy about it.


Call Manager 7.1.3.32900-4  A Publisher and two subscribers.


Attendant console server and ctimanager running on all 3

I restarted services for Attendant Console and CTImanager.

I deleted and added the ac application user.

Also deleted and added an attendant console user.



This was originally set up by a consultant and we have been using it as he configured it.  There is no Pilot point and hunt group.


I haven't tried TAC - since it is no longer supported ???


Thanks,


Bill

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Jaime Valencia Tue, 08/31/2010 - 12:05
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    2011

Legacy AC is still supported on 7.X (if configured according to the features and services guide)

It seems like you're missing the AC config so that would be the first thing you need to take care of.

AC without the proper pilot point and hunt group config is not supported. Most likely your consultant used hunt pilots and line groups instead, that's not supported.


HTH


java


If this helps, please rate


www.cisco.com/go/pdihelpdesk

gb-fairchild Tue, 08/31/2010 - 16:27
User Badges:

Thanks and shame on me for not reading the end of life bulletin.

Any thought on why removing that server messed it up?

Tracy Larson Tue, 08/31/2010 - 13:41
User Badges:
  • Silver, 250 points or more

Java is spot on as usual. One thing though, the attendant console will function without pilot points or hunt groups. We have some users that choose to use the attendant console as a cheap form of "presence" and only use it to see if someone is on the phone or for an easy way to transfer calls. So if this is your setup as well, i would download the attendant console from the new servers and reinstall it on the pc's.


When you removed the servers from the list, did you then also perform a reset on the group?

gb-fairchild Tue, 08/31/2010 - 16:30
User Badges:

Tracy,


Thanks.


I used it myself the way you mentioned without a pilot.  If you are asking did I reboot all servers in the cluster the answer is no - the TAC person said I didn't need to do that.


Bill

Tracy Larson Tue, 08/31/2010 - 18:08
User Badges:
  • Silver, 250 points or more

No I was assuming since you added new servers to the cluster then you might need to reset your call manager group through the gui. I doubt that is what is messing with the AC but should be done if you didnt do it for the phones. I would however reinstall the AC after downloading it from the new servers. I assume you plugged in the correct settings into the AC if the ip addresses of the servers you are now pointing the AC to are different?

gb-fairchild Tue, 08/31/2010 - 19:50
User Badges:

Call Manager group is all set.  The attendant console has been running with the new servers for weeks.  Only after I deleted the old servers did we start having this problem.  I just remembered that I also added a device pack to fix a problem with Cisco cameras and 9951 phones.  I did the deletes and the device pack on Friday night.  On Monday the receptionist complained about not being able to transfer calls using the attendant console.  I assumed it was the deletes, but maybe not?



The attendant console program points to the IP address of the new publisher.



I did download a new copy of the attendant console from the new publisher and installed it on my laptop.  Unfortunatley right now the stupid laptop thinks my external monitor is still connected and insists on opening the attendant console window on the phantom monitor :-)  So I'll have to wait until tomorrow to see if that made a difference.

gb-fairchild Wed, 09/01/2010 - 06:57
User Badges:

Made some progress by downloading a fresh copy of

Attendant Console from the server.  It now brings up Call Control

successfully, but transfers still fail - now with a new message

"Failed to transfer the call due to Internal Error".

Tracy Larson Wed, 09/01/2010 - 07:08
User Badges:
  • Silver, 250 points or more

Verify your firewall is turned off for starters. Then in your AC settings you should be pointing to your publisher in the Basic tab where it shows "Attendant Server Host Name or IP Address" then on the Advanced tab you should be pointing to your primary subscriber under "Call Processing Server Host Names or Ip Addresses". Give that a try.

gb-fairchild Wed, 09/01/2010 - 09:09
User Badges:

This is working now but I'm not sure why.  After I got the

"Failed to transfer the call due to Internal Error", I re-started the CTIManager service and the Attendant Console service on the publisher and on the subscriber that the phones used by the receptionists are registered to.


It started working on my attendant console.  Then I found out that it started working on the two recepionist's consoles also - even though they did not get a new copy of the console program.  We all have the same version - 7.1.0_c.


Thanks again for all the help.



Bill

Actions

This Discussion