1131 AP BVI

Unanswered Question
Sep 1st, 2010

Hi,

i have an access point connected to 3560 switch with 2 SSID (staff and guest), where the users are taking the ip address from a pool from 3560 switch.

it works fine, but i cannot connect to the BVI interface on the AP.

i have vlan 30 as a  managemet vlan on the switches and access points, with submet 192.168.30.1/24

the interface BVI 1 on the AP is 192.168.3.28/24 with ip default-gateway 192.168.3.1.

i cannot ping from the switch 192.168.3.28 nor from the AP the interface vlan 30,  192.168.3.1

is there anything else i should do?

here are the config of the interface on the switch connecting to the AP:

switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1, 10,20,30
switchport mode trunk
switchport nonegotiate

and the AP config:

Siran-T-AP-F4-01#sh run
Building configuration...

Current configuration : 4372 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!

dot11 syslog
dot11 vlan-name guest vlan 20
dot11 vlan-name staff vlan 10
!
dot11 ssid SiranTower-Guest
   vlan 20
   authentication open
   authentication key-management wpa version 2
   mbssid guest-mode
   wpa-psk ascii xxxxxxxxxxxxx
   information-element ssidl advertisement wps
!
dot11 ssid SiranTower-Staff
   vlan 10
   authentication open
   authentication key-management wpa version 2
   mbssid guest-mode
   wpa-psk ascii xxxxxxxxxxxxxxxx
   information-element ssidl advertisement wps
!
power inline negotiation prestandard source
!


username Cisco password xxxxxx
!        
!
bridge irb
!
!
interface Dot11Radio0
no ip address
no ip route-cache
!
encryption vlan 10 mode ciphers tkip
!
encryption vlan 20 mode ciphers tkip
!
ssid SiranTower-Guest
!
ssid SiranTower-Staff
!
mbssid
station-role root
bridge-group 1
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
bridge-group 1 spanning-disabled
!
interface Dot11Radio0.10
encapsulation dot1Q 10
no ip route-cache
bridge-group 10
bridge-group 10 subscriber-loop-control
bridge-group 10 block-unknown-source
no bridge-group 10 source-learning
no bridge-group 10 unicast-flooding
bridge-group 10 spanning-disabled
!
interface Dot11Radio0.20
encapsulation dot1Q 20
no ip route-cache
bridge-group 20
bridge-group 20 subscriber-loop-control
bridge-group 20 block-unknown-source
no bridge-group 20 source-learning
no bridge-group 20 unicast-flooding
bridge-group 20 spanning-disabled
!
interface FastEthernet0
no ip address
no ip route-cache
duplex auto
speed auto
!
interface FastEthernet0.10
encapsulation dot1Q 10
no ip route-cache
bridge-group 10
no bridge-group 10 source-learning
bridge-group 10 spanning-disabled
!
interface FastEthernet0.20
encapsulation dot1Q 20
no ip route-cache
bridge-group 20
no bridge-group 20 source-learning
bridge-group 20 spanning-disabled
!
interface FastEthernet0.30
encapsulation dot1Q 30 native
no ip route-cache
!
interface BVI1
ip address 192.168.3.28 255.255.255.0
no ip route-cache


!
ip default-gateway 192.168.3.1

end

Siran-T-AP-F4-01#sh ver
Cisco IOS Software, C1130 Software (C1130-K9W7-M), Version 12.4(21a)JY, RELEASE SOFTWARE (fc1)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2010 by Cisco Systems, Inc.
Compiled Wed 28-Apr-10 10:40 by prod_rel_team

ROM: Bootstrap program is C1130 boot loader
BOOTLDR: C1130 Boot Loader (C1130-BOOT-M) Version 12.3(8)JEA, RELEASE SOFTWARE (fc2)

Siran-T-AP-F4-01 uptime is 4 hours, 3 minutes
System returned to ROM by power-on
System image file is "flash:/c1130-k9w7-mx.124-21a.JY/c1130-k9w7-mx.124-21a.JY"

  AIR-LAP1131G-E-K9    (PowerPCElvis) processor (revision D0) with 24566K/8192K bytes of memory.
Processor board ID FCZ1427Q3S6
PowerPCElvis CPU at 262Mhz, revision number 0x0950
Last reset from power-on
1 FastEthernet interface
1 802.11 Radio(s)

32K bytes of flash-simulated non-volatile configuration memory.

Top Revision Number                  : A0
Product/Model Number                 : AIR-LAP1131G-E-K9 

Configuration register is 0xF

Please i appreciate any help.

Thank you and regards,

George

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Surendra BG Fri, 09/03/2010 - 09:42

"Switchport trunk native vlan 30" on the switch and try pinging the BVI

Regards

Surendra

gaboughanem Fri, 09/03/2010 - 10:38

Thank you Surendra for your replay.

i tried this native vlan before it did work.

Today i fixed the problem, by making native vlan 30 on switch and also create  "dot11 vlan-name MGMT vlan 30"

on AP, and reboot. finally it works.

Again thank you again.

Actions

This Discussion