Auto attendant and on-hook detection

Unanswered Question
Sep 1st, 2010
User Badges:

Hello,


I have deployed the auto attendant in my UC560. The AA is answering incoming calls from an analog PSTN line. The problem is, when a client hangs up during the prompt, the call isn't disconnected and is forwarded to a blast group that I have as default forward when no option is selected.


If I forward the PSTN incoming calls to an operator directly, if the client hangs up, then the operator's phone stops ringing correctly.


I have deleted and created the AA, but it doesn't solved nothing.


The UC560 is running SWP8.0.4 and CCA 2.2(5)


Any ideas?.


Thanks.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
antyeung Thu, 09/02/2010 - 19:41
User Badges:
  • Bronze, 100 points or more

Can you get the following debugs for a test call?


debug voip ccapi inout

debug vpm signal

debug ccsip message


When you're on the console can you type in the session to mark when the PSTN hung up the call?


Also include the 'show run'.


-Anthony

sistemas.sede Fri, 09/03/2010 - 01:03
User Badges:

Hi Anthony,


I have attached the debugs and the run.

I have placed a call, and when the prompt starts I hang up, after playing the prompt the second time the call (already finished) forwards to a blast group and finally to the voice mail.


I have marked the moment I finish the call in the .txt with this:


/******************** END OF THE CALL ************************/
001657: Sep  3 07:51:06.050: htsp_process_event: [0/3/0, FXOLS_CONNECT, E_DSP_SIG_0110]fxols_rvs_battery
001658: Sep  3 07:51:06.050: htsp_timer_stop2
001659: Sep  3 07:51:06.050: htsp_timer_stop2
001660: Sep  3 07:51:19.486: htsp_process_event: [50/0/9.1, EFXS_ONHOOK, E_DSP_SIG_1100]efxs_onhook_offhook htsp_setup_ind
001661: Sep  3 07:51:19.486: [50/0/9.1] get_local_station_id calling num=BCD calling name= calling time=09/03 09:51  orig called=


Regards!

Attachment: 
sistemas.sede Wed, 09/08/2010 - 09:12
User Badges:

Hi Anthony,


Did you find out where is the problem?. I was thinking in resetting the CUE, but I don't want to lose mail-boxes and configuration.


Regards.

antyeung Sun, 09/12/2010 - 22:39
User Badges:
  • Bronze, 100 points or more

Sorry about the delay. When the PSTN party hangs up the phone with when they're connected to an IP phone user, does the IP phone user hears any tone?


-Anthony

antyeung Mon, 09/13/2010 - 00:33
User Badges:
  • Bronze, 100 points or more

Immediately? Is it a fast busy or dial-tone? It looks like your provider is using disconnect tone for disconnect supervision. I may need you to get PCM captures so we can define a custom disconnect tone.

antyeung Mon, 09/13/2010 - 11:55
User Badges:
  • Bronze, 100 points or more

Can you get PCM captures for the call so that I can get an audio sample of the disconnect tone?

antyeung Mon, 09/13/2010 - 00:36
User Badges:
  • Bronze, 100 points or more

Can you also get the same debugs "debug vpm signal" when you call an internal extension that does not have this problem? Indicate in the debugs once the pstn disconnects.


--

Anthony

antyeung Wed, 09/15/2010 - 07:45
User Badges:
  • Bronze, 100 points or more

There's nothing in the PCM capture file. They may have been captured for the wrong port. Are you using CCA or the CLI to capture PCM traces?


sistemas.sede Wed, 09/15/2010 - 08:39
User Badges:

Hi Anthony,


     I did it with CLI following this tutorial: https://www.myciscocommunity.com/docs/DOC-8419. I tried with CCA, but it does not allow to save the resultant file, the window that appears after getting the samples only allows open a file, instead of save, must be a CCA bug, you can see it in the picture.

I made a mistake the first time because I started getting the samples before placing the call, I apologise. Now I got a 8Mb file.

antyeung Sun, 09/19/2010 - 20:29
User Badges:
  • Bronze, 100 points or more

Can you give this a try-


voice class custom-cptone custom_disconnect
dualtone busy
  frequency 425
  cadence 200 198


voice-port 0/0/0
supervisory disconnect dualtone mid-call
supervisory custom-cptone custom_disconnect


Let me know how that works. I may need to tweak the cadence measurements even more if it doesn't work.


-Anthony

sistemas.sede Mon, 09/20/2010 - 07:17
User Badges:

I'm afraid it does not work. The behavior is the same.


Regards.

Steven Holl Mon, 09/20/2010 - 08:22
User Badges:
  • Cisco Employee,

voice class custom-cptone custom_disconnect
dualtone busy
  frequency 425
  cadence 200 198


voice-port 0/0/0
supervisory disconnect dualtone mid-call
supervisory custom-cptone custom_disconnect


When you specify a custom cadence, the total of the numbers needs to exceed the guard timer.


I haven't looked at the tone to see if the frequency/cadence values are right, but assuming they are, try this:

voice class custom-cptone custom_disconnect
dualtone busy
  frequency 425
  cadence 200 200 200 200 200 200


voice-port 0/0/0
supervisory disconnect dualtone mid-call
supervisory custom-cptone custom_disconnect

timeouts call-disconnect 1
timeouts wait-release 1

sistemas.sede Tue, 09/21/2010 - 01:18
User Badges:

Hi Steven,


     Thanks for your input. I have tried the configurations you suggested, but unfortunately still doing the same. At the begining it worked fine, but after doing some tests creating and deleting the AA, it stopped detecting the on-hook tone. Very strange.


Regards.

paolo bevilacqua Wed, 12/26/2012 - 11:42
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

As indicated above, you need to configure disconnect tones correctly.


There are many many threads about that, please use th search function.

Actions

This Discussion