Better WiFi transmit and receive on built-in SR520W antenna...

Unanswered Question
Sep 1st, 2010


We are using a SR520 with the latest IOS in an home office and also using the built-in WiFi.  What can we do to natively boost the antenna performance so we can walk more than 25 feet away from the SR520?

Below is the section from the show run for what we have tried for better antenna TX/RX.

interface Dot11Radio0
no ip address
ssid sr520
speed basic-1.0 2.0 5.5 6.0 9.0 11.0 12.0 18.0 24.0 36.0 48.0 54.0
station-role root
antenna receive right
antenna transmit right
antenna gain 128

Please advise.

Thank you, John

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
sethschmautz Wed, 09/01/2010 - 16:02

Hi John,

Is there any way that you can check to determine if there are other wireless networks nearby that are operating on the same frequency?  There are wifi analyzer programs available for everything from your laptop to your ipod touch or android phones.  In addition, check to see if there are any other 2.4GHz devices around - cordless phones, microwaves, etc. 

We have deployed SR520s in different locations, and while the range isn't the greatest that we have ever seen, it should be better than 25'.  Is the wireless card in the laptop built in?  How new/old is the laptop that you are using?  Have you tried multiple devices with the same problem?



jwaskewics Thu, 09/02/2010 - 15:16


I changed the WiFi channel to "least busy" in CCA.  We are using a Cisco 7921 phone for the WiFi connection.  At around 25" it drops out.  The SR520 is in an office, so there may be some interference, but even in a complete clear line of sight it drops out.

I have not tried a laptop, just the phone.  It could be other 2.5 Ghz devices I presume.

Prior to making the CLI changes below, reception was WORSE at only 6'.

Maybe I'll have to look into the WiFi analizer.

Any other ideas would be welcomed.

Thank you,


sethschmautz Thu, 09/02/2010 - 15:46

Hmmmm.  That doesn't seem right at all.

The wifi analyzer isn't a perfect tool, but it sure helps.  For instance, channels 1, 6, and 11 are the only non-overlapping channels.  We make it a point to always set our APs for clients in one of these 3 channels.  The UC540W installations that we do often have a standard setting of channel 4 for some reason. . .

In the event that don't have access to a wifi analyzer, you can use your 7921.  Open the toolbox, scroll down to "status", then select "site survey".  It will show you broadcasting SSIDs, channels, and RSSI (signal strength).  You should be seeing somewhere in the neighborhood of -45dB right in front of the SR520W, but it will degrade as you get further away.  Everything should work well until approximately -80dB.  At that point, I think you'll have some problems.  If you click on a specific SSID/channel, you can see more specific info, including a better view of the signal strength.  In this new page you will be able to see something like this:

RSSI: -30(-43,-26)

The -30 is the current RSSI, -43 is the lowest that the devices has seen, and the -26 is the highest that the device has seen.  This can be very helpful.

Best practices include:

1. Line of Sight works best.  Some materials scatter or absorb 2.4 GHz including wood, metal, etc.  You may notice that as you enter an office where you may be trying to communicate through a huge wooden cupboard that your coverage gets much worse.

2. Other devices in the 2.4 GHz range can interfere with the signal.  This includes microwaves, cordless phones that operate in the 2.4GHz spectrum, and other devices

3. Ensure that your antenna is tightly screwed onto the antenna port on the SR520

Hopefully this helps.  Let me know what you find out.



This Discussion

Related Content