802.11n: How can I force a wireless adapter to primarily associate to a 5Ghz radio and not to the 2.4Ghz one?

Unanswered Question
Sep 1st, 2010

Hi experts,

I am playing with a Cisco 1142 AP. I have same SSID configured on both dot0 and dot1 interfaces. I have a test laptop and it has a Linksys dual-band wireless adapter. However the card always try to associate on the 2.4GHz. It will only associate with the 5GHz radio when I shut down the dot 0 interface. The laptop is running Windows XP SP3 and I'm using the windows wireless Zero configuration to configure the wireless. The following is the AP's configuration:

dot11 ssid Guest-Wireless
   authentication open
   guest-mode

interface Dot11Radio0
no ip address
no ip route-cache
!
ssid Guest-Wireless
!
antenna gain 0
channel 2412
station-role root
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 port-protected
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
bridge-group 1 spanning-disabled

interface Dot11Radio1
no ip address
no ip route-cache
!
ssid Guest-Wireless
!
antenna gain 0
dfs band 3 block
channel dfs
station-role root
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 port-protected
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
bridge-group 1 spanning-disabled

Is it something I can control through the AP or it's the laptop/wireless adapter's own behavior so I either need a new card or update it with a new firmware?

Thanks!

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Leo Laohoo Wed, 09/01/2010 - 16:12

Not sure if you can find this feature in the Linksys card but you can specify for the client to associate to either 2.4 or 5.0.

What's the signal like of the 5.0 Ghz when the card associates to the 2.4Ghz.

2.4Ghz is know for low speed but long range (and penetrating power) however 5.0 Ghz suffers the opposite:  low penetrating power, short range but higher speed.

Difan Zhao Wed, 09/01/2010 - 16:17

Leolaohoo,

Thanks for quick reply! My laptop is just next to the AP. There is nothing but air between the laptop and the AP.

I actually did speed tests on both 2.4 and 5 (with 2.4 disabled of course) and I got pretty much the same result: 46Mbps MAX. I don't know if it's the linksys n card is limiting the capacity of the AP. But for now I just want it to jump on 5GHz instead of 2.4GHz...

Thanks,

Leo Laohoo Wed, 09/01/2010 - 16:33

It's possible.  Like I said, I'm not familiar with the Linksys product.  But I've got a cheap Cisco CB21 from e-bay and using the driver and software, I can specify if I want 2.4 or 5.0 or auto.

Actions

This Discussion