DHCPRelay ASA 5505 --> ASA5520 --> Infoblox

Unanswered Question
Sep 2nd, 2010

Hi

,

I'm trying to setup a soho with an ASA 5505 (via VPN) with DHCP Relay to our Infoblox.

I cann see that the 5505 is sending the packets to the destination correctly:

config:

dhcprelay server 10.59.1.100 outside
dhcprelay enable inside
dhcprelay setroute inside
dhcprelay timeout 60

routing:

name 10.0.0.0 SV_Netz description SV_Netz

network-object SV_Netz 255.0.0.0
object-group network SV_Netz_Internal
network-object SV_Netz 255.0.0.0
network-object SV_Netz 255.0.0.0
access-list inside_access_in extended permit ip object-group SV_Netz_Internal any log debugging
access-list outside_1_cryptomap extended permit ip 172.17.27.128 255.255.255.192 object-group SV_Netz_Internal

debug:


dhcpd_forward_request: request from 0001.e32f.c1d7 forwarded to 10.59.1.100.
DHCPRA: relay binding found for client 0001.e32f.c1d7.
DHCPD: setting giaddr to 172.17.27.129.
dhcpd_forward_request: request from 0001.e32f.c1d7 forwarded to 10.59.1.100.
DHCPRA: relay binding found for client 0001.e32f.c1d7.
DHCPD: setting giaddr to 172.17.27.129.
dhcpd_forward_request: request from 0001.e32f.c1d7 forwarded to 10.59.1.100.
DHCPRA: relay binding found for client 0001.e32f.c1d7.
DHCPD: setting giaddr to 172.17.27.129.

The ASA 5520 is in our moitoring and there is no information at all about incomming DHCP request at all from Network 172.17.27.128/26!

I can access from the soho Net to the internal Net 10.0.0.0 / 8

Question:

is there any further needs to setup something on the ASA 5520???

What Debug commands can I use on the ASA 5520???

Thanks

Roy

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Yudong Wu Thu, 09/02/2010 - 15:42

1. Is DHCP relay packet included in your VPN ACL?

2. If using NAT, did you exclude DHCP relay packet from NAT?

Please paste your configuration file

RoyBoy1979 Thu, 09/02/2010 - 22:58

Hi,

Im not using NAT and my ACL is open for 10.0.0.0/8.

here is my config

fw-c-sv-it-testlab# sho running-config
: Saved
:
ASA Version 8.0(4)
!
hostname fw-c-sv-it-testlab
domain-name net.sv.de

names
name 10.0.0.0 SV_Netz description SV_Netz
!
interface Vlan1
nameif inside
security-level 100
ip address 172.17.27.129 255.255.255.192
!
interface Vlan2
nameif outside
security-level 0
pppoe client vpdn group Telekom
ip address pppoe setroute
!
interface Ethernet0/0
switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
boot system disk0:/asa804-k8.bin
ftp mode passive
dns domain-lookup inside
dns server-group DefaultDNS
domain-name net.sv.de
object-group network SV_Netz_Internal
network-object SV_Netz 255.0.0.0
network-object 172.26.0.0 255.255.0.0
object-group network DM_INLINE_NETWORK_1
network-object 213.61.179.0 255.255.255.0
group-object SV_Netz_Internal
object-group network DM_INLINE_NETWORK_2
network-object 213.61.179.0 255.255.255.0
group-object SV_Netz_Intern
access-list inside_access_in extended permit ip any any log debugging
access-list inside_access_in extended permit ip object-group SV_Netz_Internal any log debugging
access-list outside_1_cryptomap extended permit ip 172.17.27.128 255.255.255.192 object-group SV_Netz_Internal
access-list inside_nat0_outbound extended permit ip interface inside 172.26.0.0 255.255.0.0
access-list outside_access_in extended permit ip object-group DM_INLINE_NETWORK_1 any log debugging
access-list outside_access_in extended permit ip any object-group DM_INLINE_NETWORK_2 log debugging
pager lines 24
logging enable
logging asdm informational
mtu inside 1500
mtu outside 1500
icmp unreachable rate-limit 1 burst-size 1
icmp permit any echo inside
icmp permit any echo-reply inside
icmp permit 213.61.179.0 255.255.255.0 echo outside
icmp permit 213.61.179.0 255.255.255.0 echo-reply outside
asdm image disk0:/asdm-621.bin
no asdm history enable
arp timeout 14400
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 0 0.0.0.0 0.0.0.0
access-group inside_access_in in interface inside
access-group outside_access_in in interface outside
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
dynamic-access-policy-record DfltAccessPolicy
nac-policy DfltGrpPolicy-nac-framework-create nac-framework
default-acl  unused
reval-period 36000
sq-period 300
aaa authentication enable console LOCAL
aaa authentication http console LOCAL
aaa authentication ssh console LOCAL
http server enable
http 172.17.27.128 255.255.255.192 outside
http 172.26.16.0 255.255.255.192 inside
http 172.17.27.128 255.255.255.192 inside
http 213.61.179.0 255.255.255.0 outside
http 172.26.50.0 255.255.255.192 inside
http 172.26.50.0 255.255.255.192 outside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
crypto map outside_map 1 match address outside_1_cryptomap
crypto map outside_map 1 set peer 213.xx.xxx.xxx
crypto map outside_map 1 set transform-set ESP-AES-256-SHA ESP-3DES-SHA ESP-DES-SHA
crypto map outside_map 1 set security-association lifetime seconds 28800
crypto map outside_map 1 set security-association lifetime kilobytes 4608000
crypto map outside_map 1 set nat-t-disable
crypto map outside_map interface outside
crypto isakmp enable outside
crypto isakmp policy 10
authentication pre-share
encryption 3des
hash sha
group 2
lifetime 86400
no crypto isakmp nat-traversal
telnet timeout 5
ssh 172.26.50.0 255.255.255.192 inside
ssh 213.xx.xxx.0 255.255.255.0 outside
ssh timeout 5
console timeout 0
management-access inside
vpdn group Telekom request dialout pppoe
vpdn group Telekom localname [email protected]
vpdn group Telekom ppp authentication pap
vpdn username [email protected] password ********* store-local
dhcpd auto_config outside
!
dhcpd address 172.17.27.130-172.17.27.135 inside
dhcpd dns 10.59.1.100  10.59.101.100 interface inside
dhcpd domain sv.intern interface inside
!
dhcprelay server 10.59.1.100  outside
dhcprelay enable inside
dhcprelay setroute inside
dhcprelay timeout 60

priority-queue inside
priority-queue outside
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
ntp server 10.59.1.100  source outside prefer
group-policy DfltGrpPolicy attributes
vpn-tunnel-protocol IPSec
nac-settings value DfltGrpPolicy-nac-framework-create
webvpn
  svc keepalive none
  svc dpd-interval client none
  svc dpd-interval gateway none
  customization value DfltCustomization
username admin password wutdsvsdf/ghzugdu encrypted privilege 15
tunnel-group 213.xx.xxx.xxx type ipsec-l2l
tunnel-group 213.xx.xxx.xxx ipsec-attributes
pre-shared-key *
!
class-map inspection_default
match default-inspection-traffic
class-map voice-class
match rtp 5004 595
!
!
policy-map type inspect dns preset_dns_map
parameters
  message-length maximum 512
policy-map global_policy
class voice-class
  priority
class inspection_default
  inspect dns preset_dns_map
  inspect esmtp
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect netbios
  inspect rsh
  inspect rtsp
  inspect skinny
  inspect sqlnet
  inspect sunrpc
  inspect tftp
  inspect xdmcp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:85d4854e0550d5dad816741cfa624d2f
: end

Yudong Wu Fri, 09/03/2010 - 08:41

Could you please remove the following commands and try it again? I did not see dhcpd is enabled. So we don't need those commands. Since dhcprelay and dhcpd could not be used on the same interface. I just wonder if those commands confused the system although dhcpd is not enabled on inside interface.

dhcpd address 172.17.27.130-172.17.27.135 inside
dhcpd dns 10.59.1.100  10.59.101.100 interface inside
dhcpd domain sv.intern interface inside

RoyBoy1979 Sun, 09/05/2010 - 23:09

Hi,

unfortunally that didn't work:

here is my config and DEBUG:

fw-c-sv-it-testlab# sho runn
: Saved
:
ASA Version 8.0(4)
!
hostname fw-c-sv-it-testlab
domain-name net.sv.de
enable password WV7adffgIN/Lyt99 encrypted
passwd 2gddtrtNIdI.2KYOU encrypted
names
name 10.0.0.0 SV_Netz description SV_Netz
!
interface Vlan1
nameif inside
security-level 100
ip address 172.17.27.129 255.255.255.192
!
interface Vlan2
nameif outside
security-level 0
pppoe client vpdn group Telekom
ip address pppoe setroute
!
interface Ethernet0/0
switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
boot system disk0:/asa804-k8.bin
ftp mode passive
dns domain-lookup inside
dns server-group DefaultDNS
domain-name net.sv.de
object-group network SV_Netz_Internal
network-object SV_Netz 255.0.0.0
network-object 172.xx.0.0 255.255.0.0
object-group network DM_INLINE_NETWORK_1
network-object 213.xx.xxx.0 255.255.255.0
group-object SV_Netz_Internal
object-group network DM_INLINE_NETWORK_2
network-object 213.xx.xxx.0 255.255.255.0
group-object SV_Netz_Internal
object-group network DM_INLINE_NETWORK_3
network-object 172.xx.0.0 255.255.0.0
group-object SV_Netz_Internal
object-group network DM_INLINE_NETWORK_4
access-list inside_access_in extended permit ip any any log debugging
access-list inside_access_in extended permit ip object-group SV_Netz_Internal any log debugging
access-list outside_1_cryptomap extended permit ip 172.xx.xx.xxx 255.255.255.192 object-group SV_Netz_Internal log debugging
access-list outside_1_cryptomap extended permit ip interface outside object-group SV_Netz_Internal log debugging
access-list inside_nat0_outbound extended permit ip interface inside object-group DM_INLINE_NETWORK_3 log debugging
access-list inside_nat0_outbound extended permit ip interface outside object-group SV_Netz_Internal log debugging
access-list outside_access_in extended permit ip object-group DM_INLINE_NETWORK_1 any log debugging
access-list outside_access_in extended permit ip any object-group DM_INLINE_NETWORK_2 log debugging
access-list outside_access_in extended permit ip interface outside object-group SV_Netz_Internal log debugging
pager lines 24
logging enable
logging asdm-buffer-size 200
logging monitor emergencies
logging buffered debugging
logging trap debugging
logging history debugging
logging asdm debugging
mtu inside 1500
mtu outside 1500
icmp unreachable rate-limit 1 burst-size 1
icmp permit any echo inside
icmp permit any echo-reply inside
icmp permit 213.xx.xx.0 255.255.255.0 echo outside
icmp permit 213.xx.xx.0 255.255.255.0 echo-reply outside
asdm image disk0:/asdm-621.bin
no asdm history enable
arp timeout 14400
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 0 0.0.0.0 0.0.0.0
access-group inside_access_in in interface inside
access-group outside_access_in in interface outside
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
dynamic-access-policy-record DfltAccessPolicy
nac-policy DfltGrpPolicy-nac-framework-create nac-framework
reval-period 36000
sq-period 300
aaa authentication enable console LOCAL
aaa authentication http console LOCAL
aaa authentication ssh console LOCAL
http server enable
http 172.xx.xx.0 255.255.255.192 outside
http 172.xx.xx.0 255.255.255.192 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
crypto map outside_map 1 match address outside_1_cryptomap
crypto map outside_map 1 set peer 213.xx.xxx.xxx
crypto map outside_map 1 set transform-set ESP-AES-256-SHA ESP-3DES-SHA ESP-DES-SHA
crypto map outside_map 1 set security-association lifetime seconds 28800
crypto map outside_map 1 set security-association lifetime kilobytes 4608000
crypto map outside_map 1 set nat-t-disable
crypto map outside_map interface outside
crypto isakmp enable outside
crypto isakmp policy 10
authentication pre-share
encryption 3des
hash sha
group 2
lifetime 86400
no crypto isakmp nat-traversal
telnet timeout 5
ssh 172.xx.xx.0 255.255.255.192 inside
ssh 213.xx.xxx.0 255.255.255.0 outside
ssh timeout 5
console timeout 0
management-access inside
vpdn group Telekom request dialout pppoe
vpdn group Telekom localname [email protected]
vpdn group Telekom ppp authentication pap
vpdn username [email protected] password ********* store-local
dhcprelay server 10.59.1.100 outside
dhcprelay enable inside
dhcprelay setroute inside
dhcprelay timeout 60

priority-queue inside
priority-queue outside
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
ntp server 10.59.1.100 source outside prefer
group-policy DfltGrpPolicy attributes
vpn-tunnel-protocol IPSec
nac-settings value DfltGrpPolicy-nac-framework-create
webvpn
  svc keepalive none
  svc dpd-interval client none
  svc dpd-interval gateway none
  customization value DfltCustomization
username admin password wuk3ChbB/p13IopQ encrypted privilege 15
tunnel-group 213.xx.xxx.xxx type ipsec-l2l
tunnel-group 213.xx.xxx.xxx ipsec-attributes
pre-shared-key *
!
class-map inspection_default
match default-inspection-traffic
class-map voice-class
match rtp 5004 595
!
!
policy-map type inspect dns preset_dns_map
parameters
  message-length maximum 512
policy-map global_policy
class voice-class
  priority
class inspection_default
  inspect dns preset_dns_map
  inspect esmtp
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect netbios
  inspect rsh
  inspect rtsp
  inspect skinny
  inspect sqlnet
  inspect sunrpc
  inspect tftp
  inspect xdmcp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:6e7bf2fe9fe3e8f60c042778990d0e2a
: end

DEBUG:

debug dhcprelay event enabled at level 1
fw-c-sv-it-testlab# debug dhcprelay er
fw-c-sv-it-testlab# debug dhcprelay error
debug dhcprelay error enabled at level 1
fw-c-sv-it-testlab# debug dhcprelay pa
fw-c-sv-it-testlab# debug dhcprelay packet
debug dhcprelay packet enabled at level 1
fw-c-sv-it-testlab# DHCPRA: relay binding found for client 0001.e32f.c1d7.
DHCPD: setting giaddr to 172.17.27.129.
dhcpd_forward_request: request from 0001.e32f.c1d7 forwarded to 10.59.1.100.

DHCPRA: relay binding found for client 0001.e32f.c1d7.
DHCPD: setting giaddr to 172.17.27.129.
dhcpd_forward_request: request from 0001.e32f.c1d7 forwarded to 10.59.1.100.
DHCPRA: relay binding found for client 0001.e32f.c1d7.
DHCPD: setting giaddr to 172.17.27.129.
dhcpd_forward_request: request from 0001.e32f.c1d7 forwarded to 10.59.1.100.

I read somewhere, that maybe the DHCP request may be running out to the "Outside" interface, but I need it over the VPN tunnel.

I'm sending 10.0.0.0/8 over the tunnel or is maybe something missing???

Thanks for your help

Roy

Nagaraja Thanthry Sun, 09/05/2010 - 23:57

Hello,

So, based on your description you have

SOHO -- ASA5505 -VPN-ASA5520--DHCP Server

And you do see the DHCP replies coming back on the ASA5505 (via debugs) and

you do get an IP to the client. Is that correct?

If you are looking for the corresponding traffic on the 5520, I don't think

you will see any debug messages as for 5520, it is just a regular unicast

traffic. You can configure captures on the interface where DHCP server is

connected to monitor the DHCP requests.

Hope this helps.

Regards,

NT

RoyBoy1979 Mon, 09/06/2010 - 00:04

Hi,

the Flow is correct.

No, I don't recieve a DHCP Replie. I also do not see any incomming traffic (Port 67 or 68) on the 5520.

The DHCP Server is rechable via ICMP ans so on.

Nagaraja Thanthry Mon, 09/06/2010 - 00:04

Hello,

On a second look, I realized that the debugs are just stating that they are

setting the default gateway but are actually not getting the IP from the

remote server. When I looked at your configuration, I do not see a rule in

the cryptomap that matches traffic destined to the remote DHCP server.

Please try the following:

access-list outside_1_cryptomap extended permit ip any host 10.59.1.100

On the remote firewall (5520):

access-list "crypto ACL name" permit ip host 10.59.1.100 any

Also, make sure that, on the remote ACL, you do have a nonat statement that

matches traffic sourced from 10.59.1.100 to any.

Hope this helps.

Regards,

NT

Yudong Wu Tue, 09/07/2010 - 09:56

On 5505, you do have the following ACL to match DHCP relay packet.

access-list outside_1_cryptomap extended permit ip 172.17.27.128 255.255.255.192 object-group SV_Netz_Internal

What's your config on ASA5520?

Actions

This Discussion