One prot out of 4 of a L2 Portchannel goes down (errdisable), Channel remains up, but OSPF neighbourship goes down

Unanswered Question
Sep 2nd, 2010

Hi all,
We have a VSS core switch and one VSS distrubution switch, connected via 4x 10GE l2 Ether-channel using pagp
all 4 links are connected to a WS-X6716-10G-3C (on the 2 VSS systems (see drawing)). sporadically one link (link 1/3/1, we assume that the port asic has a problem)
goes down (errdisable udld). The etherchannel remains up but all OSPF neighbours are going down (dead timer expired).
after aprox. 50 sec. later the OSPF neighbours are comming up again (link 1/3/1 is still down).

Now my question, it there anything special with the first link in a port-channel, not just STP but OSPF-hello e.g.

This scenario should be very redundant, but abviously it is not.
So any hints, informations, sugguestions are welcome !
Thanks in advance

here some informations from the boxes:

-----------------
| VSS-Core |
---------------
|  |  |  |
|  |  |  | L2 Etherchannel 1/3/1 + 1/3/9 + 2/3/1 + 2/3/9
|  |  |  |
|  |  |  |
--------------
| VSS-dist |
--------------

Core:
interface Port-channel210
description VSS-dist
switchport
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
logging event link-status
!
interface TenGigabitEthernet1/3/1
description dist Te2/3/16
switchport
switchport mode trunk
switchport nonegotiate
logging event link-status
channel-group 210 mode desirable
..
...
router ospf 1
nsf
""default timer"
....

Logg VSS-Core:

....
Sep 1 07:46:00.957: %OSPF-5-ADJCHG: Process 1, Nbr 10.136.138.97 on Vlan763 from FULL to DOWN, Neighbor Down: Dead timer expired
Sep 1 07:46:32.450: %LINEPROTO-5-UPDOWN: Line protocol on Interface TenGigabitEthernet1/3/1, changed state to down
Sep 1 07:46:32.466: %LINK-3-UPDOWN: Interface TenGigabitEthernet1/3/1, changed state to down
Sep 1 07:46:32.432: %UDLD-SW1_SP-4-UDLD_PORT_DISABLED: UDLD disabled interface Te1/3/1, unidirectional link detected
Sep 1 07:46:32.432: %PM-SW1_SP-4-ERR_DISABLE: udld error detected on Te1/3/1, putting Te1/3/1 in err-disable state
Sep 1 07:46:32.584: %LINEPROTO-SW1_SP-5-UPDOWN: Line protocol on Interface TenGigabitEthernet1/3/1, changed state to down
Sep 1 07:46:32.588: %LINK-SW1_SP-3-UPDOWN: Interface TenGigabitEthernet1/3/1, changed state to down
Sep 1 07:46:32.788: %PM-SW2_SPSTBY-4-ERR_DISABLE: udld error detected on Te1/3/1, putting Te1/3/1 in err-disable state
Sep 1 07:46:39.498: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.10.37 on Vlan3127 from LOADING to FULL, Loading Done
....
....

Logg VSS-dist:
Sep  1 07:46:32.571: %LINEPROTO-5-UPDOWN: Line protocol on Interface TenGigabitEthernet1/2/16, changed state to down
Sep  1 07:46:32.607: %LINK-3-UPDOWN: Interface TenGigabitEthernet1/2/16, changed state to down
Sep  1 07:46:32.835: %LINEPROTO-SW1_SP-5-UPDOWN: Line protocol on Interface TenGigabitEthernet1/2/16, changed state to down
Sep  1 07:46:32.835: %LINK-SW1_SP-3-UPDOWN: Interface TenGigabitEthernet1/2/16, changed state to down

Thanks!
Manu

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
e.hoehn Fri, 09/03/2010 - 04:12

I just opend a tac Service request. I will update this post once I have a explanation / solution

.

v.matiakis Fri, 04/08/2011 - 06:56

Hi there,

Did you have an answer from the Cisco TAC? Can you post the problem-solution?

Actions

This Discussion

Related Content