Cannot ping vlan interface with LAG etablished¿?¿?

Answered Question
Sep 3rd, 2010

HI all ¡¡¡¡¡¡¡¡

I have a switch powerconect (Dell/cisco).


I have one prolem. When i etablish channel group and LAG with another switch i cant  ping the vlan interface 100.

If the interfaces are not in a channel group i can ping this vlan interface.


Why i can't ping the vlan interface when the LAG its etablished?¿¿?¿?


I put the config with explanation:


Ok, this is the config

!Current Configuration:
!System Description "PowerConnect M6220, 3.1.5.2, VxWorks 6.5"
!System Software Version 3.1.5.2
!System Operational Mode "Normal"
!
configure
vlan database
vlan  100
exit
hostname "SW-xxxxxxx"
stack
member 1 1
member 2 1
exit
switch 1 priority 12
switch 2 priority 11
exit
ip address none
ip routing--------->Routing for ipv4 enable
ip route 0.0.0.0 0.0.0.0 10.0.4.1 --->DEFAULT GATEWAY IN THE SAME SUBNET OF THE VLAN INTERFACE 100
interface vlan 100
routing
ip address  10.0.4.7  255.255.255.0-->VLAN INTERFACE 100
exit


!
interface ethernet 1/g17
channel-group 2 mode auto --------->member of channel group 2 and vlan 100
switchport access vlan 100
exit


!
interface ethernet 2/g17
channel-group 2 mode auto------->member of channel group 2 and vlan 100 mode auto(lacp)
switchport access vlan 100
exit


!
interface port-channel 2
switchport access vlan 100-------->Portchannel 2 member of vlan 100


In this escenario you can view 2 interfaces in a chanel group:

If the LAG its etablished with the other switch i can´t ping te interface 10.0.4.7.
If one interface (1/g17 or 2/g18)its not in the channel group i can ping the interface 10.0.4.7

Why i can't ping the 10.0.4.7 when the LAG its etablished ¿? Please help.

Correct Answer by vinodjad1234 about 6 years 5 months ago

Hi,


it looks like , you have issue with STP.


I reckon , you need to disable the STP in dell ... I hope it will be connected with LAG


Please check it and let me know.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Correct Answer
vinodjad1234 Fri, 09/03/2010 - 02:39

Hi,


it looks like , you have issue with STP.


I reckon , you need to disable the STP in dell ... I hope it will be connected with LAG


Please check it and let me know.

extrandubi Fri, 09/03/2010 - 03:14

OMG ¡¡ Now it works.


STP its recommended with LACP. Why stp bloqs the ports???


Thanks ¡¡

vinodjad1234 Fri, 09/03/2010 - 04:18

Hi,


Due to internal connectivity structure of dell switches , it creates loop and keeps LAG ports in blocking . I had same issue and when i had raised query against dell , they recommanded that STP should be disabled.


I think , you are also having same issue.


Please give rating your query has got rectified.

extrandubi Fri, 09/03/2010 - 04:32

Vinod , thanks a lot.

It was driving me crazy ¡¡¡¡


regards ¡¡

Actions

This Discussion