cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
663
Views
0
Helpful
3
Replies

How to configure DHCP

PRASAD BAIT
Level 1
Level 1

Hi,

I have windows 2003 server is it possible to make it DHCP server ? If its possible how to achive redundancy in it?

Regards,

Prasad Bait

3 Replies 3

Jon Marshall
Hall of Fame
Hall of Fame

baitprasad wrote:

Hi,

I have windows 2003 server is it possible to make it DHCP server ? If its possible how to achive redundancy in it?

Regards,

Prasad Bait

Yes it's possible and in fact WIndows probably has the best DHCP server. For redundancy you could have 2 DHCP servers and split each subnet in half so one server is responsible for half the subnet and the other server responsible for the other.

.On the L3 switch you would simply configure ip helper-addresses under the L3 vlan interfaces eg -

int vlan 10

ip helper-address 192.168.5.10

ip helper-address 192.168.6.10

where 192.168.5.10 and 192.168.6.10 are the IP addresses of the DHCP servers.

As for setting it up it is fairly intuitive as it is all GUI based on Windows. If you need instructions best place to look would be on technet which can be found on the microsoft website - www.microsoft.com.

Jon

Hi Jon,

I have configured the DHCP server but can you tell how i can mapped the VLAN to Specific subnet or Specific pool of addresses.

Regards,

Prasad Bait

Here is how you could configure the ports and VLANs

interface GigabitEthernet2/3
description Desktop_PC VLAN112
switchport
switchport access vlan 112
switchport mode access
spanning-tree portfast

interface GigabitEthernet2/40
description Desktop_PC VLAN111
switchport
switchport access vlan 111
switchport mode access
spanning-tree portfast

interface Vlan111
description VLAN 111 Data
ip address 10.10.111.1 255.255.255.0
ip helper-address 10.10.13.57 <----------------1st DHCP Server
ip helper-address 10.10.13.38 <----------------2nd DHCP Server


interface Vlan112
description VALN 112 Data
ip address 10.10.112.1 255.255.255.0
ip helper-address 10.10.13.38 <----------------2nd DHCP Server
ip helper-address 10.10.13.57 <----------------1st DHCP Server

I hope this helps you.

Mike

Review Cisco Networking products for a $25 gift card