Can't get into rommon

Unanswered Question
Sep 3rd, 2010


I upgraded four 3560E, 12.2(44) to 12.2(55)SE
Three 3560 works fine, the last one stops after 17-18 seconds with a solid green LED.

I cant get into ROMmon, the switch doesn't boot up. its like "dead but still alive"

My TS:
1: Removed all SFPs.
2: Reseat PSU and fan moduls.
3: Replace PSU and fan modules.
4: Try to get into ROMmon.(pushing mode button and break seq.)

Startup LED:
0-1 seconds:
    SYST: Amber
    RPS: Amber
    STAT: Green
    DUPLEX: Green
    SPEED: Green

1-17 seconds
    SYST: Blinking Green
    RPS: OFF

18 s--> (only testet up to one hour)
    SYST: Solid Green
    RPS: OFF

A working 3560E
Startup LED information
If I compare a working switch with the faulty switch I can see about 18 seconds into booting
SYST change very fast from green to amber and continues with booting,
this doesnt happend on the faulty switch (solid green 18 seconds).
Pushing MODE button, doesn't get me in to ROMmon, this works for all the other switches.
On a normal 3560 it takes around 40 seconds before I get in to ROMmon.
With this faulty switch it stops after 18 seconds(solid green) and it doesnt respond.

Would be nice if anyone could point me in the right direction


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Calin Chiorean Mon, 09/06/2010 - 03:40


You followed this procedure:

"Hold down the mode button located on the left side  of the front             panel, while you reconnect the power cable to the switch.

Release the Mode button after approximately 15  seconds when                           the SYST LED turns solid green. When you release the Mode                           button, the SYST LED blinks green."

and it's not working at all?

lamin.sonko Mon, 09/06/2010 - 03:53


Its correct, no response. I have several other switches were I can get into rommon without any problem.

lamin.sonko Mon, 09/06/2010 - 04:52


The switch is 2 years old and we don't have any smartnet/support, so no TAC case.

Calin Chiorean Mon, 09/06/2010 - 05:56

I did a little test with 2 C3560 to boot into rommon. One was reacting normal and after 40-60 seconds I was in the rommon mode. The other one needed aproximative 3 minutes to enter rommon. I thought that it's broken...

Then, strange characters started to appear on the screen...console speed was set to 115200.

So, before throw it away, try to let it a little bit more time to enter the rommon and play with the Serial port Baud rate.

Maybe it help. If not...I don't know

lamin.sonko Mon, 09/06/2010 - 06:04

Hi I tried All available BAUD rates in Putty. I think it was from 300 - 115200.

negative result. I tried with hyperterminal, putty and secureCRT.

YFadahunsi Tue, 08/07/2012 - 13:13

For what it is worth as I know the 'real problem' has been solved now but but you simply need to change the baud rate back to 9600 on your terminal client. the router's bad rate gets reset when you reset the switch by pressing down on the mode button. So effectively if you have been working on 115200 previously like I was when the router when bad, I then pressed the mode button to reset the switch and boot into rmon mode, I simply then need to remember to chage my client settings to connect at 9600 now instead of the 115200.


This Discussion

Related Content