ASA firewall 5505 blocks VPN PPTP

Unanswered Question
Sep 2nd, 2010

Hi,

I have a VPN PPTP session on my PC, however as soon as I have installed a firewall ASA 5505 ver. 8x on

my company's network I'm NOT able to connect outside on my PPTP server.

Please see my configuration below and let me know for any suggestions. Thank you very much for your time.


ASA Version 8.2(1)
!
hostname MUSKITA
enable password xxxxxxxxxxxxx encrypted
passwd xxxxxxxxxxxxx encrypted
names
!
interface Vlan1
nameif inside
security-level 100
ip address 192.168.5.252 255.255.255.0
!
interface Vlan2
nameif outside
security-level 0
ip address x.x.x.45 255.255.255.252
!
interface Ethernet0/0
switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
ftp mode passive
clock timezone EEST 2
clock summer-time EEDT recurring last Sun Mar 3:00 last Sun Oct 4:00
dns domain-lookup inside
dns domain-lookup outside
same-security-traffic permit inter-interface
same-security-traffic permit intra-interface
access-list outside_access_in extended permit tcp any host x.x.x.45 eq pop3

access-list outside_access_in extended permit tcp any host x.x.x.45 eq https

access-list outside_access_in extended permit tcp any host x.x.x.45 eq www
access-list outside_access_in extended permit tcp host x.x.x.146 host x.x.x.45 eq 3389
access-list outside_access_in remark RMD DN
access-list outside_access_in extended permit tcp x.x.x.192 255.255.255.224 host x.x.x.45 eq 3389
access-list outside_access_in extended permit tcp any host x.x.x.45 eq ftp
access-list VPN_splitTunnelAcl standard permit 192.168.5.0 255.255.255.0
access-list inside_nat0_outbound extended permit ip 192.168.5.0 255.255.255.0 192.168.5.0 255.255.255.0
access-list inside_nat0_outbound extended permit ip 192.168.5.0 255.255.255.0 172.16.29.0 255.255.255.224
access-list REMOTE_splitTunnelAcl standard permit 192.168.5.0 255.255.255.0
access-list 101 extended permit gre any host x.x.x.13
access-list 101 extended permit tcp any host x.x.x.13
pager lines 24
logging enable
logging asdm informational
mtu inside 1500
mtu outside 1500
ip local pool VPN 172.16.29.1-172.16.29.20 mask 255.255.255.0
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 1 0.0.0.0 0.0.0.0
static (inside,outside) tcp interface 3389 192.168.5.4 3389 netmask 255.255.255.255
static (inside,outside) tcp interface pop3 192.168.5.4 pop3 netmask 255.255.255.255
static (inside,outside) tcp interface https 192.168.5.4 https netmask 255.255.255.255
static (inside,outside) tcp interface www 192.168.5.4 www netmask 255.255.255.255
static (inside,outside) tcp interface ftp 192.168.5.4 ftp netmask 255.255.255.255
access-group 101 in interface outside
route outside 0.0.0.0 0.0.0.0 x.x.x.46 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
dynamic-access-policy-record DfltAccessPolicy
http server enable
http 192.168.1.0 255.255.255.0 inside
http 192.168.5.0 255.255.255.0 inside
http x.x.x.192 255.255.255.224 outside
http x.x.x.146 255.255.255.255 outside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac
crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac
crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac
crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac
crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set transform-set ESP-AES-128
-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256
-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5
crypto map outside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
crypto map outside_map interface outside
crypto isakmp enable outside
crypto isakmp policy 10
authentication pre-share
encryption 3des
hash sha
group 2
lifetime 86400
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd auto_config outside
!

threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn
group-policy REMOTE internal
group-policy REMOTE attributes
dns-server value 192.168.5.4
vpn-tunnel-protocol IPSec
split-tunnel-policy tunnelspecified
split-tunnel-network-list value REMOTE_splitTunnelAcl
username xxxx password xZ16ZWBXZLVt4Tfb encrypted privilege 0
username xxxxx attributes
vpn-group-policy REMOTE
tunnel-group REMOTE type remote-access
tunnel-group REMOTE general-attributes
address-pool VPN
default-group-policy REMOTE
tunnel-group REMOTE ipsec-attributes
pre-shared-key *
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map global_policy
class inspection_default
  inspect pptp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:c069370f545193c16b84275f64bb32a4
: end

Regards

Leon

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
leonnikolaou Thu, 09/02/2010 - 12:27

Hi MS and thanks for your quick reply.

I have only one PPTP session and my nat is configured as shown below:

access-list inside_nat0_outbound extended permit ip 192.168.5.0 255.255.255.0 192.168.5.0 255.255.255.0
access-list inside_nat0_outbound extended permit ip 192.168.5.0 255.255.255.0 172.16.29.0 255.255.255.224

nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 1 0.0.0.0 0.0.0.0

Thanks

Federico Coto F... Thu, 09/02/2010 - 15:08

Hi,

You're trying to establish a PPTP connection from inside the ASA to a PPTP server on the outside?

The ASA is doing PAT?

If this is so, you should change the fixup for the

policy-map global_policy
class inspection_default

  inspect pptp

The inspection for PPTP will handle the TCP port for the control channel and managing the GRE tunnel.

If the version announced is not PPTPv1, it's not suppoted.

Federico.

leonnikolaou Thu, 09/02/2010 - 22:26

Hi Federico,

Thanks for your reply, I have tried already these commands

policy-map global_policy
class inspection_default
  inspect pptp

but still not working.

Basically, as soon as I configured the fixup protocol pptp command the firewall automatically initiated the above commands.

Thanks for your time.

Federico Coto F... Fri, 09/03/2010 - 07:40

I think the best way to find out exactly why is not working you can do a capture:

capture capin interface inside match ip any host

capture capout interface outside match ip any host

Federico.

leonnikolaou Fri, 09/03/2010 - 10:39

Hi Federico,

thanks a lot for your help.

I would do that next week and I 'll let you know.

Thanks again.

Leon

Actions

This Discussion