Cisco 2960S supplying PoE to 4507-R

Unanswered Question
Sep 7th, 2010
User Badges:

Hey Everyone,


I've come across a peculiar issue on a WS-C2960S-48FPD-L where it is supplying PoE to it's neighbour a WS-C4507R. This seems to cause the etherchannel between the two devices to fluctuate during initial connection shortly after booting. You can see what I mean from the log below:


Sep  6 19:09:40: %ILPOWER-7-DETECT: Interface Gi1/0/4: Power Device detected: IEEE PD
Sep  6 19:09:41: %ILPOWER-5-POWER_GRANTED: Interface Gi1/0/4: Power granted
Sep  6 19:09:57: %ILPOWER-7-DETECT: Interface Gi1/0/1: Power Device detected: IEEE PD
Sep  6 19:09:58: %ILPOWER-5-POWER_GRANTED: Interface Gi1/0/1: Power granted
Sep  6 19:10:46: %ILPOWER-7-DETECT: Interface Gi2/0/3: Power Device detected: IEEE PD (EDI_EX2960S-1-2)
Sep  6 19:10:47: %ILPOWER-5-POWER_GRANTED: Interface Gi2/0/3: Power granted (EDI_EX2960S-1-2)
Sep  6 19:11:09: %ILPOWER-7-DETECT: Interface Gi1/0/2: Power Device detected: IEEE PD
Sep  6 19:11:10: %ILPOWER-5-POWER_GRANTED: Interface Gi1/0/2: Power granted
Sep  6 19:11:55: %ILPOWER-7-DETECT: Interface Gi2/0/4: Power Device detected: IEEE PD (EDI_EX2960S-1-2)
Sep  6 19:11:57: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet2/0/4, changed state to down
Sep  6 19:11:58: %LINK-3-UPDOWN: Interface GigabitEthernet2/0/4, changed state to down
Sep  6 19:11:56: %ILPOWER-5-IEEE_DISCONNECT: Interface Gi2/0/4: PD removed (EDI_EX2960S-1-2)
Sep  6 19:12:04: %LINK-3-UPDOWN: Interface GigabitEthernet2/0/4, changed state to up
Sep  6 19:12:06: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet2/0/4, changed state to up
Sep  6 19:14:09: %ILPOWER-7-DETECT: Interface Gi1/0/3: Power Device detected: IEEE PD
Sep  6 19:14:11: %ILPOWER-5-POWER_GRANTED: Interface Gi1/0/3: Power granted
Sep  6 19:14:32: %ILPOWER-7-DETECT: Interface Gi2/0/1: Power Device detected: IEEE PD (EDI_EX2960S-1-2)
Sep  6 19:14:33: %ILPOWER-5-IEEE_DISCONNECT: Interface Gi2/0/1: PD removed (EDI_EX2960S-1-2)
Sep  6 19:14:34: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet2/0/1, changed state to down
Sep  6 19:14:35: %LINK-3-UPDOWN: Interface GigabitEthernet2/0/1, changed state to down
Sep  6 19:14:41: %LINK-3-UPDOWN: Interface GigabitEthernet2/0/1, changed state to up
Sep  6 19:14:43: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet2/0/1, changed state to up
Sep  6 19:16:50: %STACKMGR-4-STACK_LINK_CHANGE: Stack Port 2 Switch 1 has changed to state DOWN
Sep  6 19:16:50: %STACKMGR-4-STACK_LINK_CHANGE: Stack Port 2 Switch 2 has changed to state DOWN
Sep  6 19:18:58: %ILPOWER-7-DETECT: Interface Gi2/0/1: Power Device detected: IEEE PD (EDI_EX2960S-1-2)
Sep  6 19:18:59: %ILPOWER-5-POWER_GRANTED: Interface Gi2/0/1: Power granted (EDI_EX2960S-1-2)
Sep  6 19:20:51: %ILPOWER-7-DETECT: Interface Gi2/0/4: Power Device detected: IEEE PD (EDI_EX2960S-1-2)
Sep  6 19:20:52: %ILPOWER-5-IEEE_DISCONNECT: Interface Gi2/0/4: PD removed (EDI_EX2960S-1-2)
Sep  6 19:20:53: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet2/0/4, changed state to down
Sep  6 19:20:54: %LINK-3-UPDOWN: Interface GigabitEthernet2/0/4, changed state to down
Sep  6 19:21:00: %LINK-3-UPDOWN: Interface GigabitEthernet2/0/4, changed state to up
Sep  6 19:21:02: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet2/0/4, changed state to up
Sep  6 19:24:10: %ILPOWER-7-DETECT: Interface Gi2/0/4: Power Device detected: IEEE PD (EDI_EX2960S-1-2)
Sep  6 19:24:11: %ILPOWER-5-POWER_GRANTED: Interface Gi2/0/4: Power granted (EDI_EX2960S-1-2)
Sep  6 19:27:25: %STACKMGR-4-STACK_LINK_CHANGE: Stack Port 2 Switch 1 has changed to state UP
Sep  6 19:27:25: %STACKMGR-4-STACK_LINK_CHANGE: Stack Port 2 Switch 2 has changed to state UP


Here is the ouput from a "show power inline":


--------- ------ ---------- ------- ------------------- ----- ----
Gi1/0/1   auto   on         15.4    WS-C4507R-E         0     30.0
Gi1/0/2   auto   on         15.4    WS-C4507R-E         0     30.0
Gi1/0/3   auto   on         15.4    WS-C4507R-E         0     30.0
Gi1/0/4   auto   on         15.4    WS-C4507R-E         0     30.0


The above interfaces are members of two etherchannels to two separate 4507Rs. I can deactivate the PoE with the "power inline never" command and the interfaces remain normal.


My query, if anyone knows the answer, is why it is even supplying PoE to the 4507 in the first place?


The 2960s are in a stack of two using the stacking modules and are running 12.2(55)SE code.

The 4507s are running 12.2(54)SG code, ad the connecting blades are WS-X4648-RJ45V+E's.


I should also note that no power is being supplied by the 4507s.


Cheers,


James McMichael

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
vvasisth Tue, 09/07/2010 - 03:20
User Badges:
  • Silver, 250 points or more

personally i have never seen such an issue

please let me know what IOS are you running on the switches

when did you see this issue 1st time ?

any changes made ?

send me the port config as well for those ports



Regards,

Varun

James McMichael Tue, 09/07/2010 - 03:44
User Badges:

Hello Varun,


Thanks for the speedy reply.


The 2960Ss are running 12.2(55)SE on universalk9, and the 4507s are running 12.2(54)SG on ipbasek9.


Below is the config for the interfaces on the 2960:


interface GigabitEthernet1/0/1
description *** Link to EDI_EX4507-1 (Local Port-Channel1) ***
switchport trunk native vlan 1351
switchport trunk allowed vlan 129-132,137,138,140,141,1311,1351,1402
switchport mode trunk
mls qos trust dscp
channel-group 1 mode on

!
interface GigabitEthernet1/0/2
description *** Link to EDI_EX4507-1 (Local Port-Channel1) ***
switchport trunk native vlan 1351
switchport trunk allowed vlan 129-132,137,138,140,141,1311,1351,1402
switchport mode trunk
mls qos trust dscp
channel-group 1 mode on

!
interface GigabitEthernet1/0/3
description *** Link to EDI_EX4507-2 (Local Port-Channel2) ***
switchport trunk native vlan 1351
switchport trunk allowed vlan 129-132,137,138,140,141,1311,1351,1402
switchport mode trunk
mls qos trust dscp
channel-group 2 mode on

!
interface GigabitEthernet1/0/4
description *** Link to EDI_EX4507-2 (Local Port-Channel2) ***
switchport trunk native vlan 1351
switchport trunk allowed vlan 129-132,137,138,140,141,1311,1351,1402
switchport mode trunk
mls qos trust dscp
channel-group 2 mode on
!
interface GigabitEthernet2/0/1
description *** Link to EDI_EX4507-1 (Local Port-Channel1) ***
switchport trunk native vlan 1351
switchport trunk allowed vlan 129-132,137,138,140,141,1311,1351,1402
switchport mode trunk
mls qos trust dscp
channel-group 1 mode on
!
interface GigabitEthernet2/0/2
description *** Link to EDI_EX4507-1 (Local Port-Channel1) ***
switchport trunk native vlan 1351
switchport trunk allowed vlan 129-132,137,138,140,141,1311,1351,1402
switchport mode trunk
mls qos trust dscp
channel-group 1 mode on
!
interface GigabitEthernet2/0/3
description *** Link to EDI_EX4507-2 (Local Port-Channel2) ***
switchport trunk native vlan 1351
switchport trunk allowed vlan 129-132,137,138,140,141,1311,1351,1402
switchport mode trunk
mls qos trust dscp
channel-group 2 mode on
!
interface GigabitEthernet2/0/4
description *** Link to EDI_EX4507-2 (Local Port-Channel2) ***
switchport trunk native vlan 1351
switchport trunk allowed vlan 129-132,137,138,140,141,1311,1351,1402
switchport mode trunk
mls qos trust dscp
channel-group 2 mode on

!

interface Port-channel1
description *** Link to EDI_EX4507-1 ***
switchport trunk native vlan 1351
switchport trunk allowed vlan 129-132,137,138,140,141,1311,1351,1402
switchport mode trunk

!
interface Port-channel2
description *** Link to EDI_EX4507-2 ***
switchport trunk native vlan 1351
switchport trunk allowed vlan 129-132,137,138,140,141,1311,1351,1402
switchport mode trunk


The following is the config on one of the 4507s


interface GigabitEthernet6/45
description *** EtherChannel Link to EDI_EX2960S-1 ***
switchport trunk native vlan 1351
switchport trunk allowed vlan 129-132,137,138,140,141,1311,1351,1402
switchport mode trunk
channel-group 4 mode on
service-policy output VoIP-Output-Queuing-Policy
!
interface GigabitEthernet6/46
description *** EtherChannel Link to EDI_EX2960S-1 ***
switchport trunk native vlan 1351
switchport trunk allowed vlan 129-132,137,138,140,141,1311,1351,1402
switchport mode trunk
channel-group 4 mode on
service-policy output VoIP-Output-Queuing-Policy
end

!

interface GigabitEthernet7/45
description *** EtherChannel Link to EDI_EX2960S-1 ***
switchport trunk native vlan 1351
switchport trunk allowed vlan 129-132,137,138,140,141,1311,1351,1402
switchport mode trunk
channel-group 4 mode on
service-policy output VoIP-Output-Queuing-Policy

!
interface GigabitEthernet7/46
description *** EtherChannel Link to EDI_EX2960S-1 ***
switchport trunk native vlan 1351
switchport trunk allowed vlan 129-132,137,138,140,141,1311,1351,1402
switchport mode trunk
channel-group 4 mode on
service-policy output VoIP-Output-Queuing-Policy

!
interface Port-channel4
description *** Link to EDI_EX2960S-1 ***
switchport
switchport trunk native vlan 1351
switchport trunk allowed vlan 129-132,137,138,140,141,1311,1351,1402
switchport mode trunk
service-policy input VoIP-Input-Dscp-Policy
service-policy output VoIP-Po2-Output-Policing-Marking-Policy


Cheers,


James McMichael

James McMichael Tue, 09/07/2010 - 04:06
User Badges:

The issue occured yesterday after we installed the stacking modules and rebooted the stack.


Prior to this the two 2960s where connected separately to the core switches, so the etherchannels have been reconfigured.


It is likely that this issue was always present, but as our engineer was connected to the switches at the time he noticed the issue as it occurred.

Actions

This Discussion