Cisco 7940 Hard Reset

Unanswered Question
Sep 7th, 2010
User Badges:

Hello,


We have some Cisco IP 7940 phones configured for a network.

And we would like to make a hard reset in order to use them in another network.

Please could you help us to do so

We tested the 2 methods below without success.

Thanks in advance




We tried this:

  1. Press ***#* in order to unlock Network Configuration on the phone.
   2. Press *Settings*.
   3. Press *3* on the keypad (or scroll down) for Network Configuration.
   4. Press *33* on the keypad (or scroll down) for Erase Configuration.
  5. Press the *Yes* softkey.
   6. Press the *Save* softkey.


And we tried also this:

  1. Unplug the power cable from the phone, and then plug in the cable             again.

    The phone begins its power up cycle.

  2. Immediately press and hold # and while the Headset, Mute, and             Speaker buttons begin to flash in sequence, release #.

    The Headset, Mute, and Speaker buttons flash in sequence in order             to indicate that the phone waits for you to enter the key sequence for the             reset.

  3. Press 123456789*0# within 60 seconds after the             Headset, Mute, and Speaker buttons begin to flash.

    If you repeat a key within the sequence, for example, if you press             1223456789*0#, the sequence is still accepted and the phone resets.

    If you do not complete this key sequence or do not press any keys,             after 60 seconds, the Headset, Mute, and Speaker buttons no longer flash, and             the phone continues with its normal startup process. The phone does not reset.

    If you enter an invalid key sequence, the buttons no longer flash,             and the phone continues with its normal startup process. The phone does not             reset.

    If you enter this key sequence correctly, the phone displays this             prompt:

    Keep network cfg? 1 = yes             2 = no

  4. In order to maintain the current network configuration settings for             the phone when the phone resets, press 1. In order to reset             the network configuration settings when the phone resets, press 2.

    If you press another key or do not respond to this prompt within 60             seconds, the phone continues with its normal startup process and does not             reset. Otherwise, the phone goes through the factory reset process.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Aaron Harrison Tue, 09/07/2010 - 06:33
User Badges:
  • Super Bronze, 10000 points or more
  • Community Spotlight Award,

    Member's Choice, May 2015

Hi


In general (that is, unless you have a secure cluster - i.e. you are using encryption and authentication, have configured CAPF etc using the USB security tokens) you don't need to reset anything on the phones to move them. Move them to the new network, new IP and TFTP server settings should be assigned by the new DHCP server, and new firmware should be loaded.


If you do want to reset settings, the first procedure you listed is a little incorrect; it's more likely to be as follows:


Press *Settings*.
Scroll down to Network Configuration and select it

Press **# in order to unlock Network Configuration on the phone.

Scroll down to Erase Configuration.
Press the *Yes* softkey.
Press the *Save* softkey.


The other factory reset proc you posted looks more or less right.


Either way, since your IP and option 150 settings come from DHCP and the rest of the config from your CCM, it will download the same settings after you have reset it anyway.


Regards


Aaron


Please rate helpful posts...

Tracy Larson Tue, 09/07/2010 - 08:01
User Badges:
  • Silver, 250 points or more

Depending on how you have your cluster setup, you may also have to delete the CTL file under your security options.

Andrew Zenz Tue, 09/28/2010 - 22:38
User Badges:

Hi, I am having the same issue, can't reset the phone with either method.


As far as a hard reset goes, when I power the phone on, the Mute light is the only illuminated light, followed a few seconds later by a very, very brief flash of the speaker light.  The screen then displays the Cisco logo and away it goes.  I do not get the Headset, Mute and Speaker lights flashing in sequence.


I have also tried a factory reset via the softkeys with no success.


As with the original poster, we are moving VoIP providers (networks) and need to undertake some testing beforehand.


I noticed that this thread did not have a solution, hoping this might prompt someone.


Cheers,

Aaron Harrison Wed, 09/29/2010 - 00:45
User Badges:
  • Super Bronze, 10000 points or more
  • Community Spotlight Award,

    Member's Choice, May 2015

Hi


The thread does have solutions...


The 'soft' method by the menus varies slightly depending on model/firmware, but the principal is the same - use **# when in the network settings to 'unlock' the settings (padlock icon will change) and then find the erase option... and then if required also erase the security settings as Tracy suggested.


The hard method is as described -


1) Attach power cable or powered ethernet whilst holding down #

2) Continue holding until the phone indicates it's acceptance- depending on models this can be a flashing MWI light, a sequence of the headset/speaker/mute buttons, or 'reset sequence detected' on the LCD. It can take a good few seconds for this to happen, so keep holding.

3) When it's ready, dial 123456789*0# and then it may ask whether to keep some settings, tell it no. You don't have to do this 123.. bit quickly, but if you hit a wrong key it will just boot normally so type carefully.


Regards


Aaron

Andrew Zenz Wed, 09/29/2010 - 15:35
User Badges:

Hi Aaron,


Yes, you're right, the thread does have solutions, it just isn't marked as answered.


I have powered on the phone with the # button pressed and held it there for a few minutes, nothing.  No acceptance messages, no messages indicating it might want to reset, nada.


As stated previoulsy, the Mute light illuminates follwed by a very brief flash of the speaker light then the usual boot up process; Cisco logo and the message Conviguring VLAN.


Is it possible to 'lock' the phones so that they cannot be changed?

Must I have the phone on the original network in order to effect a change?


Thanks for you help - still noob to Cisco gear.

Paolo Bevilacqua Wed, 09/29/2010 - 23:43
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

This phone may have been used with a MGCP configuration and been locked.


Then recovering it's much more difficult, you have try emulating the registration process and see if you can get to the point where are an unlocking configuration can be feed into the phone.


I can not give more details that that and if you do not have a long time to spend on it, recommend move one to another phone/

sflanagan Thu, 05/31/2012 - 14:26
User Badges:

Use this at your own risk.


I was going through the same thing. I still have not been able to figure out how to factory reset the phone however, I was able to unlock it.


I use a tftpserver to download the configuration files to the phones. So after searching the internet and only finding the aforementioned solutions (which weren't working) I finaly found this

http://www.cisco.com/en/US/docs/voice_ip_comm/cuipph/7960g_7940g/sip/8_0/english/administration/guide/sipins80.html#wp1127295


If you do a find for phone_password:  you will see that one of the variables in the .cnf file is phone_password:

I set the password in the cnf file and rebooted the phone.

I then was able to let the phone boot and get into settings and unlock the configuration. It isn't factory reset however I can now configure the phone the way I needed.


I did notice on my particular 7940 there isn't a number 33 but a # 28 "erase configuration"


Hope this helps someone.


Have a nice day,

Flan

John Mayer Sun, 10/14/2012 - 08:03
User Badges:

hello everyone

did some one could solve this problem, i'm already have this problem,

i test every methid on my 7940 but it still have its original config, even i put my tftp server and ip address in phone

Actions

This Discussion