B-ACD que hangs up on calls

Unanswered Question
Sep 7th, 2010

I've set up a B-ACD que with one member, when the hunt timeout ends the "All agents busy" prompt plays and then the call disconnects. I would like it to continue to hunt on the member until the phone is picked up. Have I missed something in the config or is there something wrong?

Here's the application config:

service aaservice0 flash:/bacdprompts/app-b-acd-aa-
  param aa-pilot 352
  paramspace english index 0
  param second-greeting-time 30
  paramspace english language en
  param call-retry-timer 15
  param voice-mail 502
  param max-time-call-retry 600
  param service-name bacd
  param number-of-hunt-grps 1
  paramspace english location flash:/bacdprompts/
  param drop-through-option 1
  param handoff-string aaservice0
  param max-time-vm-retry 1
service bacd flash:/bacdprompts/app-b-acd-
  param number-of-hunt-grps 10
  param aa-hunt2 A360
  param queue-len 30
  param queue-cme-debugs 1
  param aa-hunt1 A352

Hunt group config:

ephone-hunt 50 sequential
pilot A352
list 501
timeout 14
no-reg pilot
statistics collect
description *** CCA BACD ***

"show ephone-hunt 50 stat" shows this. What makes the call abandoned?

Tue 17:00 - 18:00
    Max Agents: 1
    Min Agents: 1
    Queue related statistics:
      Total calls presented to the queue:  4
      Calls answered by agents:  0
      Number of calls in the queue:  0
      Average time to answer (secs):  0
      Longest time to answer (secs):  0
      Number of abandoned calls:  1
      Average time before abandon (secs):  30
      Calls forwarded to voice mail:  0
      Calls answered by voice mail:  0

Best regards


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Steven Holl Wed, 09/08/2010 - 07:14

You have 10 hunt groups defined in the queue, but only one defined in the aa, and you are actually only pointing to a single hunt group.    param number-of-hunt-grps should match the amount of aahunt options you have configured, and should be the same in both the aa and the queue.

Ensure that you have MOH configured on CME, as well.

Since you didn't include your whole configuration, I assume that your ephone-hunt pilot is configured for A352?

Typically 'paramspace english index 0' is specified instead of 'paramspace english index 1'.  Is there a reason why you have index 1 configured instead of 0?

Be sure to restart the whole application after you make parameter changes, so that they take effect, too.

m.junghage Thu, 09/09/2010 - 00:19

Interesting, now when I think about it it did work before I removed MoH. Will add it back in to se how it reacts.

"Typically 'paramspace english index 0' is specified instead of  'paramspace english index 1'.  Is there a reason why you have index 1  configured instead of 0?"

No idea, it's all configured using the CCA. Could it be that the UC is localized to Swedish?

Best regards


Steven Holl Thu, 09/09/2010 - 06:31

MOH is a requirement for BACD to work.  That's mentioned in the BACD config guide.  So if you removed MOH, adding it back in should fix it.