Config pix501 for access client

Answered Question
Sep 7th, 2010
User Badges:

Hi

I have a pix 501. This is the information



Cisco PIX Firewall Version 6.3(5)

Cisco PIX Device Manager Version 3.0(4)


My configuration is:
pix501(config)# sh conf
: Saved
: Written by enable_15 at 19:38:00.558 CEDT Tue Sep 7 2010
PIX Version 6.3(5)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password XXXXXXXXXXXX encrypted
passwd XXXXXXXXXXXX encrypted
hostname pix501
domain-name mydomain.com
clock timezone CEST 1
clock summer-time CEDT recurring last Sun Mar 2:00 last Sun Oct 3:00
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list ping_acl permit icmp any any
access-list VPNSplit permit ip 10.0.0.0 255.255.0.0 any
access-list inside_outbound_nat0_acl permit ip 10.0.0.0 255.255.0.0 10.1.1.0 255.255.255.0
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside 192.168.1.254 255.255.255.0
ip address inside 10.0.0.254 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool poolVPN_Home 10.1.1.100-10.1.1.200 mask 255.255.255.0
pdm location 10.0.0.100 255.255.255.255 inside
pdm location 0.0.0.0 255.255.255.0 outside
pdm location 10.1.1.0 255.255.255.0 outside
pdm location 10.0.0.102 255.255.255.255 inside
pdm location 10.0.0.101 255.255.255.255 inside
pdm location 10.0.0.107 255.255.255.255 inside
pdm location 10.0.0.0 255.255.0.0 inside
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_outbound_nat0_acl
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
access-group ping_acl in interface outside
route outside 0.0.0.0 0.0.0.0 192.168.1.1 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout sip-disconnect 0:02:00 sip-invite 0:03:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
http server enable
http 192.168.1.0 255.255.255.0 outside
http 10.0.0.100 255.255.255.255 inside
http 10.0.0.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
sysopt ipsec pl-compatible
auth-prompt prompt Prompt
auth-prompt accept Accepted
auth-prompt reject Reject
crypto ipsec transform-set setVPN_Home esp-3des esp-sha-hmac
crypto dynamic-map mapDinVPN_Home 4 set transform-set setVPN_Home
crypto map mapVPN_Home 20 ipsec-isakmp dynamic mapDinVPN_Home
crypto map mapVPN_Home client configuration address initiate
crypto map mapVPN_Home client configuration address respond
crypto map mapVPN_Home client authentication LOCAL
crypto map mapVPN_Home interface outside
isakmp enable outside
isakmp key XXXXXXXXXXXXX address 0.0.0.0 netmask 0.0.0.0
isakmp policy 8 authentication pre-share
isakmp policy 8 encryption 3des
isakmp policy 8 hash md5
isakmp policy 8 group 2
isakmp policy 8 lifetime 86400
vpngroup gruppoVPN_Home address-pool poolVPN_Home
vpngroup gruppoVPN_Home dns-server 8.8.8.8
vpngroup gruppoVPN_Home wins-server 192.168.1.1
vpngroup gruppoVPN_Home default-domain mydomain.com
vpngroup gruppoVPN_Home split-dns mydomain.com
vpngroup gruppoVPN_Home idle-time 1800
vpngroup gruppoVPN_Home password XXXXXXXXXXXXX
telnet 192.168.1.0 255.255.255.0 outside
telnet 10.0.0.0 255.255.255.0 inside
telnet timeout 20
ssh 0.0.0.0 0.0.0.0 outside
ssh timeout 20
console timeout 0
dhcpd address 10.0.0.100-10.0.0.200 inside
dhcpd dns 192.168.1.1 8.8.8.8
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd auto_config outside
dhcpd enable inside
username test password XXXXXXXXXXXXX encrypted privilege 3
username diego password XXXXXXXXXXXXX encrypted privilege 15
terminal width 80
banner exec Session Banner
banner login Login Banner
Cryptochecksum:XXXXXXXXXXXXX
pix501(config)#
My problem is: when client connect to vpn with vpn client 5.0.07, have ip but don't go on internet
Can you halp me?
Thank you
Correct Answer by Nagaraja Thanthry about 6 years 8 months ago

Hello,


Please try the following line in the configuration:


nat (outside) 1 10.1.1.0 255.255.255.0


Hope this helps.


Regards,


NT

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Federico Coto F... Tue, 09/07/2010 - 10:59
User Badges:
  • Green, 3000 points or more

Hi,


Your problem is that the VPN client connects but it loses Internet?

If that's so, you need to configure split-tunneling.


You add under:

vpngroup gruppoVPN_Home

a reference to ACL VPNSplit


Federico.

rdie121977 Tue, 09/07/2010 - 11:13
User Badges:

Yes, VPN client connects but it loses Internet and remote intranet


This?

vpngroup gruppoVPN_Home split-tunnel VPNSplit

Correct Answer
Nagaraja Thanthry Tue, 09/07/2010 - 11:00
User Badges:
  • Cisco Employee,

Hello,


Please try the following line in the configuration:


nat (outside) 1 10.1.1.0 255.255.255.0


Hope this helps.


Regards,


NT

rdie121977 Tue, 09/07/2010 - 11:34
User Badges:


For this command:


pix501(config)# nat (outside) 1 10.1.1.0 255.255.255.0

WARNING:  Binding inside nat statement to outermost interface.

WARNING:  Keyword "outside" is probably missing.

but insert the command but dont work :-(

Actions

This Discussion