cme 4.3 on a cisco 3745

Unanswered Question
Sep 7th, 2010

Hi Guys; Has anyone tried to install cme 4.3 on a cisco 3745 ? If so which IOS version have you tried. I am stuck trying to install cme 4.3 on a 3745 and can not find the right ios. It is for the ccna voice labs. Ram 256, flash 128.

Cheers.

Fereidoun.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
fereidoun.fatahiany Tue, 09/07/2010 - 18:09

Hi ashar; I tried it before but it hangs and c

an't create the right directories.  I even

tried it on c 2691 and c 2561XM still . I have not managed to find the right IOS for none of them.

Fereidoun.

tariq khan Tue, 09/07/2010 - 18:20

Dear,

What exactly is the error and problem that you are facing? are you using the supported IOS?

Tariq Khan.

fereidoun.fatahiany Thu, 09/09/2010 - 07:02

Hi Tariq ; It tends to miss opening some directories a

nd hanging in middle of installing the ephone directories

The 12.4(15)XZ  is not available on cisco's site.  I ma totally stuck now.

fereidoun.fatahiany Sun, 09/12/2010 - 12:31

Hi Tariq: I have managed to install cme gui 7.0

on 3745 with the recent ios, but I don't know how to

create directories like phone and others to upload the files in them.

Can you help please.

Kind regards.

Fereidoun.

Steven Holl Thu, 09/09/2010 - 11:21

The last platform which supports the 3745 for CME is 4.2 (12.4(11)XW throttle).  CME 4.3 does not support the 3745, as per this document:

http://www.cisco.com/en/US/docs/voice_ip_comm/cucme/requirements/guide/33matrix.htm

Your options are to either run CME 4.2, or get hardware which supports more recent CME releases.  That platform can't handle the feature set of newer IOS code.

fereidoun.fatahiany Thu, 09/09/2010 - 12:25

Hi; Thank you for your comment. I think I am starting to think your way. But

can't find the 12.4(11)xw and cisco won't guide me for any other IOS to

download. Would you know which IOS would do the job please?

Thanks.

Fereidoun.

On 9 September 2010 19:21, sholl

fereidoun.fatahiany Fri, 09/10/2010 - 04:09

Hi;  I tried it but it didn't work. So I installed the GUI 7.0.0.1 and it worked with the latest " ipvoice ios version". This is after going through every IOS and cme available. I even increased the internal compact flash to 1GIG and still no good. This is all because of misleading info by cisco on compatibility matrix list for CME 4.3 and CME 7.0 that I bought the cheaper 3745, otherwise I could have bought the 2811 instead.

The IOS is : 3745-ipvoicek9-mz.124-25d.bin

Now I need to find out how I can make the right directories like "phone, "desktop " and so on and put the right data in them to work smoothly.

Do you have any suggestions please. ?

Kind regards.

Fereidoun.

Steven Holl Fri, 09/10/2010 - 06:51

You don't need to make directories for the phone firmware, html, etc.  You can throw everything in the root of flash and things will work (just be carefule that you don't have so many files that you run out of root entries on flash).  If you want to put things in a folder:

Router# mkdir test
Create directory filename [test]?
Created dir flash:test

Router# copy ftp flash:/test/destination-filename

If you read the CME configuration guide, it does a good job at explaining the procedure for initial CME configuration.

And I fail to see how the CME matrix is incorrect.  I was able to run CME 4.2 on a 3745 running 12.4(11)XW7.  That's the latest version of CME and IOS you'll ever get on this box:

F340.04.24-3700-4#sh ver

Cisco IOS Software, 3700 Software (C3745-IPVOICE-M), Version 12.4(11)XW7, RELEASE SOFTWARE (fc2)

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 1986-2008 by Cisco Systems, Inc.

Compiled Tue 08-Apr-08 22:37 by prod_rel_team

ROM: System Bootstrap, Version 12.2(8r)T2, RELEASE SOFTWARE (fc1)

F340.04.24-3700-4 uptime is 2 minutes

System returned to ROM by reload

System image file is "flash:c3745-ipvoice-mz.124-11.XW7"

Cisco 3745 (R7000) processor (revision 2.0) with 239616K/22528K bytes of memory.

Processor board ID JMX0729L6A0

R7000 CPU at 350MHz, Implementation 39, Rev 3.3, 256KB L2, 2048KB L3 Cache

2 FastEthernet interfaces

1 ATM interface

1 ATM/Voice AIM

DRAM configuration is 64 bits wide with parity disabled.

151K bytes of NVRAM.

125184K bytes of ATA System CompactFlash (Read/Write)

62720K bytes of ATA Slot0 CompactFlash (Read/Write)

F340.04.24-3700-4#conf t

Enter configuration commands, one per line.  End with CNTL/Z.

F340.04.24-3700-4(config)#telew

F340.04.24-3700-4(config)#tele

F340.04.24-3700-4(config)#telephony-service

F340.04.24-3700-4(config-telephony)#do sh tele

F340.04.24-3700-4(config-telephony)#do sh telephony-s

CONFIG (Version=4.2(0))

=====================

Version 4.2(0)

Cisco Unified Communications Manager Express

For on-line documentation please see:

www.cisco.com/univercd/cc/td/doc/product/access/ip_ph/ip_ks/index.htm

ip source-address 0.0.0.0 port 2000

max-ephones 0

max-dn 0

max-conferences 8 gain -6

dspfarm units 0

dspfarm transcode sessions 0

conference software

hunt-group report delay 1 hours

hunt-group logout DND

max-redirect 5

cnf-file location: system:

cnf-file option: PER-PHONE-TYPE

network-locale[0] US   (This is the default network locale for this box)

network-locale[1] US

network-locale[2] US

network-locale[3] US

fereidoun.fatahiany Fri, 09/10/2010 - 09:39

Hi; This is getting a real thing . I

was getting an error message when I was configuring the upto ip source-address. So I changed everything to your spec and I am getting it again.

error deleting flash:sepdefault.cnf( no such file or directory )

error deleting flash:XMDefault.cnf.xml ( no such file or directory )

Can you help please.

Kind regards.

Fereidoun.

Steven Holl Fri, 09/10/2010 - 10:09

You get that error when doing what?  Can you send the output of:

sh run | s telephony|tftp

sh flash:

sh telephony-service tftp

fereidoun.fatahiany Fri, 09/10/2010 - 10:32

CME_TFTP_SERVER#sh run | s telephony|tftp

telephony-service

max-ephones 10

max-dn 10

ip source-address 172.16.1.1 port 2000

max-conferences 8 gain -6

CME_TFTP_SERVER#conf t

Enter configuration commands, one per line. End with CNTL/Z.

CME_TFTP_SERVER(config)#tele

CME_TFTP_SERVER(config)#telephony-service

CME_TFTP_SERVER(config-telephony)#ip source

CME_TFTP_SERVER(config-telephony)#ip source-address 172.16.1.1

%Error deleting flash:SEPDEFAULT.cnf (No such file or directory)

%Error deleting flash:XMLDefault.cnf.xml (No such file or directory)

CME_TFTP_SERVER(config-telephony)#

Hi ; This is what I get .

Fereidoun.

On 10 September 2010 18:10, sholl

Steven Holl Fri, 09/10/2010 - 13:31

You didn't obtain the output I requested in my last post.

Please collect the information I request if you want me to help you out with this.


That may be cosmetic, though.  Those files should be writing to a subfolder in system:/its/...

You need to define a DN, ephone, time-zone, and issue 'cre cnf' first, before those are built, though.

fereidoun.fatahiany Sun, 09/12/2010 - 07:10

Hi again; I did configure right up to ip sources address, then it throws up that error. As I am new in ccna voice I am following the ccna offical voice book. I don't know how to configure crf files. Further more there seems to be no \ phone\ directory on CME 4.2. How do I create an phone directory . I tried :

Router(config)#cd flash:

                    # mkdir phone

It does not accept.

I also tried

Router(config)# mkdir phone.  No Good.

Router(config)#mkdir flash:/phone/  Still no good.

This voice stuff is really picky on the ios and platform.

My last reply is the show command you wanted to see plus some more extras. More than that it just won't take.

Yours.

Fereidoun.

Steven Holl Mon, 09/13/2010 - 06:37

You still haven't provided me the output I requested to take a look at this:

I asked for the following:

sh run | s telephony|tftp

sh flash:

sh telephony-service tftp

And you've only provided me with the first command's output.

CME, by default, doesn't write CNF files to flash.  It will typically write them to system:its/vrf1/, but you can verify that with the 'sh telephony-service tftp' command.  You can do a 'dir' on the directory which it is aliasing the CNF files to and see if it is building the files.

Have you tried adding a  DN, ephone, time-zone, and then issue 'cre cnf' like I mentioned in the previous post?  Are you following the configuration steps as outlined in the CME Administration Guide?

fereidoun.fatahiany Fri, 09/17/2010 - 11:05

Hi Steven; I had a problem running the router as per your recommended IOS and CME full 4.2 . I am trying to install it again and then once I have configured it, I will send you. Sorry about this.

Fereidoun.

fereidoun.fatahiany Mon, 09/27/2010 - 05:34

Hi GUYS;

I managed to install the CME-full-7.1 on cisco 2691 and cisco 3745 and it works fine. I am new to cisco VOICE and it seems that it is not ripped properly yet. Too many loose ends. If anybody wants to know how please let me know and I will reply. P.S. You must have CCO account to dowload the right IOS and CME first.

One more thing; While I was configuring I couldn't get my two 7940's registered yet the softphones from two pc can register very easiely. Anybody knows why please?

Fereidoun.

Steven Holl Mon, 09/27/2010 - 05:45

It sounds like you applied the ZIP file for CME 7.1 onto the 2691 and 3745.  That isn't installing CME 7.1, it just has the supporting files for CME 7.1.  The CME version is directly tied to the version of IOS which you are running, and as I mentioned before, CME 4.2 is the latest you will get running on this platform.  You can verify with 'sh telephony-service'.

So you've actually applied the wrong CME GUI files to the system by using the CME-full-7.1 file.  You'll probably see issues with that.  You should use 12.4(11)XW and the CME 4.2 zip file on the 3745.

For your hard phone registration issue, it could be a few different issues.  Could be a config issue, network issue on the voice vlan, DHCP issue.  Please collect:

sh run

sh ephone ph

sh ip dhcp bind

And get this during a registration attempt:

debug tftp event

debug ephone register

debug ip dhcp server

Note the MAC of the phone not registering.

fereidoun.fatahiany Mon, 09/27/2010 - 07:52

Hi Steven;

Ok, you may think I am crazy, but here it goes. I tried the IOS you mentioned for 3745 and cme 4.2 , first it took it but it didn't create the right dirctories Ie, phone, and others so I tried again and this time it would not accept the 4.2 at all, very odd indeed. So ::::::

I borrowed and c2811 , installed a oldish IOS : ip servicesk9-mz.124-22.yb1.bin., then installed the cme-full 7.1 on it.  Pulled the compact flash out , stock it into a card reader and copied the files related to 7.1 onto the compact flash cards on 2691 and 3745.

So far no probelm, but I am booting from slot0: So I don't have to re-install the flash if I have to do it again. The cards must be formatted in fat files first before copying the flash and the CME files on them.

I will run those show & debugg commands and send them to you.  This is starting to get interesting now. I thought security courses were full of problems, this is even better. Keeps you on you toes.

By the way any compact disk "extreme type " as flash card works better.!!!!!!!

Fereidoun.

Steven Holl Mon, 09/27/2010 - 08:05

Again, you aren't running CME 7.1 on the 3745.  The version of CME is *directly* tied to the IOS version.  The files on flash don't impact the CME version.  That's just the GUI version, and phone firmware.

Like I mentioned previously, if you issue 'sh telephony-service' you'll see what version of CME you are running on the device.

The only files you need on flash for a phone to register are the phone firmware files.  The config file for the phone is built into memory by default.

fereidoun.fatahiany Mon, 09/27/2010 - 10:32

Yes you are right. it show version 3.3 on 3745 and version 7.1 on 2811.

Fereidoun.

On 27 September 2010 16:05, sholl

Steven Holl Mon, 09/27/2010 - 09:21

The issue looks to be here:

*Sep 15 04:27:44.334: skinny_server_process: Socket error. errno=254
*Sep 15 04:27:44.334: CLOSED Skinny socket 1 at hdr errno=254 (3 active)
ECONNRESET:reset by peer

Can you recollect those debugs with the addition of 'debug ip tcp trans' running?  Also include a current configuration.

Steven Holl Mon, 09/27/2010 - 12:40

Not sure why you pulled the switch configs.  The socket error is likely an issue with TCP/2000 which is were the Skinny communication occurs.

That's why I asked for TCP debugs along with the other debugs during the issue.

Actions

This Discussion