CUCM 7.1.5 and UCCX 8.0(2). IPPA

Unanswered Question
Sep 8th, 2010

Hi,

I have a problem with the IPPA service.

I configure a IP Phone Service in my CUCM, I show in the lines below: http://10.34.215.21:6293/ipphone/jsp/sciphonexml/IPAgentInitial.jsp


The opcion appear in the Cisco IP Phone 6941, but always when I press the buttom, the phone show me: "The Service i not active".

In CUCM, I created a User "telecaster", user group "CTI Enable" and add the phone mac to this user.

Too, I add the phone mac to the jtapi users.

I put the url in my explorer and I obtain this lines:

Este fichero XML no parece tener ninguna información de estilo asociada. Se muestra debajo el árbol del documento.
     

<CiscoIPPhoneText>
<Title>Error</Title>

<Text>
El servicio de agente de teléfono IP seleccionado no está activo. Seleccione otro servicio de agente de teléfono IP.
</Text>
<Prompt/>

<SoftKeyItem>
<Name>Aceptar</Name>
<URL>Key:Services</URL>
<Position>1</Position>
</SoftKeyItem>
</CiscoIPPhoneText>

In UCCX, the IPPA service is active, in two server.

I don't know where can be the problem.

Can I help me?

Many thanks.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Aaron Harrison Wed, 09/08/2010 - 01:36

Hi

In a two-server HA cluster, you can ONLY use the IPPA service on the current 'Master' server (i.e. the one with a small M next to the Cisco Desktop services in the System/Control Center menu).

If you try to connect to the inactive  server, you get the message that you posted.

This means that in a HA cluster, you have to configure TWO phone services - a 'Phone Agent A' and 'Phone Agent B', with each one pointed at one server. If the agents get the 'inactive' message, they must be trained to know that they must use the other phone service.

If a failover occurs, they must then switch to the other service.

If you use CAD on their PCs, you don't have this problem, and failover is automatic.

Regards

Aaron

Please rate helpful posts...

ma.romero Wed, 09/08/2010 - 02:05

Hi,

I created a new Service for the Second Node of UCCX.

But the IP Phone show me the same error.

I restarted the two server of UCCX, logout and login again with the UDP of the Agent.

And the problem persist.

Do I use the correct port?

I don't know what to do now.

Many thanks

A00460610 Fri, 03/09/2012 - 13:47

Restarting the "Cisco Desktop Browser and IP Phone Agent Service" did the trick for us (UCCX

8.5.1.10000-37). Restarting didn't work.

anchoudh Fri, 03/09/2012 - 18:56

Hi,

Please check th IPPA service status in CUCM, go to CUCM Admin->Device->Device settings->Phone services, and check if its in enabled state. If not please Enable it.

If already enabled , please disable and save. Again Enable it and do unsubscribe and subscribe this service one more time on Phone and check the behaviour.

Hope it helps.

Anand

Actions

This Discussion