Unity 5 and a new exchange 2007 server

Unanswered Question

HI All,

I have an issue with unity 5.  Partner server is 2003 and they have added a new 2007 server to the cluster, ran the permissions wizard and all success.  However the server is offline and all mails collect in the MTA folder.  Is there a step we have missed out to bring this online with Unity.  We have got this out of the permissions wizard report

"Cisco Unity Directory service Account: xxx\UnityDirSvc . This account must be granted Microsoft Exchange Administrator Rights. Click here for detailed instructions.

UnityDirSvc has no permissions in the new exchange 2007 environment."

Do we need to redelegate the permissions as we have added a new server  through the 2003 exchange tools???

Thanks in advance


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Scott Hills Wed, 09/08/2010 - 06:16


The main thing we need to make sure of is that you are running Unity 5.0 with ES 75 or later.

ES 75 is required to support Microsoft Exchange 2007.


Scott Hills

Cisco TAC

Scott Hills Wed, 09/08/2010 - 06:26

If you go to Tools Depot > Reporting Tools > Gather Unity System Info. Double-Click this and app will launch. Here you will see a section like below:

Unity Install Information:
     Unity server name = UNITY702
     Unity version = 7.0(2.0)
     Patches installed:=CU7.0(2)_ES21, CU7.0(2)_ES35

You should see it report something with ES 75 or later.



Scott Hills Thu, 09/09/2010 - 06:38


Based on the requirement that is at the very least part of your issue.

I checked Cisco.com and ES 86 is available for download.

Since our patches are cumulative that should address the issue I speak of.

Here is a link that should take you to the location:




Scott Hills Thu, 09/09/2010 - 07:19

I'm also going to clarify one other thing.

The System Requirements guide does not state this is required for 2007 to be supported:


However the ES Readme does state:


This document contains information on installing software, new and  changed support, new and changed functionality, and resolved defects for  Cisco Unity5.0(1).

Applying this engineering special allows Cisco Unity to support:

  1. Microsoft Exchange 2010
  2. Cisco Unity 5.0 ES 85 and later supports Microsoft Exchange 2010 as the message store for voice messages or as a partner.

    NOTE:  If you want to use Microsoft Exchange 2010 as the message store for  Cisco Unity voice messages or as the partner Exchange server, you must  follow the applicable procedures in the "Using Microsoft Exchange 2010  with Cisco Unity" document, available at Cisco Connection Online (CCO),  or Cisco Unity will not function properly. Read the document before you  install Cisco Unity into an environment that includes Exchange 2010, or  before you add Microsoft Exchange 2010 to the Microsoft Exchange  environment for an existing Cisco Unity server.

  3. Microsoft Exchange 2007
  4. Cisco Unity 5.0 ES 75 and later supports Microsoft Exchange 2007


    We have an issues with message store reporting offline with Exchange 2007. And there have been different bugs to address such as CSCsx59710.

    And the following recommendation has been made:

    1. Upgrade to the latest ES.
    2. Change the "Startup Type" of AvMMProxySvr from "Automatic" to "Manual".
    3. Make sure that "HKEY_LOCAL_MACHINE\SOFTWARE\Active Voice\AvWM\1.00\Check Level" is set to 0xF0.
    4. Reboot.




This Discussion