Cisco RAS dialin with DDR dialout

Unanswered Question

Dear experts,

Please be so kind and take a look at my configurations and problem.

I need to configure Cisco 2811 (modem pvdm2-36D, E1 PRI) as RAS for dialin and dialout DDR to 250 remote locations (analog modems) with different usernames and passwords.

I managed to configure dialin where authentication is done via radius and that works flawless but I'm confused with how to configure DDR on same device.

Remote locations authenticate with radius and get their static IP addressess via radius too.

Please give me suggestions/examples.

----------------------------------------------------------------------------------------

My current configuration:

card type e1 1

!

aaa new-model

aaa authentication ppp default group radius local

aaa authorization network default group radius

aaa session-id common

clock timezone UTC1 1

clock summer-time MET-DST recurring last Sun Mar 2:00 last Sun Oct 2:00

network-clock-participate slot 1

network-clock-select 1 E1 1/0

!

modem country v12 e1-default

no ip source-route

!

isdn switch-type primary-net5

!

controller E1 1/0

pri-group timeslots 1-31

!

interface FastEthernet0/0

ip address 192.168.1.125 255.255.255.0

duplex auto

speed auto

!

interface Serial1/0:15

no ip address

encapsulation ppp

isdn switch-type primary-net5

isdn incoming-voice modem

no cdp enable

!

!

interface Group-Async1

ip unnumbered FastEthernet0/0

encapsulation ppp

async mode interactive

ppp authentication pap

group-range 0/322 0/357

!

!

ip route 172.16.0.128 255.255.255.128 10.10.0.2 -> ip route to remote location 1

.

.

.

ip route 172.16.201.0 255.255.255.128 10.10.1.214 -> ip route to remote location 250

!

!

line 0/322 0/357

no flush-at-activation

login local

modem InOut

modem autoconfigure discovery

transport input all

transport output all

autoselect during-login

autoselect ppp

----------------------------------------------------------------------------------------

This is my configuration for dialin and DDR dialout but it doesn't work. My idea was to make two dialer pool-member on interface Serial 1/0:15 where dialer pool-member 1 is for incoming connections (dialin) and where dialer pool-member 2 is for outgoing connections (DDR dialout) with reserved 2 B channels.

interface Loopback1

ip address 10.10.0.1 255.255.255.255

.

.

.

interface Loopback250

ip address 10.10.1.213 255.255.255.255

!

interface Serial1/0:15

no ip address

encapsulation ppp

no ip route-cache cef

no ip route-cache

no ip mroute-cache

dialer pool-member 1

dialer pool-member 2 min-link 1 max-link 2

isdn switch-type primary-net5

isdn incoming-voice modem

no fair-queue

no cdp enable

ppp authentication pap

!

interface Dialer1

ip unnumbered Loopback1

encapsulation ppp

no ip route-cache cef

no ip route-cache

no ip mroute-cache

dialer pool 2

dialer idle-timeout 300

dialer string XXXXX

dialer-group 1

peer default ip address 10.10.0.2

no fair-queue

no cdp enable

ppp authentication pap

ppp pap sent-username USERNAME password 0 cisco

ppp ipcp address accept -> makes remote location to accept IP address

!

.

.

.

interface Dialer250

ip unnumbered Loopback250

encapsulation ppp

no ip route-cache cef

no ip route-cache

no ip mroute-cache

dialer pool 2

dialer idle-timeout 300

dialer string XXXXX

dialer-group 1

peer default ip address 10.10.1.214

no fair-queue

no cdp enable

ppp authentication pap

ppp pap sent-username USERNAME password 0 cisco

ppp ipcp address accept -> makes remote location to accept IP address

!

ip route 172.16.0.128 255.255.255.128 10.10.0.2 -> route for remote location 1 when remote location dials in

ip route 172.16.0.128 255.255.255.128 Dialer1 -> route for same remote location 1 when Cisco makes DDR dial out

.

.

.

ip route 172.16.201.0 255.255.255.128 10.10.1.214

ip route 172.16.201.0 255.255.255.128 Dialer250

!

dialer-list 1 protocol ip permit

I would be very thankfull for any suggestion!

Regards

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
alanssie Tue, 09/21/2010 - 15:42

No very sure I understand your point here, you said that the remote dial via analog, but you want to make dialout

via the digital  ?

With the current configuration you will use a B-channel, but as no modem trigger the call so you will never do analog

in the B-channel

If you want to dialout using the anallog the group-async is the interface to point as pool-member

and you will need  a chat-script to provide the at command to the internal modem

Alain

Actions

This Discussion

Related Content