2651 only rings half the time on call transfer

Unanswered Question
Sep 8th, 2010

I have a 2561 with T1CAS. Incomming calls hit a call handler and are given the option to transfer direct to

an extension. When the transfer occurs, The calling party only hears half of the rings. The called party hears them all.

For example outside caller calls in and hears unity handler. They transfer to extension 1234. 1234 converage is to voicemail after about 22 seconds (4 rings.)

The caller will hear two rings with extended silence between the rings and the called party hears all 4 if they dont answer and let it roll to voicemail.

The behavior is the same if you call a DID number through this circuit and router and have them transfer you to a 4 digit extension, which removes

unity from the mix. If you call the handler or extension from the inside (VOIP) and repeat the transfer you dont get this behavior. So its gotta be

something on the gateway. Dial-peer perhaps? Any ideas?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
byrne Wed, 09/08/2010 - 14:48

From the description it sounds like this is a h323 gateway to CUCM, correct?

The T1 CAS call would be considered answered (connected) when the call handler gets the call and gives the option to dial a extension, so after a transfer the gateway would not be playing the ringback, but this should be coming from CUCM Annunciator (ANN).

(Service Parameters  H225 Info for call Progress Tone --> Use ANN for Ring Back

Just a guess, but you may be running into CSCta10219  Intermittently silence packets streamed from MOH &/or ANN Server.

Thanks,

Rich

Greg Dowdy Thu, 09/09/2010 - 06:01

Its set up as MGCP. The current setting for H225 user message is User info for call progress tone. Will do some more looking.

byrne Thu, 09/09/2010 - 06:28

Since this is MGCP then the h225 setting is not relevant, and CUCM could be telling the gateway to play ringback on the transfer.

Can you please collected "debug mgcp packet" from the gateway for one on these calls.

Thanks,

Rich

Greg Dowdy Thu, 09/09/2010 - 06:44

Sep  9 13:41:17.729: MGCP Packet sent to 10.22.96.12:2427--->
NTFY 505562 [email protected] MGCP 0.1
N: [email protected]:2427
X: 0
O: DT/sup
<---

Sep  9 13:41:17.777: MGCP Packet received from 10.22.96.12:2427--->
200 505562
<---

Sep  9 13:41:17.785: MGCP Packet received from 10.22.96.12:2427--->
RQNT 7901365 [email protected] MGCP 0.1
X: 0
R: D/[0-9ABCD*#]
S: L/dl
Q: process,loop
<---

Sep  9 13:41:17.789: MGCP Packet sent to 10.22.96.12:2427--->
200 7901365 OK
<---

Sep  9 13:41:18.402: MGCP Packet sent to 10.22.96.12:2427--->
NTFY 505563 [email protected] MGCP 0.1
N: [email protected]:2427
X: 0
O: D/3
<---

Sep  9 13:41:18.438: MGCP Packet received from 10.22.96.12:2427--->
200 505563
<---

Sep  9 13:41:18.442: MGCP Packet received from 10.22.96.12:2427--->
RQNT 7901367 [email protected] MGCP 0.1
X: 0
R: D/[0-9ABCD*#]
S:
Q: process,loop
<---

Sep  9 13:41:18.446: MGCP Packet sent to 10.22.96.12:2427--->
200 7901367 OK
<---

Sep  9 13:41:18.542: MGCP Packet sent to 10.22.96.12:2427--->
NTFY 505564 [email protected] MGCP 0.1
N: [email protected]:2427
X: 0
O: D/7
<---

Sep  9 13:41:18.566: MGCP Packet received from 10.22.96.12:2427--->
200 505564
<---

Sep  9 13:41:18.674: MGCP Packet sent to 10.22.96.12:2427--->
NTFY 505565 [email protected] MGCP 0.1
N: [email protected]:2427
X: 0
O: D/1
<---

Sep  9 13:41:18.698: MGCP Packet received from 10.22.96.12:2427--->
200 505565
<---

Sep  9 13:41:18.702: MGCP Packet received from 10.22.96.12:2427--->
RQNT 7901368 [email protected] MGCP 0.1
X: 0
R: D/[0-9ABCD*#]
S: L/dl
Q: process,loop
<---

Sep  9 13:41:18.706: MGCP Packet sent to 10.22.96.12:2427--->
200 7901368 OK
<---

Sep  9 13:41:18.814: MGCP Packet sent to 10.22.96.12:2427--->
NTFY 505566 [email protected] MGCP 0.1
N: [email protected]:2427
X: 0
O: D/1
<---

Sep  9 13:41:18.842: MGCP Packet received from 10.22.96.12:2427--->
200 505566
<---

Sep  9 13:41:18.846: MGCP Packet received from 10.22.96.12:2427--->
RQNT 7901369 [email protected] MGCP 0.1
X: 0
R: D/[0-9ABCD*#]
S:
Q: process,loop
<---

Sep  9 13:41:18.850: MGCP Packet sent to 10.22.96.12:2427--->
200 7901369 OK
<---

Sep  9 13:41:18.943: MGCP Packet sent to 10.22.96.12:2427--->
NTFY 505567 [email protected] MGCP 0.1
N: [email protected]:2427
X: 0
O: D/5
<---

Sep  9 13:41:18.979: MGCP Packet received from 10.22.96.12:2427--->
200 505567
<---

Sep  9 13:41:22.745: MGCP Packet received from 10.22.96.12:2427--->
CRCX 7901373 [email protected] MGCP 0.1
C: A000000002858553000000F5
X: 0
L: p:20, a:PCMU, s:off, t:b8
M: recvonly
R: DT/rel
Q: process,loop
<---

Sep  9 13:41:22.761: MGCP Packet sent to 10.22.96.12:2427--->
200 7901373 OK
I: A033

v=0

c=IN IP4 10.21.6.2

m=audio 19522 RTP/AVP 0 100

a=rtpmap:100 X-NSE/8000

a=fmtp:100 192-194

<---

Sep  9 13:41:22.785: MGCP Packet received from 10.22.96.12:2427--->
RQNT 7901374 [email protected] MGCP 0.1
X: 0
R: D/[0-9ABCD*#], DT/rel
S: G/rt
Q: process,loop
<---

Sep  9 13:41:22.789: MGCP Packet sent to 10.22.96.12:2427--->
200 7901374 OK
<---

Sep  9 13:41:22.805: MGCP Packet received from 10.22.96.12:2427--->
RQNT 7901375 [email protected] MGCP 0.1
X: 0
R: D/[0-9ABCD*#]
S: DT/ans
Q: process,loop
<---

Sep  9 13:41:22.813: MGCP Packet sent to 10.22.96.12:2427--->
200 7901375 OK
<---

Sep  9 13:41:22.841: MGCP Packet received from 10.22.96.12:2427--->
MDCX 7901376 [email protected] MGCP 0.1
C: A000000002858553000000F5
I: A033
X: 0
L: p:20, a:PCMU, s:off, t:b8
M: sendrecv
R: D/[0-9ABCD*#], DT/rel, L/hf
S:
Q: process,loop

v=0

o=- 41011 0 IN EPN [email protected]
s=Cisco SDP 0
t=0 0
m=audio 30482 RTP/AVP 0
c=IN IP4 10.22.96.13
<---

Sep  9 13:41:22.849: MGCP Packet sent to 10.22.96.12:2427--->
200 7901376 OK
<---

Sep  9 13:41:29.284: MGCP Packet sent to 10.22.96.12:2427--->
NTFY 505568 [email protected] MGCP 0.1
N: [email protected]:2427
X: 0
O: D/8
<---

Sep  9 13:41:29.300: MGCP Packet received from 10.22.96.12:2427--->
200 505568
<---

Sep  9 13:41:29.624: MGCP Packet sent to 10.22.96.12:2427--->
NTFY 505569 [email protected] MGCP 0.1
N: [email protected]:2427
X: 0
O: D/2
<---

Sep  9 13:41:29.708: MGCP Packet received from 10.22.96.12:2427--->
200 505569
<---

Sep  9 13:41:29.913: MGCP Packet sent to 10.22.96.12:2427--->
NTFY 505570 [email protected] MGCP 0.1
N: [email protected]:2427
X: 0
O: D/5
<---

Sep  9 13:41:29.989: MGCP Packet received from 10.22.96.12:2427--->
200 505570
<---

Sep  9 13:41:30.173: MGCP Packet sent to 10.22.96.12:2427--->
NTFY 505571 [email protected] MGCP 0.1
N: [email protected]:2427
X: 0
O: D/1
<---

Sep  9 13:41:30.289: MGCP Packet received from 10.22.96.12:2427--->
200 505571
<---

Sep  9 13:41:32.750: MGCP Packet received from 10.22.96.12:2427--->
CRCX 7901395 [email protected] MGCP 0.1
C: A000000002858565000000F5
X: f
L: p:20, a:PCMU, s:off, t:b8
M: recvonly
R: DT/oc, DT/of
S: DT/sup(addr(7,2,3,0,7,9,8))
Q: process,loop
<---

Sep  9 13:41:32.826: MGCP Packet sent to 10.22.96.12:2427--->
200 7901395 OK
I: A034

v=0

c=IN IP4 10.21.6.2

m=audio 16930 RTP/AVP 0 100

a=rtpmap:100 X-NSE/8000

a=fmtp:100 192-194

<---

Sep  9 13:41:33.535: MGCP Packet received from 10.22.96.12:2427--->
MDCX 7901398 [email protected] MGCP 0.1
C: A000000002858553000000F5
I: A033
X: 0
M: recvonly
R: D/[0-9ABCD*#], DT/rel, L/hf
S:
Q: process,loop
<---

Sep  9 13:41:33.543: MGCP Packet sent to 10.22.96.12:2427--->
NTFY 505572 [email protected] MGCP 0.1
N: [email protected]:2427
X: 1
O: DT/sup
<---

Sep  9 13:41:33.547: MGCP Packet sent to 10.22.96.12:2427--->
200 7901398 OK
<---

Sep  9 13:41:33.563: MGCP Packet received from 10.22.96.12:2427--->
200 505572
<---

Sep  9 13:41:33.571: MGCP Packet received from 10.22.96.12:2427--->
RQNT 7901401 [email protected] MGCP 0.1
X: 1
R: D/[0-9ABCD*#]
S: L/dl
Q: process,loop
<---

Sep  9 13:41:33.579: MGCP Packet sent to 10.22.96.12:2427--->
200 7901401 OK
<---

Sep  9 13:41:33.583: MGCP Packet received from 10.22.96.12:2427--->
RQNT 7901402 [email protected] MGCP 0.1
X: 0
R: D/[0-9ABCD*#], DT/rel
S: L/ht
Q: process,loop
<---

Sep  9 13:41:33.591: MGCP Packet sent to 10.22.96.12:2427--->
200 7901402 OK
<---

Sep  9 13:41:34.152: MGCP Packet sent to 10.22.96.12:2427--->
NTFY 505573 [email protected] MGCP 0.1
N: [email protected]:2427
X: 1
O: D/6
<---

Sep  9 13:41:34.172: MGCP Packet received from 10.22.96.12:2427--->
200 505573
<---

Sep  9 13:41:34.176: MGCP Packet received from 10.22.96.12:2427--->
RQNT 7901406 [email protected] MGCP 0.1
X: 1
R: D/[0-9ABCD*#]
S:
Q: process,loop
<---

Sep  9 13:41:34.180: MGCP Packet sent to 10.22.96.12:2427--->
200 7901406 OK
<---

Sep  9 13:41:34.292: MGCP Packet sent to 10.22.96.12:2427--->
NTFY 505574 [email protected] MGCP 0.1
N: [email protected]:2427
X: 1
O: D/2
<---

Sep  9 13:41:34.312: MGCP Packet received from 10.22.96.12:2427--->
200 505574
<---

Sep  9 13:41:34.432: MGCP Packet sent to 10.22.96.12:2427--->
NTFY 505575 [email protected] MGCP 0.1
N: [email protected]:2427
X: 1
O: D/1
<---

Sep  9 13:41:34.452: MGCP Packet received from 10.22.96.12:2427--->
200 505575
<---

Sep  9 13:41:34.456: MGCP Packet received from 10.22.96.12:2427--->
RQNT 7901407 [email protected] MGCP 0.1
X: 1
R: D/[0-9ABCD*#]
S: L/dl
Q: process,loop
<---

Sep  9 13:41:34.460: MGCP Packet sent to 10.22.96.12:2427--->
200 7901407 OK
<---

Sep  9 13:41:34.528: MGCP Packet received from 10.22.96.12:2427--->
RQNT 7901408 [email protected] MGCP 0.1
X: 0
R: D/[0-9ABCD*#], DT/rel
S: G/rt
Q: process,loop
<---

Sep  9 13:41:34.533: MGCP Packet sent to 10.22.96.12:2427--->
200 7901408 OK
<---

Sep  9 13:41:34.565: MGCP Packet sent to 10.22.96.12:2427--->
NTFY 505576 [email protected] MGCP 0.1
N: [email protected]:2427
X: 1
O: D/7
<---

Sep  9 13:41:34.585: MGCP Packet received from 10.22.96.12:2427--->
200 505576
<---

Sep  9 13:41:34.585: MGCP Packet received from 10.22.96.12:2427--->
RQNT 7901409 [email protected] MGCP 0.1
X: 1
R: D/[0-9ABCD*#]
S:
Q: process,loop
<---

Sep  9 13:41:34.589: MGCP Packet sent to 10.22.96.12:2427--->
200 7901409 OK
<---

Sep  9 13:41:34.701: MGCP Packet sent to 10.22.96.12:2427--->
NTFY 505577 [email protected] MGCP 0.1
N: [email protected]:2427
X: 1
O: D/1
<---

Sep  9 13:41:34.721: MGCP Packet received from 10.22.96.12:2427--->
200 505577
<---

Sep  9 13:41:34.729: MGCP Packet received from 10.22.96.12:2427--->
CRCX 7901411 [email protected] MGCP 0.1
C: A00000000285857c000000F5
X: 1
L: p:20, a:PCMU, s:off, t:b8
M: recvonly
R: DT/rel
Q: process,loop
<---

Sep  9 13:41:34.745: MGCP Packet sent to 10.22.96.12:2427--->
200 7901411 OK
I: A035

v=0

c=IN IP4 10.21.6.2

m=audio 18788 RTP/AVP 0 100

a=rtpmap:100 X-NSE/8000

a=fmtp:100 192-194

<---

Sep  9 13:41:34.765: MGCP Packet received from 10.22.96.12:2427--->
RQNT 7901412 [email protected] MGCP 0.1
X: 1
R: D/[0-9ABCD*#], DT/rel
S: G/rt
Q: process,loop
<---

Sep  9 13:41:34.769: MGCP Packet sent to 10.22.96.12:2427--->
200 7901412 OK
<---

Sep  9 13:41:34.817: MGCP Packet sent to 10.22.96.12:2427--->
NTFY 505578 [email protected] MGCP 0.1
N: [email protected]:2427
X: f
O: DT/oc(dt/sup)
<---

Sep  9 13:41:34.837: MGCP Packet received from 10.22.96.12:2427--->
200 505578
<---

Sep  9 13:41:34.893: MGCP Packet received from 10.22.96.12:2427--->
MDCX 7901413 [email protected] MGCP 0.1
C: A000000002858565000000F5
I: A034
X: f
L: p:20, a:PCMU, s:off, t:b8
M: sendrecv
S:

v=0

o=- 41012 0 IN EPN [email protected]
s=Cisco SDP 0
t=0 0
m=audio 25804 RTP/AVP 0
c=IN IP4 10.21.6.66
<---

Sep  9 13:41:34.905: MGCP Packet sent to 10.22.96.12:2427--->
200 7901413 OK
<---

Sep  9 13:41:45.314: MGCP Packet sent to 10.22.96.12:2427--->
NTFY 505579 [email protected] MGCP 0.1
N: [email protected]:2427
X: 2
O: DT/sup
<---

Sep  9 13:41:45.363: MGCP Packet received from 10.22.96.12:2427--->
200 505579
<---

Sep  9 13:41:45.383: MGCP Packet received from 10.22.96.12:2427--->
RQNT 7901439 [email protected] MGCP 0.1
X: 2
R: D/[0-9ABCD*#]
S: L/dl
Q: process,loop
<---

Sep  9 13:41:45.387: MGCP Packet sent to 10.22.96.12:2427--->
200 7901439 OK
<---

Sep  9 13:41:45.923: MGCP Packet sent to 10.22.96.12:2427--->
NTFY 505580 [email protected] MGCP 0.1
N: [email protected]:2427
X: 2
O: D/6
<---

Sep  9 13:41:45.940: MGCP Packet received from 10.22.96.12:2427--->
200 505580
<---

Sep  9 13:41:45.948: MGCP Packet received from 10.22.96.12:2427--->
RQNT 7901445 [email protected] MGCP 0.1
X: 2
R: D/[0-9ABCD*#]
S:
Q: process,loop
<---

Sep  9 13:41:45.952: MGCP Packet sent to 10.22.96.12:2427--->
200 7901445 OK
<---

Sep  9 13:41:46.064: MGCP Packet sent to 10.22.96.12:2427--->
NTFY 505581 [email protected] MGCP 0.1
N: [email protected]:2427
X: 2
O: D/2
<---

Sep  9 13:41:46.084: MGCP Packet received from 10.22.96.12:2427--->
200 505581
<---

Sep  9 13:41:46.192: MGCP Packet sent to 10.22.96.12:2427--->
NTFY 505582 [email protected] MGCP 0.1
N: [email protected]:2427
X: 2
O: D/1
<---

Sep  9 13:41:46.212: MGCP Packet received from 10.22.96.12:2427--->
200 505582
<---

Sep  9 13:41:46.216: MGCP Packet received from 10.22.96.12:2427--->
RQNT 7901446 [email protected] MGCP 0.1
X: 2
R: D/[0-9ABCD*#]
S: L/dl
Q: process,loop
<---

Sep  9 13:41:46.220: MGCP Packet sent to 10.22.96.12:2427--->
200 7901446 OK
<---

Sep  9 13:41:46.332: MGCP Packet sent to 10.22.96.12:2427--->
NTFY 505583 [email protected] MGCP 0.1
N: [email protected]:2427
X: 2
O: D/1
<---

Sep  9 13:41:46.352: MGCP Packet received from 10.22.96.12:2427--->
200 505583
<---

Sep  9 13:41:46.356: MGCP Packet received from 10.22.96.12:2427--->
RQNT 7901447 [email protected] MGCP 0.1
X: 2
R: D/[0-9ABCD*#]
S:
Q: process,loop
<---

Sep  9 13:41:46.360: MGCP Packet sent to 10.22.96.12:2427--->
200 7901447 OK
<---

Sep  9 13:41:46.464: MGCP Packet sent to 10.22.96.12:2427--->
NTFY 505584 [email protected] MGCP 0.1
N: [email protected]:2427
X: 2
O: D/6
<---

Sep  9 13:41:46.480: MGCP Packet received from 10.22.96.12:2427--->
200 505584
<---

Sep  9 13:41:46.488: MGCP Packet received from 10.22.96.12:2427--->
CRCX 7901448 [email protected] MGCP 0.1
C: A00000000285859d000000F5
X: 2
L: p:20, a:PCMU, s:off, t:b8
M: recvonly
R: DT/rel
Q: process,loop
<---

Sep  9 13:41:46.504: MGCP Packet sent to 10.22.96.12:2427--->
200 7901448 OK
I: A036

v=0

c=IN IP4 10.21.6.2

m=audio 16544 RTP/AVP 0 100

a=rtpmap:100 X-NSE/8000

a=fmtp:100 192-194

<---

Sep  9 13:41:46.528: MGCP Packet received from 10.22.96.12:2427--->
RQNT 7901449 [email protected] MGCP 0.1
X: 2
R: D/[0-9ABCD*#], DT/rel
S: G/rt
Q: process,loop
<---

Sep  9 13:41:46.532: MGCP Packet sent to 10.22.96.12:2427--->
200 7901449 OK
<---

Sep  9 13:41:47.907: MGCP Packet received from 10.22.96.12:2427--->
RQNT 7901450 [email protected] MGCP 0.1
X: 0
R: D/[0-9ABCD*#], DT/rel
S:
Q: process,loop
<---

Sep  9 13:41:47.911: MGCP Packet sent to 10.22.96.12:2427--->
200 7901450 OK
<---

Sep  9 13:41:48.003: MGCP Packet received from 10.22.96.12:2427--->
MDCX 7901451 [email protected] MGCP 0.1
C: A000000002858553000000F5
I: A033
X: 0
L: p:20, a:PCMU, s:off, t:b8
M: sendrecv
R: D/[0-9ABCD*#], DT/rel, L/hf
S:
Q: process,loop

v=0

o=- 41011 0 IN EPN [email protected]
s=Cisco SDP 0
t=0 0
m=audio 29766 RTP/AVP 0
c=IN IP4 10.21.6.51
<---

Sep  9 13:41:48.015: MGCP Packet sent to 10.22.96.12:2427--->
200 7901451 OK
<---

Sep  9 13:41:49.594: MGCP Packet sent to 10.22.96.12:2427--->
NTFY 505585 [email protected] MGCP 0.1
N: [email protected]:2427
X: 1
O: DT/rel(0)
<---

Sep  9 13:41:49.614: MGCP Packet received from 10.22.96.12:2427--->
200 505585
<---

Sep  9 13:41:49.618: MGCP Packet received from 10.22.96.12:2427--->
DLCX 7901454 [email protected] MGCP 0.1
C: A00000000285857c000000F5
I: A035
X: 1
<---

Sep  9 13:41:49.626: MGCP Packet sent to 10.22.96.12:2427--->
250 7901454 OK
P: PS=0, OS=0, PR=0, OR=0, PL=0, JI=65, LA=0
<---

Sep  9 13:41:49.646: MGCP Packet received from 10.22.96.12:2427--->
RQNT 7901455 [email protected] MGCP 0.1
X: 1
R: DT/sup, D/[0-9ABCD*#]
S: DT/rlc
Q: process,loop
<---

Sep  9 13:41:49.654: MGCP Packet sent to 10.22.96.12:2427--->
200 7901455 OK
<---

Sep  9 13:41:49.874: MGCP Packet received from 10.22.96.12:2427--->
MDCX 7901456 [email protected] MGCP 0.1
C: A000000002858553000000F5
I: A033
X: 0
M: recvonly
R: D/[0-9ABCD*#], DT/rel, L/hf
S:
Q: process,loop
<---

Sep  9 13:41:49.878: MGCP Packet sent to 10.22.96.12:2427--->
200 7901456 OK
<---

Sep  9 13:41:49.902: MGCP Packet received from 10.22.96.12:2427--->
DLCX 7901457 [email protected] MGCP 0.1
C: A000000002858553000000F5
I: A033
X: 0
R: DT/rlc
S: DT/rel
Q: process,loop
<---

Sep  9 13:41:49.910: MGCP Packet sent to 10.22.96.12:2427--->
250 7901457 OK
P: PS=588, OS=94080, PR=505, OR=80482, PL=0, JI=63, LA=0
<---

Sep  9 13:41:50.227: MGCP Packet sent to 10.22.96.12:2427--->
NTFY 505586 [email protected] MGCP 0.1
N: [email protected]:2427
X: f
O: DT/ans
<---

Sep  9 13:41:50.247: MGCP Packet received from 10.22.96.12:2427--->
200 505586
<---

Sep  9 13:41:50.251: MGCP Packet received from 10.22.96.12:2427--->
RQNT 7901458 [email protected] MGCP 0.1
X: f
R: D/[0-9ABCD*#], DT/rel, L/hf
S:
Q: process,loop
<---

Sep  9 13:41:50.255: MGCP Packet sent to 10.22.96.12:2427--->
200 7901458 OK
<---
un
Sep  9 13:41:54.882: MGCP Packet sent to 10.22.96.12:2427--->
NTFY 505587 [email protected] MGCP 0.1
N: [email protected]:2427
X: 0
O: DT/rlc
<---

Sep  9 13:41:54.902: MGCP Packet received from 10.22.96.12:2427--->
200 505587
<---

Sep  9 13:41:54.906: MGCP Packet received from 10.22.96.12:2427--->
RQNT 7901470 [email protected] MGCP 0.1
X: 0
R: DT/sup, D/[0-9ABCD*#]
Q: process,loop
<---

Sep  9 13:41:54.947: MGCP Packet sent to 10.22.96.12:2427--->
200 7901470 OK
<---
all
All possible debugging has been turned off
mwvgw1#

Greg Dowdy Thu, 09/09/2010 - 07:04

version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname mwvgw1

!

boot-start-marker

boot system flash c2600-ipvoice-mz.123-11.T2.bin

boot-end-marker

!

logging buffered 4096 debugging

enable secret 5 $

!

username

network-clock-participate wic 0

no network-clock-participate wic 1

voice-card 0

dspfarm

no local-bypass

!

aaa new-model

!

!

aaa group server tacacs+ ACS

server 10.20.1.110

!

aaa authentication login

aaa authentication enable default group ACS enable none

aaa authorization commands

aaa accounting exec lourdes start-stop group ACS

aaa accounting commands

aaa session-id common

ip subnet-zero

ip cef

!

!

!

!

ip multicast-routing

no ftp-server write-enable

!

!

!

!

!

!

!

!

!

!

!

voice translation-rule 1

rule 1 /62/ /8/

!

!

voice translation-profile srst1

translate calling 1

!

!

ccm-manager fallback-mgcp

ccm-manager redundant-host 10.22.96.11

ccm-manager mgcp

ccm-manager music-on-hold

ccm-manager config server 10.22.96.11

ccm-manager config

!

!

controller T1 0/0

framing sf

linecode ami

cablelength short 133

ds0-group 1 timeslots 1-16 type e&m-wink-start

!

controller T1 0/1

framing esf

clock source internal

linecode b8zs

channel-group 0 timeslots 1-24 speed 64

!

controller T1 0/2

framing esf

clock source internal

linecode b8zs

channel-group 0 timeslots 1-24 speed 64

!

!

!

!

interface Multilink1

ip address 10.21.250.5 255.255.255.252

ip pim sparse-dense-mode

ppp multilink

ppp multilink group 1

!

interface MFR1

no ip address

!

interface FastEthernet0/0

no ip address

duplex auto

speed auto

!

interface FastEthernet0/0.10

description ***MARCUMDATA***

encapsulation dot1Q 10

ip address 10.21.2.5 255.255.255.0

standby 1 ip 10.21.2.1

standby 1 priority 150

standby 1 preempt

standby 1 track Multilink1 100

!

interface FastEthernet0/0.11

encapsulation dot1Q 11

ip address 10.21.6.2 255.255.255.0

ip helper-address 10.21.2.2

ip pim sparse-dense-mode

standby ip 10.21.6.1

standby priority 150

standby preempt

standby track Multilink1 100

!

interface FastEthernet0/0.12

description **** Marcum SleepLab Network ****

encapsulation dot1Q 12

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface Serial0/1:0

no ip address

encapsulation ppp

ppp chap hostname group1

ppp multilink

ppp multilink group 1

!

interface Serial0/2:0

no ip address

encapsulation ppp

ppp chap hostname group1

ppp multilink

ppp multilink group 1

!

ip classless

ip route 0.0.0.0 0.0.0.0 10.21.250.6

ip route 10.0.0.0 255.0.0.0 10.21.250.6

ip route 10.20.9.0 255.255.255.0 10.21.2.3

ip route 10.21.2.15 255.255.255.255 10.20.1.61

ip route 10.21.250.0 255.255.255.252 10.21.6.3

!

ip http server

!

logging source-interface FastEthernet0/0.11

access-list 109 deny tcp host 10.21.6.86 any eq 2000

access-list 109 permit ip any any

snmp-server community lourdesmon RW

snmp-server community lourdesmon1 RW

snmp-server enable traps tty

!

tacacs-server host 10.20.1.110

tacacs-server directed-request

!

control-plane

!

!

call application alternate DEFAULT

!

!

voice-port 0/0:1

!

mgcp

mgcp call-agent 10.22.96.12 2427 service-type mgcp version 0.1

mgcp dtmf-relay voip codec all mode out-of-band

mgcp rtp unreachable timeout 1000 action notify

mgcp modem passthrough voip mode nse

mgcp package-capability rtp-package

no mgcp package-capability res-package

mgcp package-capability sst-package

no mgcp package-capability fxr-package

mgcp package-capability pre-package

no mgcp timer receive-rtcp

mgcp sdp simple

mgcp fax t38 inhibit

mgcp rtp payload-type g726r16 static

mgcp bind control source-interface FastEthernet0/0.11

mgcp bind media source-interface FastEthernet0/0.11

!

mgcp profile default

!

!

!

dial-peer voice 99900199 pots

application mgcpapp

port 0/0:1

!

dial-peer voice 9 pots

destination-pattern 9[2-9]......

forward-digits 7

prefix 606

!

dial-peer voice 606 pots

destination-pattern 606.......

forward-digits all

!

dial-peer voice 91 pots

destination-pattern 91..........

forward-digits 11

!

dial-peer voice 9911 pots

destination-pattern 9911

forward-digits 3

!

!

call-manager-fallback

max-conferences 4

limit-dn 7940 1

ip source-address 10.21.6.2 port 2000 strict-match

max-ephones 48

max-dn 192 preference 2

dialplan-pattern 1 62... extension-length 4 extension-pattern 8...

alias 1 32115 to 8107 preference 1 cfw 8202 timeout 10

alias 2 37706 to 8220

translation-profile incoming srst1

byrne Thu, 09/09/2010 - 14:25

Don't see where there should be a issue with the caller on the T1 CAS side hearing ringback tone when the call gets transfer.

I see the call come in and goes to 37115, connects to Unity I am guessing 10.22.96.13.

User hits 8251, call gets transfer to 10.21.6.51

Call Manager is telling the t1 CAS GW to play ringback from 13:41:34.528 to 13:41:48.003, there should not be any /* Style Definitions */ table.MsoNormalTable {mso-style-name:"Table Normal"; mso-tstyle-rowband-size:0; mso-tstyle-colband-size:0; mso-style-noshow:yes; mso-style-priority:99; mso-style-qformat:yes; mso-style-parent:""; mso-padding-alt:0in 5.4pt 0in 5.4pt; mso-para-margin:0in; mso-para-margin-bottom:.0001pt; mso-pagination:widow-orphan; font-size:11.0pt; font-family:"Calibri","sans-serif"; mso-ascii-font-family:Calibri; mso-ascii-theme-font:minor-latin; mso-fareast-font-family:"Times New Roman"; mso-fareast-theme-font:minor-fareast; mso-hansi-font-family:Calibri; mso-hansi-theme-font:minor-latin;} interruptions of ringback between these times.

Is this when the issue is seen (heard)?

Greg Dowdy Fri, 09/10/2010 - 06:14

Thats what is strange. You have the  sequence  correct. The problem comes in when User hits 8251, call gets transfer to 10.21.6.51.

8251 extension has a coverage path to voicemail and the time to coverage is 25 seconds, about 4 and a half rings.

On the caller side, they only hear half the rings. On the called party side, they get (1) ring silence (2)  ring silence (3) ring silence (4)ring silence partial ring and xfer to voicemail. 

The incomming caller hears (1) ring silence silence (2) ring silence silence then transfer to voicemail. In other words, they only hear half the ringbacks they are supposed to.  The caller is perceving that the ring time is too short when it really isnt.You can set the time to voicemail to 50 seconds and the pattern repeats, just longer.

We had one a few years ago where you got no ringback at all, but that was fixed by modifying the incoming dial peer and adding a statement that allowed the gateway to recognize a different proress indicator coming from the phone company . That was on CM 4.3. This one works fine, but you only hear half the rings when you call through this gateway and transfer.

byrne Fri, 09/10/2010 - 10:20

Think you are most likely running into a old bug:

CSCef60201 No ringback on transfer, Cadence3 off timer set to 10000

Symptom:
------------------
Ringback cadence is extremely long when transferring calls using MGCP. The ringback cadence is 16 seconds between rings.

Problem:
------------------
The Cadence3 timer is set to 10000ms causing the ring cadence to be 2 seconds on and 14 seconds off

Workaround:
-----------------
Manually change the c:\program files\cisco\tftpath\united_states\gateway_tones.xml file. Change the "CPTONE_RING_BACK" section, "ONTT" parameter to 1.
Then enable the 3700 to download the gateway tones with the 'ccm-manager download-tones'.
This will set the cadence 3 tone to 1 ms and thereby avoid the 10000 ms default.
This workarond has not been fully tested, but my solve the problem.

View on cisco.com here:

http://tools.cisco.com/Support/BugToolKit/search/getBugDetails.do?method=fetchBugDetails&bugId=CSCef60201

Fixed-In  12.3(11)T8 and above.

Actions

This Discussion