8.0.4 Upgrade of CUE failed

Unanswered Question

Started the upgrade to 8.0.4 and it started well, but I got a Upgrade failed; Upgrade of CUE failed.

Checked the log and it upgraded IOS, CME fine, then it backed up CUE which went fine, then it went to install the new CUE image and that failed.

I don't want to pooch it before I hear back from you guys so I'll leave it in this state without reboot.

I wish it was more detailed as to why it failed..

A little help...

THanks,

Bob James

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
phil.wyche Thu, 09/09/2010 - 00:50

I have the same problem with my uc560 and now cannot get inbound calls working across my E1 (ISDN 8 channel PRI)

Mine's just kind of in limbo now as I see the software (IOS) is uploaded to flash and everything else

looked like it worked, but I don't want to reboot at this point. I'm wondering if I can just try the CUE install by inself and see if that works.

I would suggest you open a ticket for yours, I can wait a little to get mine going as it's not a production system.

Steven are you there?

Bob James

JOHN NIKOLATOS Thu, 09/09/2010 - 15:11

Bob - CCA does that a lot.

It looks for the reboot and tries to access it again and says failed.  As long as you can confirm the transfer of the IOS was succes

sful and is on the flash you will be fine.  A console will always be able to help you in the case you need to xmodem your config over... but I am sure it will reboot.  Just have teh new IOS handy and copy the config from a command prompt.

John Nikolatos

www.niktek.com

Steven DiStefano Thu, 09/09/2010 - 16:22

Logs are obtained by clicking HELP in the CCA menu bar, then Support, then generate log (a zip file gets saved where you specify).

Steve DiStefano

Found it,

Took me three times to find the button;

Something to pass on to the GUI team, on a laptop you cannot see the Troubleshooting button, there are two scroll bars on the right, I had to use the left one to scroll down, then the right one to scroll further to see the button.

I am re-trying the upgrade and I will review the log files and post here if I can't figure it out.

Thanks,

Bob

Steven DiStefano Fri, 09/10/2010 - 02:22

Will ask CCA team for assistance looking at logs and let you know.

When you performed you 7.1.3 CUE install back in the day, did we see a similar issue? What was the root cause and resolution? I seem to remember you are in Netherlands and localize Dutch, correct?

Steve

Steven DiStefano Fri, 09/10/2010 - 11:32

/* Style Definitions */ table.MsoNormalTable {mso-style-name:"Table Normal"; mso-tstyle-rowband-size:0; mso-tstyle-colband-size:0; mso-style-noshow:yes; mso-style-priority:99; mso-style-qformat:yes; mso-style-parent:""; mso-padding-alt:0in 5.4pt 0in 5.4pt; mso-para-margin:0in; mso-para-margin-bottom:.0001pt; mso-pagination:widow-orphan; font-size:11.0pt; font-family:"Calibri","sans-serif"; mso-ascii-font-family:Calibri; mso-ascii-theme-font:minor-latin; mso-fareast-font-family:"Times New Roman"; mso-fareast-theme-font:minor-fareast; mso-hansi-font-family:Calibri; mso-hansi-theme-font:minor-latin;}

Can we ask tou to do the following manually?

1. Session to CUE

2. offline

3. restore factory default

4. When it is complete reload the router

5. Delete the software pack already downloaded and redownload from CCO.We have seen sometimes that file is corrupted while downloading.

6. Redo software upgrade

Will Do,

A couple of points;

Strange that the only thing in the ZIP that is corrupted is CUE?

Is there a validity checker for the downloaded file to ensure integrity before I try the upgrade?

If the Upgrade knows the file is corrupt, can you not write it so it checks the files before the upgrade begins?

What will your steps do to my existing CUE configuration?

When you say reload the router, you mean bounce the UC520?

Thanks again,

Bob James

OK now I'm hooped,

Did what you suggested and downloaded the image from CCO (which was down for maintenance) and tried it again; same issue CUE failed.

Now I have CUE with factory defaults and I am unable to upgrade it.

I'm going to choose CUE only and see what happens

Attached log file, but I don't see the same error again?.

HELP

JOHN NIKOLATOS Sat, 09/11/2010 - 09:57

Make sure you can ping cue and have one nic enabled.

John Nikolatos

NIKTEK LLC

2038741273

Thanks John,

Yes the NIC one burned me before (had wireless on), but this is not the case.

I am getting closer now to figuring out what the issue is, here's where I am:

I extracted the CUE configurations/images out of the newly downloaded 8.0.4 zip and ran a install CUE only. This appeared to work, and now I am restoring the configuration as Steven had me reset to factory earlier.

If the restore works, I will reboot the whole unit and go through my testing. If that is successful I would say Cisco has an issue in how 2.2.5 CCA is handling the upgrade of CUE (although I'm sure hundreds or people will chime in and say" It worked fine for me"). My thinking on this is; if the same CUE worked fine from the same ZIP file, then the issue was how CCA is doing the upgrade.

I will post here in a little while and say how things went.

Bob

Final Update

The Upgrade of CUE worked by itself, it did not work when I chose Upgrade All via CCA 2.2.5; I tried this with two images I downloaded.

Steven, can you guys take a look at this?

Anyway the most important thing is is backups! Please backup your systems a lot, my restore (of CUE) went fine after a factory reset, so this is extremely important, use CCA to perform backups prior to any change made.

My system is now at the latest version, I just have to figure out how to get the latest phone loads on it now, but I will open a new thread about these issues.

Cheers,

Bob James

Steven DiStefano Mon, 09/13/2010 - 14:09

They have the logs, but would like a case.   If you can ipen one, I will pass it to them.

Sorry for the inconvenience.

Actions

This Discussion