How to repeat IVR file in Menu(M) microapp

Unanswered Question
Sep 9th, 2010
User Badges:

I am having a setup where i am using Network VRU script M,Media.wav . i am using it with Run external script object in ICM.

problem here is that my Media file play only for a single time. i want to repeat this annoucement which is not happening ?


Call flow is as follows.


Call get queued to Skill group. if agent are busy call should give a queue annoucement " All agents are busy be in queue or press 1 for voicemail.


Above annoucement file play for one time but go to silence mode after that.


i am using Runexternal Script object with M,media file microapp. success node i have connected to CED to collect digit for voicemail.

while X node is connected to wait object and then again connected to Runexternal Script node.


Screenshot are attached for reference.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
david.macias Thu, 09/09/2010 - 06:38
User Badges:
  • Blue, 1500 points or more

A couple of things:


1. Your script is very hard to follow, you might want to clean it up.

2. Do not use Wait nodes.

3. Change the config parameters to 1-2,Y,3,3 and try it again.


david

pankajibt Thu, 09/09/2010 - 09:35
User Badges:

i changed the configuration parameter as per suggested by you but no help.

Callflow is simple . call comes to ICM script which is forwarded to CVP application for welcome annoucement and from there it is coming back again for agent getting it to icm object (queue to skillset)


In case of agent busy i have connected queue to skillgroup object X node to Run external script object where i used a Microapp(M,media.wav) to play a   media file(be in queue all agents are busy press 1 for voicemail). for voicemail transfer i used CED object . which is working if i am pressing 1. but if i am not pressing anything at no input condition of Run external script media file is not repeating i want it get it repeat three times  . media.wav is playing only one time and call getting disconnected if i dont press anything.

This is your first microapp script, correct?


In case of agent busy i have connected queue to skillgroup object X node to Run external script .....


That's wrong. If all the agents are unavailable and it queues the call, it comes out the check port, not the X port. If it comes out the X port, it's probably because your "condition if" failed.


. but if i am not pressing anything at no input condition of Run external script media file is not repeating i want it get it repeat three times  . media.wav is playing only one time and call getting disconnected if i dont press anything.


No you don't. You are saying to the caller "Press 1 for voice mail or just stay on the line" so you certainly don't want to repeat this. You really want to just play this once. The specifications I use when I do this is to set the "no entry" tries to 1 and override the custom messages.


Check the CVP logs. If the call is coming out the X port of the Run Ext Script, it's because there is an error. Now it may be an error you are expecting (like reaching the max number of no entry tries) but you need to catch it and process it. In your case it could be because it can't find the system message "please make a selection".


Callflow is simple . call comes to ICM script which is forwarded to CVP application for welcome annoucement and from there it is coming back again for agent getting it to icm object (queue to skillset)



Let's look at your script again.


It looks like you set up for Audium (CVP VXML) and call the application "Hns SD Project" through PlayVXMLScript node 149 (I assume this is GS,Server,V). Is that your Welcome? Why does the X out of 149 go to 192?


Now it goes to the Q2SG. If no agents are available, it goes to node 191. How can 191 go to both 192 and 193?


microapp.media_server should be set to a key word like "media" and resolve this on the gateway. Why is this set to "http://ms/en-us"?


The locale will kick in and append the locale - which you don't override. That's en-us. So it will make this "http://ms/en-us/en-us/app" and this is going to be wrong.


196 failure goes to 197 (wait) which is illegal and then goes back to 196. What are you doing?


This script is full of errors. It cannot possibly validate.


Regards,

Geoff

microapp.media_server should be set to a key word like "media" and resolve this on the gateway. Why is this set to "http://ms/en-us"?


The locale will kick in and append the locale - which you don't override. That's en-us. So it will make this "http://ms/en-us/en-us/app" and this is going to be wrong.


Sorry, I made an error in this comment.


If the locale is not defined, it will not have any value so your technique will work.


But you should still follow the Cisco recommendation of setting media_server to a keyword like "media" which is resolved by the gateway through the ip host table, set the locale to something like "en-us" and your app_media_lib to something like "app/foobar" so that the combination is "media/en-us/app/foobar".


Now the Call Server will prepend "http://" and the gateway will see "http://media/en-us/app/foobar" which it will resolve to "http://a.b.c.d/en-us/app/foobar" and find your wave files located on the web server a.b.c.d under the root at "en-us/app/foobar".


Regards,

Geoff

Actions

This Discussion