Unable to use Phone Designer

Unanswered Question
Sep 9th, 2010
User Badges:

I'm running a brand-new installation of UCMBE 8 and I want to roll out Phone Designer for some of my users so they can customize their backgrounds. Trouble is, I can't get wallpaper to push out to the phone. I keep getting the message 'Personalization is disabled on the selected device' anytime I try.


I've set Phone Personalization to Enabled on the individual phones, in the Common Phone Profile, and even in the Enterprise Parameters, performing a reset each time. Still, I get that message. Is there something I'm missing in enabling personalization?


Thanks,

Jason

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.7 (7 ratings)
Loading.
Bruno rangel Thu, 09/09/2010 - 19:40
User Badges:
  • Green, 3000 points or more
  • Participante em Destaque,

    Prêmio 'Escolha da Audiência' fevereiro 2015

  • Events Top Contributors,

    External, 2014

Hi Jason
Make sure the phone web access is working properly,and your URL Authentication in CM is correct.





But I think,it isn't supported to CM 8.

http://www.cisco.com/en/US/prod/collateral/voicesw/ps6882/ps9156/at_a_glance_c45-487466.pdf

jason9045 Fri, 09/10/2010 - 04:31
User Badges:

I hope it's supported. I'm getting similar errors when trying to use third-party background deployment tools as well though, which led me to believe it was a configuration issue. But, I'll definitely explore the compatibility avenue as well.

jason9045 Fri, 09/10/2010 - 04:48
User Badges:

Also, for what it's worth, the URL authentication appears to be working correctly. I'm able to hit my corporate and personal directories so everything should be in order there.

Bruno rangel Fri, 09/10/2010 - 09:32
User Badges:
  • Green, 3000 points or more
  • Participante em Destaque,

    Prêmio 'Escolha da Audiência' fevereiro 2015

  • Events Top Contributors,

    External, 2014

Try take test with Extension Mobility.


In your phone login used EM with end user you is tenting

jason9045 Mon, 09/13/2010 - 05:07
User Badges:

I don't have EM enabled, and I hate to enable it for the sake of troubleshooting this and run the risk of wasting time troubleshooting any EM-only issues that may come up.


I believe I'll just stick to using TFTP and give up on Phone Designer since it's proving to be more trouble than it's worth. Thanks for your help, though.

scheived Fri, 09/17/2010 - 14:37
User Badges:

I'm having the same problem, log file in Phone Designer says The remote server returned an error: (400) Bad Request.


This was working fine in ccm version 7.5, something is wrong in version 8


This is very fustrating...

Bruno rangel Sat, 09/18/2010 - 13:00
User Badges:
  • Green, 3000 points or more
  • Participante em Destaque,

    Prêmio 'Escolha da Audiência' fevereiro 2015

  • Events Top Contributors,

    External, 2014

Hi Scheived


Explain to us  how is your configuration. Maybe will is help our friend

Joseph Martini Sat, 09/18/2010 - 14:18
User Badges:
  • Cisco Employee,

Try taking a look at a packet capture to see what is going on.  I have this working fine on CUCM 8.0.3.  As others have said make sure your authentication URLs have a resolvable name or an IP address from the perspective of your PC.  One big change in CUCM 8 is HTTPS by default, that means that depending on how Phone Designer authenticates if it's using HTTPS and TVS (Trust Verification Service) then you have to make sure under system > server, you have an IP address and your TVS service has been restarted since making that change or that the PC and/or the phone can resolve the name.  If other services on the phone work that need to authenticate then the phone is already ok (assuming it's a 7941/61/70 or later since 40/60 don't use HTTPS).

scheived Thu, 09/30/2010 - 08:57
User Badges:

I was able to get phone designer to work correctly by upgrading ccm to version 8.03. 

Lamar Demby Fri, 10/08/2010 - 11:47
User Badges:

We just upgraded to 8.0.3 and getting "An Unkown Error occurred on your Cisco IP Phone" when trying to preview a built-in image on 7945G.

We checked the following and all are good:


- Firmware load is later than 8.4.1

- Personalization is enabled

- UCCM servers are running version later than 6

- UCCM servers are running properly and the network connection status is active


Any ideas?

scheived Fri, 10/08/2010 - 13:33
User Badges:

Just a shot in the dark but try downgrading your phone's firmware version, I've had that clear up some other issues.

Lamar Demby Fri, 10/08/2010 - 14:03
User Badges:

Phone was at SCCP45.9-0-3S.  Backed it down to SCCP45.8-5-4S...works like a charm.  We also had an issue with Corporate Directory not working...Host Not Found error.  This fixed that too!  So much for the new firmware load.


I appreciate the feedback...Thx.

Christos Georgiadis Fri, 11/19/2010 - 14:31
User Badges:
  • Silver, 250 points or more

Can you try the following ?


- Populate the "Owner ID" field on the phone admin page
- Enabled "Web Access" on the phone admin page
- Disable and re-enable "Personalization" on the phone admin page
- Restart the Tomcat service in CUCM which hosts the Server side of the Phone Designer.


HTH,

Christos

gstrobel78 Fri, 07/15/2011 - 08:02
User Badges:

We, too, were receiving the "personalization disabled" with Phone Designer on our SCCP75.9-0-3S phones running CM 8.0.3.20000-2, with all personalization enabled.


It appears Phone Designer on CM 8.0+ won't work if the CCMCIP Service (in Phone Designer) is set to your Publisher. Please change this to your Subscriber IP address. It worked like a charm, and no, we did not have to downgrade our firmware.

Ken Douglas Fri, 10/28/2011 - 10:21
User Badges:

Pointing to a subscriber fixed our problem with Phone Designer message "personalization disabled" All our 7962 and 7942 Cisco IP phones on our CUCM 8.5 cluster are now able to use Phone Designer.


Thanks George!

Lamar Demby Thu, 12/20/2012 - 06:00
User Badges:

Our Designer has always been pointed to the Subscriber.  As scheived  noted at that time, downgrading the phone firmware did fix our issue, so whichever works...roll with it.

Actions

This Discussion

Related Content