Can the same voice vlan be in two different data vlan configurations?

Answered Question
Sep 9th, 2010

In our 3750s and 6500s access layer switches we have the standard VoIP configuration on the switch ports as shown below:

interface GigabitEthernet1/5
switchport
switchport access vlan 14
switchport mode access
switchport voice vlan 910
load-interval 30
mls qos trust dscp
no cdp enable
spanning-tree portfast

interface Vlan14

description data vlan
ip address 192.168.100.1 255.255.255.128
ip helper-address 192.168.3.100
ip pim sparse-mode
load-interval 30
end

interface Vlan910

description voice vlan
ip address 172.18.100.1 255.255.255.128
ip helper-address 192.168.3.100
end

Now, for special reasons, I need to put some of the host PCs on a different data vlan but keep their connected IP phones on the same voice vlan as all the other phones....as shown below:

interface GigabitEthernet1/6
switchport
switchport access vlan 20
switchport mode access
switchport voice vlan 910
load-interval 30
mls qos trust dscp
no cdp enable
spanning-tree portfast

interface Vlan20

description data vlan
ip address 192.168.200.1 255.255.255.128
ip helper-address 192.168.3.100
ip pim sparse-mode
load-interval 30
end

So my question is, does it cause any problems to have switchports configured with different data vlans, but with the same voice vlan?

I have this problem too.
0 votes
Correct Answer by dfokin about 6 years 4 months ago

Yoy may use any combination of data and voice VLAN's on any port around your network. There is no rules, that restrict this (except one: data vlan != voice vlan)

So, your proposed configuration is correct, except one thing: cdp must be enabled. Because the Cisco Unified IP Phone uses CDP to communicate  information such as auxiliary VLAN ID, per port power management  details, and Quality of Service (QoS) configuration information with the  Cisco Catalyst switch.

interface GigabitEthernet1/5
switchport
switchport access vlan 14
switchport mode access
switchport voice vlan 910
load-interval 30
mls qos trust dscp
no cdp enable
spanning-tree portfast

interface GigabitEthernet1/6
switchport
switchport access vlan 20
switchport mode access
switchport voice vlan 910
load-interval 30
mls qos trust dscp
no cdp enable
spanning-tree portfast

Correct Answer by William Bell about 6 years 4 months ago

You can have ports assigned to different data vlans but share a common voice

vlan. No issues.

HTH.

Regards,

Bill

On 9/9/10 10:58 AM, "jkeeffe"

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (3 ratings)
Loading.
Correct Answer
William Bell Thu, 09/09/2010 - 08:31

You can have ports assigned to different data vlans but share a common voice

vlan. No issues.

HTH.

Regards,

Bill

On 9/9/10 10:58 AM, "jkeeffe"

Correct Answer
dfokin Thu, 09/09/2010 - 08:33

Yoy may use any combination of data and voice VLAN's on any port around your network. There is no rules, that restrict this (except one: data vlan != voice vlan)

So, your proposed configuration is correct, except one thing: cdp must be enabled. Because the Cisco Unified IP Phone uses CDP to communicate  information such as auxiliary VLAN ID, per port power management  details, and Quality of Service (QoS) configuration information with the  Cisco Catalyst switch.

interface GigabitEthernet1/5
switchport
switchport access vlan 14
switchport mode access
switchport voice vlan 910
load-interval 30
mls qos trust dscp
no cdp enable
spanning-tree portfast

interface GigabitEthernet1/6
switchport
switchport access vlan 20
switchport mode access
switchport voice vlan 910
load-interval 30
mls qos trust dscp
no cdp enable
spanning-tree portfast

Actions

This Discussion