PIX 515e DHCP options

Unanswered Question
Sep 9th, 2010

/* Style Definitions */ table.MsoNormalTable {mso-style-name:"Table Normal"; mso-tstyle-rowband-size:0; mso-tstyle-colband-size:0; mso-style-noshow:yes; mso-style-priority:99; mso-style-qformat:yes; mso-style-parent:""; mso-padding-alt:0in 5.4pt 0in 5.4pt; mso-para-margin:0in; mso-para-margin-bottom:.0001pt; mso-pagination:widow-orphan; font-size:11.0pt; font-family:"Calibri","sans-serif"; mso-ascii-font-family:Calibri; mso-ascii-theme-font:minor-latin; mso-fareast-font-family:"Times New Roman"; mso-fareast-theme-font:minor-fareast; mso-hansi-font-family:Calibri; mso-hansi-theme-font:minor-latin; mso-bidi-font-family:"Times New Roman"; mso-bidi-theme-font:minor-bidi;}

In the Cisco PIX (version 7.2) CLI, I’ve been trying to set the dhcp options so that the PIX can run as a DHCP server on the inside interface.  I can set all the options correctly except for option 130.  Below are my failed attempts to set option 130 to the value 'MITEL IP PHONE'.  The problem is that the CLI does not accept spaces.  Attached is the PIX running config file.

pixfirewall(config)# dhcpd option 130 ascii MITEL IP PHONE


ERROR: % Invalid input detected at '^' marker.

pixfirewall(config)# dhcpd option 130 ascii "MITEL IP PHONE"

Too many ASCII strings

Usage: dhcpd address <ip1>[-<ip2>] <srv_ifc_name>

        dhcpd dns <dnsip1> [<dnsip2>] [interface <srv_ifc_name>]

        dhcpd wins <winsip1> [<winsip2>] [interface <srv_ifc_name>]

        dhcpd lease <lease_length> [interface <srv_ifc_name>]

        dhcpd ping_timeout <timeout> [interface <srv_ifc_name>]

        dhcpd domain <domain_name> [interface <srv_ifc_name>]

        dhcpd option <code> {ascii <string> | hex <hex_string> |

                ip <address_1> [<address_2>]} [interface <srv_ifc_name>]

        dhcpd enable <srv_ifc_name>

        dhcpd auto_config <clnt_if_name> [interface <srv_ifc_name>

        dhcpd update dns [both] [override] [interface <srv_ifc_name>]

        show dhcpd [binding|statistics]

        clear dhcpd

        clear dhcpd [binding|statistics]

pixfirewall(config)# dhcpd option 130 ascii 'MITEL IP PHONE'


ERROR: % Invalid input detected at '^' marker.


The option must be "MITEL IP PHONE" (minus quotes) in order for the Mitel phone to accept the value and the DHCP offer.

Any ideas?


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
mirober2 Thu, 09/09/2010 - 11:08


The variable cannot contain whitespace. The output of 'help dhcpd' shows:

        ASCII string without whitespace

Unfortunately there is no way to specify a string that contains whitespace, so if your phone requires a certain string it would seem that this won't be supported.

Hope that helps.



This Discussion

Related Content