uccx 8 - IPPA

Unanswered Question
Sep 9th, 2010
User Badges:

Hi, new install of CUCMBE 8.0(2) with UCCX 8.  We have enhanced licences and have been using CAD with no issues.  Currently trying to setup IPPA to demo to customer but keep getting error:


- Selected IP Phone Agent service is not active.  Select another IP Phone Agent service.


I have the following IPPhone service URL's configured on our CUCM:


- http://x.x.x.x:6293/ipphone/jsp/sciphonexml/IPAgentLogin.jsp - one button login


- http://x.x.x.x:6293/ipphone/jsp/sciphonexml/IPAgentInitial.jsp


IPPhone is subscribed to phone services, phone is associated to telecaster application user.  Have followed the numerous CAD config guides to no avail.


Anyone have this working?


Thanks in advance.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Aaron Harrison Thu, 09/09/2010 - 11:51
User Badges:
  • Super Bronze, 10000 points or more
  • Community Spotlight Award,

    Member's Choice, May 2015

Hi Darren


A very similar post yesterday from another forum user:  https://supportforums.cisco.com/message/3175595#3175595


I guess there's either a bug in the software, some sloppy documentation, or something not as easy as it could be here... I have an 8.0 server to build tomorrow with no need for IPPA but will test it out myself anyway.


Regards


Aaron

Darren O'Connor Thu, 09/09/2010 - 12:27
User Badges:

Hi Aaron,


Thanks for your reply.  Would be most interested in your testing tomorrow if you get the chance.  You'll love the new UCCX build, one disk and it'll be built in next to no time.


This is probably just a case of an undocumented change in URL.


Regards


Darren

Aaron Harrison Tue, 09/14/2010 - 05:43
User Badges:
  • Super Bronze, 10000 points or more
  • Community Spotlight Award,

    Member's Choice, May 2015

Hi


This worked for me as expected - you get the error you got if you are browsing to the 'inactive' server in a HA pair, but otherwise it's fine. No specific config was required for it...


Check your URLs again - you should have a service for each server in the HA pair, and use whichever service is 'master'.


Regards


Aaron

      • I have the sam issue. My UCCX is vrsion 8.0.2.11003-10 and CUCM  8.0.3.21900-8. In uccx the preferent languaje is Spanish.
      • I try check directly with my browser and see this :
      •   <?xml version="1.0" encoding="ISO-8859-1" ?>
        -
          Error
          El servicio de agente de teléfono IP seleccionado no está activo. Seleccione otro servicio de agente de teléfono IP.
         
        -
          Aceptar
          Key:Services
          1
         
         
    • You have any idea or ear any referent a bug?
Julien Chodlewski Wed, 04/27/2011 - 05:17
User Badges:

I have the same error.


The only working url's that I found are


//Login

https:[email protected]:8443/ipphone/jsp/sciphonexml/IPAgentInitial.jsp


//One Button Login

https:[email protected]:8443/ipphone/jsp/sciphonexml/IPAgentLogin.jsp



but when I try in a web browser, the response of the first one is something like :



Connexion à Agent
Entrer informations agent.

http://10.196.3.236:8443/ipphone/jsp/sciphonexml/IPAgentLogin.jsp


Nom
ID
A

....


The problem is that the url given in response don't work because the "https" is missing. (If I type "https:[email protected]:8443/ipphone/jsp/sciphonexml/IPAgentLogin.jsp in the browser" I get the same error as above)


How can we force the service to use "https url's" ? or how to make the "http url's" working ?


Thank you,


Julien


NB:

I have no response when i try :

http:[email protected]:6293/ipphone/jsp/sciphonexml/IPAgentInitial.jsp or

http:[email protected]:8080/ipphone/jsp/sciphonexml/IPAgentInitial.jsp

billybjo1 Wed, 04/27/2011 - 06:15
User Badges:

I have seen similar problems. In my case we have identified a bug that TAC have suggested might be fixed in SU4.

Basically you have to restart the BIPPA service after a reboot, even though all services appear to be running ok.

MARK BAKER Mon, 09/19/2011 - 10:37
User Badges:
  • Bronze, 100 points or more

The stop / start of the BIPPA service did get it working again. I gave you a 5 star for pointing this out. This still needs to be fixed though.


Thanks,
Mark

Actions

This Discussion