weird issues with Voice gateway

Unanswered Question
Jan 29th, 2010

hi all,


not sure you can help me on this,


i have issue with Voice GW routing calls, issue like


1.normal PSTN call new office, i receive ring tone in the pstn phone and 7942 phone. however when i pick up the 7942 phone the PSTN phone just keep ringing almost like no one pickup the 7942 phone.

2. 7942 call out pstn, no ring tone in the 7942...my mobile phone get the office callerID and when i can pickup the phone but no voice on neither phones, then around 10 secs later, mymobile auto drop out. 7942 start with busy or bi bi bi bi signal.


here is some background.


i am installing a new office for our company which involve new gateway for the office.


i have setup the call manager part, which i have successfuly tested with Route list pointing to a existing gateway. everything fine.


any ideas?


thanks in advance.



here is a copy that very similar what it use in the new office.



vg#sh run

Building configuration...


Current configuration : 6345 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname

!

boot-start-marker

boot-end-marker

!

card type e1 0 0

logging buffered 51200 warnings

no logging console

enable secret 5

!

no aaa new-model

!

resource policy

!

network-clock-participate wic 0

network-clock-select 1 E1 0/0/0

!

!

ip cef

!

!

no ip domain lookup

ip domain name

ip multicast-routing

!

isdn switch-type primary-net5

voice-card 0

no dspfarm

dsp services dspfarm

!

!

!

no voice hunt unassigned-number

voice hunt user-busy

no voice hunt invalid-number

voice call disc-pi-off

voice call carrier capacity active

voice rtp send-recv

!

voice service voip

fax protocol pass-through g711alaw

h323

!

!

voice class codec 10

codec preference 1 g711ulaw

codec preference 2 g711alaw

codec preference 3 g729r8

codec preference 4 g729br8

!

!

!

voice class h323 10

h225 timeout tcp establish 3

  no call preserve

!

!

!

!

!

!

!

!

!

!

voice translation-rule 2


!

!

voice translation-profile in-called

translate calling 3

translate called 2

!

voice translation-profile out-calling

translate calling 4

!

!

!

!

!

!

controller E1 0/0/0

pri-group timeslots 1-31

description PRI Circuit to TTT

!

!

!

!

interface GigabitEthernet0/0

description to XXXX

ip address 10.33.64.20 255.255.192.0

ip pim sparse-dense-mode

ip igmp join-group 239.1.1.1

duplex auto

speed auto

media-type rj45

h323-gateway voip interface

h323-gateway voip bind srcaddr 10.33.64.20

!

interface GigabitEthernet0/1

no ip address

duplex full

speed 100

media-type rj45

!

interface Serial0/0/0:15

no ip address

encapsulation hdlc

no logging event link-status

isdn switch-type primary-net5

isdn incoming-voice voice

isdn bchan-number-order ascending

isdn sending-complete

no cdp enable

!

ip route 0.0.0.0 0.0.0.0 10.33.64.1

!

!

no ip http server

ip http access-class 23

ip http authentication local

no ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

ip tacacs source-interface GigabitEthernet0/0

!


!

!

control-plane

!

!

!

voice-port 0/0/0:15

translation-profile incoming in-called

translation-profile outgoing out-calling

!

voice-port 0/1/0

no comfort-noise

cptone AU

timeouts interdigit 4

description FAX

!

voice-port 0/1/1

no comfort-noise

cptone AU

timeouts interdigit 4

description FAX

!

voice-port 0/1/2

no comfort-noise

cptone AU

timeouts interdigit 4

description FAX

!

voice-port 0/1/3

no comfort-noise

cptone AU

timeouts interdigit 4

description FAX

!

ccm-manager music-on-hold

!

!

sccp local GigabitEthernet0/0

sccp ccm 10.32.192.1 identifier 2

sccp ccm 10.32.192.2 identifier 1

sccp

!

sccp ccm group 1

associate ccm 2 priority 1

associate ccm 1 priority 2

associate profile 1 register CONF-VG-CRRL01

registration retries 7

registration timeout 8

keepalive retries 5

keepalive timeout 50

connect retries 5

switchback method immediate

switchback interval 15

!

dspfarm profile 1 conference

description IOS ConferenceBridge CONF-VG-CRRL01

codec g711ulaw

codec g711alaw

codec g729ar8

codec g729abr8

codec g729r8

codec g729br8

maximum sessions 4

associate application SCCP

!

!

dial-peer voice 200 voip

description To Subscriber

destination-pattern 41...

voice-class codec 10

voice-class h323 10

session target ipv4:10.32.192.2

dtmf-relay h245-alphanumeric

fax rate disable

ip qos dscp cs5 media

ip qos dscp cs3 signaling

no vad

!

dial-peer voice 201 voip

description to Publisher

preference 1

destination-pattern 41...

voice-class codec 10

voice-class h323 10

session target ipv4:10.32.192.1

dtmf-relay h245-alphanumeric

fax rate disable

ip qos dscp cs5 media

ip qos dscp cs3 signaling

no vad

!

dial-peer voice 10 pots

preference 2

destination-pattern 0.T

progress_ind alert enable 8

incoming called-number .

direct-inward-dial

port 0/0/0:15

!

dial-peer voice 41023 pots

destination-pattern 41023

fax rate disable

port 0/1/0

!

dial-peer voice 41126 pots

destination-pattern 41126

fax rate disable

port 0/1/1

!

dial-peer voice 41128 pots

destination-pattern 41128

fax rate disable

port 0/1/2

!

dial-peer voice 41187 pots

destination-pattern 41187

fax rate disable

port 0/1/3

!

dial-peer voice 20 voip

voice-class codec 10

voice-class h323 10

incoming called-number .

no vad

!

!

!

!

call-manager-fallback

secondary-dialtone 0

max-conferences 4 gain -6

transfer-system full-consult

timeouts interdigit 5

ip source-address 10.33.64.20 port 2000

max-ephones 300

max-dn 600 dual-line

!

!

!

translation-profile outgoing out-calling

call-forward pattern .T

call-forward pattern 0.T

moh flash:moon.wav

multicast moh 239.1.1.1 port 16384 route 10.33.64.20 1.1.1.1

time-format 24

date-format dd-mm-yy

!

banner login ^CCCCCC

**********************************

Unauthorised access prohibited


any unauthorised access punishable

  to maximum extent of the law


  all activites on this device

         are logged

**********************************

^C

!

line con 0

line aux 0

line vty 0 4

exec-timeout 30 0


login

!

scheduler allocate 20000 1000

ntp clock-period 17179936

ntp server 10.32.11.1 prefer

!

end


bris-vg#

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Tommer Catlin Mon, 02/01/2010 - 05:31

The ring tone you hear when you pick up the phone is a recorded sound built into the firmware of the IP phone.  Its NOT the PSTN tone.


You may have an overlap somewhere, which is why you do not hear the dial tone from PSTN.


Dial slowly and listen.  For example:


Dial 9

What do you hear? (or outside number)

then the next number

next number


eventually it show up.

Jon shaw Tue, 02/02/2010 - 15:41

hi tcalinins

thanks for the reply,


i have tried dial slow and when i dial the outside number (0) here, i get

the 2nd dial tone. then keep dial the digits with no play back. once dial

the last digit, the pstn phone start to ring. (still no ringtone sound in

VOIP phone) however once i pick it up. both side have no sound.


i'll check the route plan again also GW see if anything obvious..


cheers


On Mon, Feb 1, 2010 at 11:31 PM, tcatlinins <

Tommer Catlin Tue, 02/02/2010 - 20:17

Sounds like you have a couple things...


When you dial the last digit, the PSTN gets the call, but still do not hear ring back.   Since its h323, there seems to be a ring back issue on the h323 side.


Check this out

https://www.cisco.com/en/US/docs/ios/12_3/vvf_c/voice_troubleshooting/old/vts_h323.html


couple things to run through.


But also, since you are not hearing audio on either end, but the call is up, you have a codec transcoding issue.   When the call is connected, hit the ? twice on the IP Phone.  You shoudl be able to see the sending and receiving codec is going on.

Jon shaw Tue, 02/02/2010 - 22:57

thanks for all the help,


i think i miss to mention the GW was behind a VPN link.


and during another troubleshooting , some of the h323, skinny inspection has

been turned off. reenable the inspection all good now..


thanks

Jon


On Wed, Feb 3, 2010 at 2:17 PM, tcatlinins <

Actions

This Discussion