no syslog on device center

Unanswered Question
Sep 10th, 2010
User Badges:

Hi all,


I have test for the ws-c2960s-tc-l to unplug the cable, it can see the syslog in device center. however when i test for cisco3945 to unplug the UTP cable. it doen't show any message on device center. I can see the syslog from the log/syslog.log. why cann't it be seem by the device center. anyone had  the problem before and can give me some advice. thanks. the RME , common service, ciscoview already update.


Mike

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Joe Clarke Sun, 09/12/2010 - 01:15
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

What version of RME do you have?  How does this router appear in the RME device selectors?  If you go to RME > Reports > Report Generator, and run the Unexepcted Device syslog report do the messages show up there?

pccwmike2009 Sun, 09/12/2010 - 09:03
User Badges:

I am installed the LMS3.2 version and firstly I found that it is not support for the device of the new equipment(cisco3945,cisco2901,ws-c2960s-tc-l.etc)

then I use the common service--->device update to update the RME,ciscoview, and also common service. after that, it can select the new equipment from common service---->device management. then I add the device of cisco 3945 and ws-c2960s-tc-l for test, however, it only have the log for 2960 but not cisco3945 from the device center.

when I generate a 24 hour report for syslog on cisco3945 , there have no any log, but if I generate a for example 12-sep-10 to 12-sep-10 report , it can so the syslog for the past 24 hour.

Joe Clarke Sun, 09/12/2010 - 10:19
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

I'm not sure I follow.  When you run a 24-hour report, you see no messages for the 3945, but you do see messages for this same 3945 if you uncheck the 24-hour box and specify a date range that covers today?

pccwmike2009 Sun, 09/12/2010 - 18:26
User Badges:

Yes, if I specify the range of today , it can see the syslog. but in 24 hours

report, it cannot see anything.

Joe Clarke Sun, 09/12/2010 - 18:28
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Post some samples of 3945 syslog messages from the syslog.log.

pccwmike2009 Tue, 09/14/2010 - 18:37
User Badges:

syslog.log have been attached

.


more I have caputre the 24 hour report and the syslog message report. you can see 24 hour doesn't have log but syslog message report have the message


Regards

Mike

Attachment: 
Joe Clarke Tue, 09/14/2010 - 21:49
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

The timezone HKT is not know to RME.  Try adding HKT (and the proper UTC offset) in NMSROOT/MDC/tomcat/webapps/rme/WEB-INF/classes/com/cisco/nm/rmeng/fcss/data/TimeZone.lst, then restart SyslogCollector and SyslogAnalyzer.  See if new messages show up properly:


pdterm SyslogCollector SyslogAnalyzer

pdexec SyslogCollector SyslogAnalyzer

pccwmike2009 Sun, 09/19/2010 - 19:56
User Badges:

Thanks a lot to Joseph , it is ok now after add the HKT in the file. however, I want to know why the HKT is not install as default setting which need to add later.


Regards

Mike

Joe Clarke Sun, 09/19/2010 - 20:27
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Only timezones that could be tested by development were added to the file by default.  However, it is perfectly acceptable to add any timezone you would like to this file.

pccwmike2009 Sun, 09/19/2010 - 20:40
User Badges:

why it is not affect to other device??? only 3945 not support?? and also I think HKT is common, so it should be tested and add as default.


Regards

Mike

Joe Clarke Sun, 09/19/2010 - 20:50
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

I only saw that the timezone was being sent from the 3945.  I didn't see any other devices with the HKT timezone in the message itself.

pccwmike2009 Sun, 09/19/2010 - 21:19
User Badges:

I have add the ws-c2960s-tc-l for test before, the ip is 10.62.83.248, it is no HKT is the message, the equipment is show ok, why it is not affect by HKT not set??


Regards,

Mike

Joe Clarke Sun, 09/19/2010 - 21:50
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

In order to have the timezone appear in syslog messages, you need to configure:


service timestamps log datetime localtime show-timezone

Actions

This Discussion