Adding QoS to 877 Router Interface

Answered Question
Sep 10th, 2010

I am currently setting up a 877 model DSL Router to use with a VOIP phone system.  I am needing to setup QoS for the phone traffic to give certain udp ports priority going over the dsl.  I have my ATM0 interface in bridge-group 1 and I have the BVI1 inteface configured.  Internet service works until  I try to apply the "Service-Policy out" command to the BVI1 interface.  Once I do apply it to that interface and the internet service goes down, I then do a show run policy-map interface BVI1 and I can see where it is getting packet matches.  Only thing is the internet no longer works.  If I try to instead apply the QoS to the ATM0 interface, the internet stays up but when I do show run policy-map int ATM0 there are no packet matches.  It is if the QoS does not work on that interface.  Any suggestions?  Below are some of the QoS configurations.  Thanks.

access-list 2000 permit udp any eq 3479 any

access-list 2000 permit udp any any eq 3479

access-list 2000 permit udp any eq 5199 any

access-list 2000 permit udp any any eq 5199

access-list 2000 permit udp any eq 5060 any

access-list 2000 permit udp any any eq 5060

Class-map match-any VOIP-Priority-Traffic

Match access-group 2000

Policy-Map Packet-Queueing

Class VOIP-Priority-Traffic

Priority percent 33

I have this problem too.
0 votes
Correct Answer by Lei Tian about 6 years 1 month ago
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Giuseppe Larosa Fri, 09/10/2010 - 12:19

Hello Mitchell,

may you add the configuration of the DSL ATM interface, BVI and  show ver | inc image?

I'm afraid you are in trouble here.

Hope to help


Lei Tian Sat, 09/11/2010 - 03:55


Not sure if you have NAT or crypto on WAN interface, if you do then it might be the reason you dont see packet matches.


Lei Tian

Mitchell Theriot Mon, 09/13/2010 - 06:46

Here are the configurations for the ATM0 and BVI1 interfaces.  The BVI1 interface is the outside NAT interface.


interface ATM0

no ip address

pvc 0/35

encapsulation aal5snap

dsl operation-mode auto

bridge-group 1

service-policy output Packet-Queueing


interface BVI1

ip address dhcp

ip nat outside

ip virtual-reassembly




This Discussion