SIP Trunk (ITSP) and MoH issue

Unanswered Question
Sep 10th, 2010

Hello everyone--i've got a client with a SIP trunk, running through CUBE.  After a painful process of getting the AA to work properly after the migration, they are having MoH issues now.  What's happening is internal users hear ringback, MoH, etc. fine; external users on the SIP trunk hear dead silence.  Any suggestions?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 0 (0 ratings)
dksingh Fri, 09/10/2010 - 12:46

Hello,

I am assuming you have CCM with IP phones on the other side of the CUBE?

Multicast MoH for PSTN SIP trunk won't work unless you do media flow around

with SDP passthrough on CUBE.

I'd recommend to use unicast MoH for SIP trunk.

Hope this helps.

DK

Scott Jones Fri, 09/10/2010 - 12:49

That does help, and yes it is callmanager. It's actually Business Edition, if that makes a difference. The MoH streams do not appear to be enabled for multicast, either, at least from what I can tell they don’t. I'm still trying to learn as I go...

Scott Jones

724.716.1096 Office

740.310.0925 Cell

jaschulz Fri, 09/10/2010 - 12:48

Hello,

So I take it the cube is providing pstn access? Could you enable the following debugs and attach and let us know the ANI and DNIS.

debug ccsip messages
dksingh Fri, 09/10/2010 - 12:56

Hello Scott,

If infact you are using unicast MoH, then it should work fine via CUBE

for the PSTN user on the SIP side (being put on hold by IP phone)

Things to check:

- Codec being used for both RTP legs (IP phone--CUBE and CUBE--ITSP)

  If using g729, have u enabled CCM to stream g729 via IPVMS service parameter?

- sh voip rtp connect

  Do that on CUBE before the call is put on hold and after. Check codec and

  verify if the 2nd output shows that its being connected to a MOH Server (CCM) and port (prob. 4000)

HTH,

DK

Scott Jones Fri, 09/10/2010 - 13:29

Ok--under the service, g.729a is enabled and here is the output from sh voip rtp connections

arin-mdf-gw1#sh voip rtp conn

VoIP RTP active connections :

No. CallId dstCallId LocalRTP RmtRTP LocalIP RemoteIP

1 57047 57048 17038 16714 10.10.5.10 10.10.5.10

2 57049 57048 16552 20980 10.10.5.10 10.10.5.176

3 57083 57084 18792 24704 152.179.37.230 63.97.104.196

4 57084 57083 16960 20428 10.10.5.10 10.10.5.176

5 57092 57093 16750 29596 10.10.5.10 10.10.5.200

6 57093 57092 18146 24372 152.179.37.230 63.97.104.196

7 57096 57097 17666 18498 10.10.5.10 10.10.5.174

8 57097 57096 18032 35224 152.179.37.230 63.97.104.196

Found 8 active RTP connections

Scott j.

Scott Jones Fri, 09/10/2010 - 13:04

Ok.  Here is the debug.  the number that was the outside is 7403100925, and it was sent to 1263.  It's just a TXT file, forgot to put the extension on.

jaschulz Fri, 09/10/2010 - 14:16

Looking at the debug we see:

065035: Sep 10 15:54:13 EDT: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Received:
BYE sip:7403100925@10.10.5.10:5060 SIP/2.0

Reason: Q.850;cause=47

Date: Fri, 10 Sep 2010 19:53:48 GMT

From: ;tag=4484d357-b67e-416a-9c48-2d32c3b9382b-18476877

Content-Length: 0

User-Agent: Cisco-CUCM6.1

Typically this error message is indicating "no resources available" to
make the call. This could be due to a number of reasons, such as MTP,
media resources, region settings, etc... Check your MRG config, I believe it
is because a transcoder is failing to be allocated. Internal callers what are
their regions set for? I assume they are using G.711 within region. Try and change
the voice class codec on the gateway to codec preference 1 g711ulaw and test.
If calls work you know that is where your problem is.

Actions

Login or Register to take actions

This Discussion

Posted September 10, 2010 at 12:38 PM
Stats:
Replies:7 Avg. Rating:
Views:3110 Votes:0
Shares:0

Related Content

Discussions Leaderboard

Rank Username Points
1 21,026
2 15,047
3 10,314
4 7,999
5 4,856
Rank Username Points
135
90
72
55
51