cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1554
Views
0
Helpful
6
Replies

Disabling a WIC-3G?

ashkentapa
Level 1
Level 1

Hi all.

A number of my remote sites have been converted from wireless wan links (via HWIC-3G-GSM cards) to wired wan links. The 3G WICs are still in the routers and due to their remoteness are likely to stay there. I've removed all the wireless configuration that I can find:

interface Cellular0/0/0
no ip address
encapsulation ppp
shutdown
!

line 0/0/0
exec-timeout 0 0
no exec

Router#sh cellular 0/0/0 profile
* - Default profile

However the logs keep filling up with these messages:

Sep 13 14:35:08 AEST: %CELLWAN-2-MODEM_DOWN: Cellular0/0/0 modem is DOWN
Sep 13 14:35:22 AEST: %CELLWAN-2-MODEM_UP: Cellular0/0/0 modem is now UP
Sep 13 14:36:06 AEST: %CELLWAN-2-MODEM_DOWN: Cellular0/0/0 modem is DOWN
Sep 13 14:36:20 AEST: %CELLWAN-2-MODEM_UP: Cellular0/0/0 modem is now UP
Sep 13 14:37:04 AEST: %CELLWAN-2-MODEM_DOWN: Cellular0/0/0 modem is DOWN

What else do I need to do to disable the 3G WICs? Thanks.

6 Replies 6

heathrw
Level 4
Level 4

Hi,

Can you send the full configuration to see what else might be in there.

Thanks

version 12.4
service timestamps debug datetime localtime show-timezone
service timestamps log datetime localtime show-timezone
service password-encryption
!
hostname ROUTER
!
boot-start-marker
warm-reboot
boot-end-marker
!
logging message-counter syslog
logging buffered 131072
enable secret 5 xxxxxx
!
aaa new-model
!
!
aaa authentication login default group tacacs+ group radius line
aaa authentication enable default group tacacs+ enable
aaa authorization exec default group tacacs+ group radius if-authenticated
!
!
aaa session-id common
clock timezone AEST 10
dot11 syslog
ip source-route
!
!
no ip dhcp use vrf connected
ip dhcp excluded-address 10.x.x.1 10.x.x.99
ip dhcp excluded-address 10.y.y.1 10.y.y.99
!
ip dhcp pool Pool1
   network 10.x.x.0 255.255.255.0
   default-router 10.x.x.1
   dns-server 10.z.z.114 10.z.z.62
   domain-name company.com
   lease 7
!
ip dhcp pool Pool2
   network 10.y.y.0 255.255.255.0
   default-router 10.14y.y.1
   domain-name companu.com
   dns-server 10.z.z.114 10.z.z.62
   lease 7
!
!
ip cef
no ip domain lookup
ip domain name company.com
!
multilink bundle-name authenticated
!
!
key chain EIGRPKeyChain
key 1
   key-string 7 xxxxx
!
!
username admin secret 5 xxxx
archive
log config
  hidekeys
!
!
ip tcp path-mtu-discovery
ip tftp source-interface FastEthernet0/0.100
!
!
interface Loopback0
ip address 192.168.200.189 255.255.255.255
!
interface FastEthernet0/0
description Corporate LAN trunk
no ip address
ip flow ingress
duplex auto
speed auto
!
interface FastEthernet0/0.10
description Office VLAN
encapsulation dot1Q 10
ip address 10.x.x.1 255.255.255.0
ip helper-address 10.z.z.62
ip flow ingress
!
interface FastEthernet0/0.100
encapsulation dot1Q 100
ip address 10.y.y.1 255.255.255.0
ip flow ingress
!
interface FastEthernet0/1
description WAN link (512 kbps)
ip address 10.a.a.26 255.255.254.0
ip authentication mode eigrp 130 md5
ip authentication key-chain eigrp 130 EIGRPKeyChain
speed 100
full-duplex
!
interface Cellular0/0/0
no ip address
encapsulation ppp
shutdown
!
interface ATM0/1/0
no ip address
shutdown
no atm ilmi-keepalive
!
router eigrp 130
passive-interface default
no passive-interface FastEthernet0/1
network 0.0.0.0
no auto-summary
eigrp stub connected summary
neighbor 10.a.a.12 FastEthernet0/1
neighbor 10.a.a.11 FastEthernet0/1
neighbor 10.a.a.2 FastEthernet0/1
neighbor 10.a.a.1 FastEthernet0/1
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
ip flow-cache timeout inactive 10
ip flow-cache timeout active 5
ip flow-export version 5
!
ip tacacs source-interface Loopback0
!
ip radius source-interface Loopback0
logging trap debugging
logging 10.a.a.102
logging 10.a.a.67
access-list 8 remark SNMP & RSH access
access-list 8 permit 10.a.0.0 0.0.15.255
access-list 8 permit 10.b.0.0 0.0.15.255
!
!
!
!
snmp-server community xxxx RO 8
tacacs-server host 10.a.a.93 key 7 xxxx
tacacs-server host 10.a.a.59 key 7 xxxx
tacacs-server directed-request
radius-server host 10.a.a.139 auth-port 1645 acct-port 1646 key 7 xxxx
!
control-plane
!
banner login ^C

THIS IS A PRIVATE COMPUTER SYSTEM --- USAGE MAY BE
MONITORED AND UNAUTHORIZED ACCESS OR USE MAY RESULT
IN CRIMINAL OR CIVIL PROSECUTION

^C
!
line con 0
location xxxx

exec-timeout 60 0
password 7 xxxx
line aux 0
line 0/0/0
exec-timeout 0 0
no exec
line vty 0 4
location xxxx
exec-timeout 60 0
password 7 xxxx

line vty 5 15
location xxxx
exec-timeout 60 0
password 7 xxxx

!
scheduler allocate 20000 1000
ntp server 10.a.a.93
end

ashok_boin
Level 5
Level 5

Hi,

Can you try by switching off GSM Radios through gsm radio off command or by removing modem profiles?

http://www.cisco.com/en/US/docs/routers/access/1800/1861/software/feature/guide/mrwlsgsm.html

Regards...

-Ashok.


With best regards...
Ashok

Hi Ashok.

Thanks for your suggestions. I've already tried deleting the modem profile but it didn't stop the errors. As you can see from the output below there are no remaining cellular profiles:

ROUTER#sh cellular 0/0/0 profile
* - Default profile
ROUTER#

I've tried to turn off the radio but I can't access the controller in order to run the command. I can do a "sh controller" on it:

ROUTER#show controllers cellular 0/0/0

Interface Cellular0/0/0
HSDPA/UMTS/EDGE/GPRS-850/900/1800/1900/2100MHz unit 0,
HWIC cellular modem configuration:
---------------------------
etc...

But I can't enter controller configuration mode:

ROUTER(config)#con?
config-register  configuration  connect  control-plane

ROUTER(config)#

So I can't actually run the "gsm radio off" command. The routers are 1841s with wic-3g-gsm WICs in them. There must be some other method for accessing the cellular controller on these boxes. I'll keep looking. Thanks.

james.mirtsis
Level 1
Level 1

Sometimes the commands are hidden, have you tried typing the full command regardless of whether it shows up on the help?

ROUTER(config)#controller cellular 0

also do a show priv, you will need to be priv 15. The only other way to shut it down is to remove it from the chasis.

Hi James.

Thanks for your response. I am indeed running at privilege level 15:

ROUTER#sh priv
Current privilege level is 15

Yet the "controller" command is not available:

ROUTER(config)#controller cellular 0
                        ^
% Invalid input detected at '^' marker.

I think I'm just going to have to get used to seeing those errors in the logs

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card