Cisco 1941 Router....IOS for IP Sla Monitor

Answered Question
Sep 13th, 2010


I have cisco 1941 Router with IOS "c1900-universalk9-mz.SPA.150-1.M1.bin"

But it shows only..

Router(config)#ip sla ?
  key-chain  Use MD5 authentication for IP SLAs Control Messages
  responder  Enable IP SLAs Responder

Which IOS would be require for the feature?


I have this problem too.
0 votes
Correct Answer by Lei Tian about 6 years 1 month ago


No need to upgrade the IOS, the features are in the code. You need to buy the data license to active the feature. You can use the evaluation license to test the feature, but eventually you need the license to active the feature.


Lei Tian

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Lei Tian Mon, 09/13/2010 - 03:37


Can you do a "show ver" and check your license. IP SLA requires data license package.


Lei Tian

arjunsawant Mon, 09/13/2010 - 03:51


Thanx a lot...

I have IP Base license..

License Info:

License UDI:

Device#   PID                   SN
*0        CISCO1941/K9          FHK140971GF

Technology Package License Information for Module:'c1900'

Technology    Technology-package          Technology-package
              Current       Type          Next reboot
ipbase        ipbasek9      Permanent     ipbasek9
security      None          None          None
data          None          None          None

For Data license, is it require to upgrade IOS?

Thanx...Once again


This Discussion