Catalyst Switch C4503 Cannot Boot Up

Unanswered Question
Sep 13th, 2010

My C4503 was lost track of the Username and Password. I boot from ROMMON. Tried to use confreg 2142 to skip password but it also not works.

I entered to ROM monitor and activated the command Clear Configuration All. This caused me cannot boot normally to the normal User Exec mode and the switch now always boot to ROM monitor.

How to resolve this problem?

Please help. Thanks!

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
glen.grant Tue, 09/14/2010 - 04:44

   If your image is in bootflash you should be able to just enter  "boot bootflash:   at the rommon prompt  then hit enter and it should load the image . Depending on how the config register is set you may have to enter a boot statement to the config once the image loads .  If you use 0x2102 you will need a boot statement , if you use 0x2101 it should automatically find the first image in bootflash and load it .

Tang-Suan Tan Tue, 09/14/2010 - 07:56

Hi Glen :

Thanks for your advice.

I managed to auto-boot up the first image by 0x2101. I tried also to disable the username and password prompt by 0x2141 ( enable the 0 1 2 3 4 5 6th bit ) for bypassing the password, it does not work. ( I have tried also 0x2142 and it doesn't work too ).

How to disable the prompting of username and password in the startup config?

Please help if you know. Thanks!


thomas-burke Tue, 09/14/2010 - 08:19

if you watch the boot process, you see that it is a two stage boot up. loads IOS to the switching module first and then loads it to the MFSC card. the config is saved on the MFSC. so let the switch load first and the do your break sequence before the MFSC load.

that will get you into the rommon of the mfsc card. thats where you set the confreg to 2141. that should bypass the password

Tang-Suan Tan Tue, 09/14/2010 - 08:57

Hi Thomas :

Refer to pic above : I press CTRL C or CTRL Break at the place just after or just before Exiting to ios. It cannot prompt out the ROMMON so that I can set 0x2141.

Any advice?

Thanks and best regards.

Tang-Suan Tan Wed, 09/15/2010 - 08:42

Hi everyone and Thomas :

I followed Thomas-Burke's instruction but couldn't have the second ROMMON after IOS loading so that to disable the username and password at the startup-config.

Anyone can help? Thanks!

Best regards.

glen.grant Wed, 09/15/2010 - 15:41

  If you use 0x2142 as the config register

it should boot to a blank config .  You then do a copy start run

command which will load the startup into running config. You  then should be able to just go into config mode and do a "no username . Change config register back to 0x2101 , write mem  then reload .  Make sure you have passwords on the vty's and a enable secret password configured before reloading.   If you cannot  send a control break or c then thats usually an issue with the terminal emulator you are using , try something like Tera Term for an emulator.

Tang-Suan Tan Thu, 09/16/2010 - 07:04

Hi Glen ;

I have tried 0x2141; 0x2142 ; also tried these two hex with advise of CTRL-C after finishing loading IOS, the username and password prompt still come out.

Have spent quite a lot of time on this problem but result is negative.

Anybody can help?




This Discussion