CAD launch external application fail

Unanswered Question
Sep 14th, 2010

Hi,

I have configured a button Task in CAD  to launch an external application but button didn't work. These application is java based.

I have tried to configured button to lauch ie or notepad and it worked.

I'm using UCCX 7.0 and CAD 6.6.

Java based Applications aren't supported?

Are there any logs that i can see what is failing?

Any suggestions?

Thanks

BestRegards

MC

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
Loading.
Aaron Harrison Tue, 09/14/2010 - 07:50

Hi

Try the logs in c:\program files\cisco\desktop\log

What is the command line used to launch your application?


Aaron

etmarcof Tue, 09/14/2010 - 12:19

Hi,

File name is lbe.bat

In cisco Agent Desktop Administrator i  just configured "C:\ldapbrowser\lbe.bat"

I add a PAUSE Comand in bat file and know i could see that:

Exception in thread "main" java.lang.NoClassDefFoundError: lbe/ui/BrowserApp
Caused by: java.lang.ClassNotFoundException: lbe.ui.BrowserApp
        at java.net.URLClassLoader$1.run(Unknown Source)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.net.URLClassLoader.findClass(Unknown Source)
        at java.lang.ClassLoader.loadClass(Unknown Source)
        at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
        at java.lang.ClassLoader.loadClass(Unknown Source)
        at java.lang.ClassLoader.loadClassInternal(Unknown Source)
Could not find the main class: lbe.ui.BrowserApp.  Program will exit.

Should i configure also java lauch?

Thanks

best Regards,

MC

How is lbe.bat configured. Oh, wait - I have that. I think I modified this already to use Java in a special place.

@echo off

set OPTIONS=

if "%1%" == "fix13" goto fix13

goto setjava

:fix13

set ARG1=

set OPTIONS=%OPTIONS% -Xbootclasspath/p:lib\ldap.jar;lib\jndi.jar;lib\providerutil.jar;lib\ldapbp.jar

:setjava

set ARG1=%1

if "X%JAVA_HOME%" == "X" goto nojavahome

set JAVA="C:\Program Files\Java\jdk1.5.0_17\jre\bin\java"

goto run

:nojavahome

set JAVA=java

:run

%JAVA% %OPTIONS% -jar lbe.jar %ARG1% %2 %3 %4 %5 %6 %7 %8 %9

This is way too complicated. Set it up in a simpler way - make your own batch file. The problem is with the classpath - it's relative and that won't work. Set it up in an explicit manner. Try a modification of this - fix it to where you have Java and where you have the LDAP Browser installed. This should all be on the same line.

C:\"Program Files"\Java\jdk1.5.0_17\jre\bin\java -cp C:\tools\ldapbrowser\lib\ldap.jar;C:\tools\ldapbrowser\lib\jndi.jar;C:\tools\ldapbrowser\lib\providerutil.jar;C:\tools\ldapbrowser\lib\ldapbp.jar -jar C:\tools\ldapbrowser\lbe.jar

Maybe you can just put this in as the launch string and avoid the bat.

Why would an agent want an LDAP browser? Are you passing something to this?

Regards,

Geoff

etmarcof Wed, 09/15/2010 - 12:57

Hi,

Thanks for your help.

I will not use LDAP browser with agent. I have just used that to test because its not working with another java application.

I have created a new bat file with you have said and it worked:

C:\"Program Files"\Java\jdk1.5.0_17\jre\bin\java -cp C:\tools\ldapbrowser\lib\ldap.jar;C:\tools\ldapbrowser\lib\jndi.jar;C:\tools\ldapbrowser\lib\providerutil.jar;C:\tools\ldapbrowser\lib\ldapbp.jar -jar C:\tools\ldapbrowser\lbe.jar

Now i will try to do smilar thing with java application that i need to configure task in Agent Desktop.

Thanks

Best Regards

MC

Actions

This Discussion