Help ! Unable to Launch ASDM from XX.XX.XX.XX

Unanswered Question
Sep 14th, 2010


we have:

ASA version:   8.0(4)23
dev mgr ver:   6.1(5)51

trying to use  ASDM launcher:   1.5.50,   running  Java 6u7 on pc.

Able to telnet and ssh to device fine.

I am getting the error  Unable to Launch ASDM from  XX.XX.XX.XX.

After launching the ASDM, and putting in credentials,  accept security cert and then gets the error

when I try to https to the same ASA insde IP,   page never loads.

here is some of the config.    I belive I have everything enable to access via  asdm and https.  but still not working.

hostname# sh ver

Cisco Adaptive Security Appliance Software Version 8.0(4)23
Device Manager Version 6.1(5)51

Compiled on Tue 03-Feb-09 20:20 by builders
System image file is "disk0:/asa804-23-k8.bin"
Config file at boot was "startup-config"

up 95 days 12 hours

Hardware:   ASA5510, 256 MB RAM, CPU Pentium 4 Celeron 1600 MHz
Internal ATA Compact Flash, 64MB
BIOS Flash AT49LW080 @ 0xffe00000, 1024KB

hostname# sh disk0:
--#--  --length--  -----date/time------  path
  152  13842432    Mar 28 2009 18:55:42  asa804-23-k8.bin
  156  7605252     Jan 12 2009 11:20:58  asdm-61551.bin

hostname# sh run
asdm image disk0:/asdm-61551.bin

http server enable
http Inside

I have this problem too.
1 vote
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Federico Coto F... Tue, 09/14/2010 - 08:33

Hi, is the only range allowed to access ASDM to the inside of the ASA according to your configuration (I assume you're trying the connection from an IP in that range).

Also, can you try opening a browser and typing https://IP_ASA (instead of using the ASDM launcher).


dluff4343 Tue, 09/14/2010 - 08:51

Yes, thanks.     that is the only net we need to access this from.

we also have:

ssh Inside

and that works fine. I can get to via ssh on that same network I am trying the asdm/https

when using https,     on IE it gets the cert error and then you accept then page just does not load.

firefox does the same.

Denis Spichkin Wed, 09/15/2010 - 06:00

By the way this issue could be related with Java problem.
To check this you need (as it was mentioned) just try to open
and if you get offer to load ASDM and then you can't execute ASDM that defently releted with JAVA.

dluff4343 Wed, 09/15/2010 - 13:25

Thanks all,

KS,  I will check that link out.


I have java 6u7,  which I have know to be good for the ASDM.    I have used the same pc w/ this java version and same ASDM launcher to get into other ASA's, but can't access this one. 

When I can I am going to reload the ASA,   I saw some post about an issue with over 1 yr uptimes,   this is only at  96 days or so, but I'm out of ideas

rmavila Fri, 09/17/2010 - 03:54

Hi Derek,

When u get the box for entering your credentials in the ASDM launcher, there will be a java button at the bottom right corner in the shape of a cup telling show java console. Click on that and u will get a display of java console . On that press 5 to set the trace level. Now enetr your credentials in the ASDM launcher and click ok. can you copy and paste the logs that come on the java console so that we can see if there is any exception. From the java logs we should be able to tell if there is java compatibility problem



Felix Bowman Thu, 09/16/2010 - 08:36


I remembered when we had just received our ASAs and I tried to access them I had a similar problem.

What I did to get it working was to update to the next minor version of the ADSM. There was a minor version upgrade on Cisco's site that went with the same version os the IOS on the ASA.

This did the trick for me. From there, I fully upgraded to the latest IOS and ADSM through the web interface.

I hope this helps.

roger-jonsson Fri, 09/17/2010 - 14:29

If it still does not work... Try to delete the ASDM cache. Under the current users user profile, there is a .asdm folder. Delete it and try again:)

// Roger


This Discussion