Presence - Desk Phone = Not Connected - Invalid Credentials

Unanswered Question
Sep 14th, 2010

Trying to get CUPC Desk Phone Control working.  Everything else seems to be working fine.  Logging in, Controlling IP Communicator via CUPC, Searching LDAP directory, etc.  I am using CUPS version 7.0.8, CUPC 7.1, CUCM 8.0.3.  CUCM is using local user accounts (no LDAP Integration to Active Directory on the CUCM side).  CUPS is pulling user information from AD LDAP.  I am using the GC port number, though since I'm not using LDAP for my CUCM users I don't know if that matters.  As others have suggested I have changed the CTI timer from 5 to 300 and reset the CTI service on both CUCM servers.  I have verified that my users are associated with their own phones, made sure they are members of Standard CTI Enabled, made sure allow control of CTI device is checked on the user, and allow control from CTI on the phone is checked.  Users have been associated with DN's, so all of that stuff should be good.  When I check server health I see the following (screen shot attached):

Screen shot 2010-09-14 at 3.52.12 PM.png

Am I running into a version issue?  The Compatibility guide for CUPS 7.x only lists as far as 7.1(3) and makes no metion of 7.1(5) or 8.x, so I'm not sure if it hasn't been updated in a while or what.

Any help would be appreciated.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Chris Schuerger Fri, 09/17/2010 - 06:58

I opened up a TAC case on the issue and this is what we found out:

first of all, CUPS 7.x is NOT officially supported with CUCM 8.x, however we did get it working.

In this enviornment I am pointing CUPS to AD, but I'm not doing AD integration with CUCM (for now).  This will work as long as the extensions and the user names in the CUCM directory match what CUPS sees in LDAP, and according to TAC, this can be case sensitive.  The issue was that when I imported my users into CUCM they were set for "Change Password at next login".  All I had to do was uncheck that checkbox and desktop phone control started working.


This Discussion