One Way Audio After Router Reboot

Answered Question
Sep 14th, 2010
User Badges:

Really looking for some help on a very strange issue I'm having.


Customer has a 2800 series router connected through 2 FXO cards (7 extensions) to their local phone system. Seven remote sites have a 1751 router connected through a single FXO port (as CO line) to their own phone system. This is a analog--->digital---->analog setup to utilize their antiquated phone systems through their network for VOIP inter-office calling.


Reprogramming for these routers was basically thrown in my lap (I'm the premise phone vendor), after the new IT company told them they do not support Cisco. I bit the bullet and gave myself a crash course in Cisco 101 and was successful in reconfiguring the routers for the new IP address scheme 3 months ago. Functionality was perfect.


Today, the 2800 was accidentally power cycled and now there is one-way audio only for inter-office calls. I've checked the configs, rebooted, etc. Still no luck.


I spent an hour on the phone with the local IT support and we could not find any problems with the routing. I am able to ping all the outside routers from the 2800 and vice-versa. Yet, if a place a call to one of the remote sites, I can hear them but they are unable to hear me.


Am I looking at a hardware issue here? My experience has been that one-way audio issues are inevitably network related, but there have been no changes to the network. Only the power cycle on the 2800.


I've attached a copy of the 2800 config if you're interested in seeing it. Please note though, this EXACT config worked flawlessly up until the 2800 was rebooted.



ANY help would be surely appreciated.


--

Dan

Correct Answer by David Smith about 6 years 8 months ago

Here's your problem, see below in bold:


mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
ip subnet-zero
no ip routing
no ip cef


You need IP routing enabled in order to pass TDM voice through codec on the DSP then wrap RTP in IP...otherwise you get one way audio.  IP-->TDM works, TDM-->IP does not.


Before enabling this make sure you have your default route set or else you'll lose connectivity:


ip default-gateway 10.1.150.1

ip route 0.0.0.0 0.0.0.0 10.1.150.1
ip classless


Also, it's not a bad idea to enable "cef" as right now your process switching all packets.


It was all probably configured before, but wasn't saved...and lost after reboot.


Make sure your config register under "sho run" is:


Configuration register is 0x2102


If not then do:


conf t

config-register 0x2102




-Dave

Correct Answer by dksingh about 6 years 8 months ago

Can u try adding following and test again?


ip route  0.0.0.0   0.0.0.0  10.1.150.1

ip routing

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.7 (3 ratings)
Loading.
dksingh Tue, 09/14/2010 - 13:49
User Badges:
  • Cisco Employee,

Hi there,


Here is your problem:


ip subnet-zero
no ip routing  <------ !!!!
no ip cef
!


Get rid of this by entering IP routing CLI on 2800 at global config (config t) prompt and test again.


Hope this helps.

DK

testeven Tue, 09/14/2010 - 13:52
User Badges:
  • Cisco Employee,

Oops! i didn't see that lol

alltronics Tue, 09/14/2010 - 14:46
User Badges:

Hey, thanks for the quick reply.


Yeah, I tried turning IP routing on earlier today, but it resulted in the calls not ringing through at all. When the VOIP was working correctly before today, "No IP routing" was enabled. Is this setting absolutely necessary for VOIP to work? Remember, I'm a Cisco noob. If so, how did it work before today?!


Just to clarify things:


Cisco 2800 Router----Sonic Firewall-----Cable Modem----Internet-----Cable Modem-----Sonic Firewall----Cisco 1751 Router


Could something have coincidentally changed in the Comcast cable modem? Am I grasping at straws here?


Thanks again.


EDIT: Would I have to restart the router after making the IP Routing command and writing to memory?


Message was edited

testeven Tue, 09/14/2010 - 13:51
User Badges:
  • Cisco Employee,

Hi!


What happens if you get a sniffer trace from the call? If you see RTP packets between the endpoints it's probably a faulty card or a hardware issue


Regards,


Tere.

alltronics Wed, 09/15/2010 - 12:54
User Badges:

Bumping this thread... I'm on-site and could use some help!

jaschulz Wed, 09/15/2010 - 13:00
User Badges:
  • Bronze, 100 points or more

If you do a 'show call active voice brief' do you see packets incrementing on the RX and TX?

alltronics Wed, 09/15/2010 - 13:17
User Badges:

Thanks for the reply.


Here is the output from that command while a call is in progress:


Telephony call-legs: 1
SIP call-legs: 0
H323 call-legs: 1
Call agent controlled call-legs: 0
SCCP call-legs: 0
Multicast call-legs: 0
Total call-legs: 2
11E1 : 1 454580ms.1 +6870 pid:31 Answer 702 active
dur 00:00:02 tx:434/72912 rx:433/69280
Tele 0/0/0 (1) [0/0/0] tx:1895/1895/0ms g711ulaw noise:-61 acom:14  i/0:-63/-49
dBm

11E1 : 2 454600ms.1 +6850 pid:2 Originate 102 active
dur 00:00:02 tx:100/16000 rx:434/69440
IP 10.1.154.2:16730 SRTP: off rtt:0ms pl:5035/0ms lost:0/0/0 delay:65/65/65ms g
711ulaw
media inactive detected:n media contrl rcvd:n/a timestamp:n/a
Telephony call-legs: 1
SIP call-legs: 0
H323 call-legs: 1
Call agent controlled call-legs: 0
SCCP call-legs: 0
Multicast call-legs: 0
Total call-legs: 2


Also, I tried enabling "IP Routing", but this results in my inability to ping the remote routers. If a call is made with this enabled, the call just rings with no answer.


--

Thanks!

Correct Answer
dksingh Wed, 09/15/2010 - 13:28
User Badges:
  • Cisco Employee,

Can u try adding following and test again?


ip route  0.0.0.0   0.0.0.0  10.1.150.1

ip routing

Correct Answer
David Smith Wed, 09/15/2010 - 13:33
User Badges:
  • Cisco Employee,

Here's your problem, see below in bold:


mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
ip subnet-zero
no ip routing
no ip cef


You need IP routing enabled in order to pass TDM voice through codec on the DSP then wrap RTP in IP...otherwise you get one way audio.  IP-->TDM works, TDM-->IP does not.


Before enabling this make sure you have your default route set or else you'll lose connectivity:


ip default-gateway 10.1.150.1

ip route 0.0.0.0 0.0.0.0 10.1.150.1
ip classless


Also, it's not a bad idea to enable "cef" as right now your process switching all packets.


It was all probably configured before, but wasn't saved...and lost after reboot.


Make sure your config register under "sho run" is:


Configuration register is 0x2102


If not then do:


conf t

config-register 0x2102




-Dave

alltronics Wed, 09/15/2010 - 13:50
User Badges:

David and Dilip you guys are my heroes! Have a virtual beer on me!


As soon as I saw that IP Route line, I recognized it immediately. Must have added that after my last "write memory" on the initial programming trip.


Have 5 great days, fellas!


--

Dan

Actions

This Discussion