Phones will not upgrade

Unanswered Question
Sep 14th, 2010

Hello All,

I have a wierd problem. I have recently found out that phones cannot upgrade (7942 or 7962) their firmware. I stood up a site about two weeks ago remotely and was able to have the phones (7911 and 7962) upgrade the firmware to SCCP42.8-5.2SR1S with no isues. Today I have had two give me problems and I'm wondering if the file itself may be corrupted? Or I could always reboot the cluster first, anyone seen this?

We are running ver 7.1.3.30000-1.

Thanks.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Tapan Dutt Tue, 09/14/2010 - 18:14

Do you see any error messages on the phone when it tries to upgrade. What is the firmware on the device default page of the call manager for 7942 and 7962 phones. What firmware do you see on the phones itself?

j.mccartney Tue, 09/14/2010 - 18:38

The phone attempts to upgrade then starts to restart and then gets the Cisco logo on the screen and sits there with a "bulls-eye" to the bottom left. The default firmware is SCCP42.8-5-2SR1S. The phones that I'm trying to upgrade had firmware of SCCP42.8-3-5S from ver 6.1.3 before upgrading to 7.1.3. I did restart the tftp service tonight and will try again tomorrow to upgrade the phones.

As I said before I added new phones with no issues over the WAN and they worked fine, not sure why they work but local (old phones) do not.

Thanks for your help.

Jonathan Schulenberg Wed, 09/15/2010 - 03:57

The new phones you added likely had a firmware of 8.5.2 or later which is why they worked. There was a critical notice in the UCM 7.1.3 release notes that stated you must upgrade all phones to 8.5.2 (not 8.5.2SR1) before they will accept any firmware beyond that (e.g. 8.5.2SR1). You will need to load them to 8.5.2 first. After that, I suggest you upgrade all the phones to 8.5.3 or 8.5.4 to resolve several known issues with 8.5.2.

j.mccartney Fri, 09/17/2010 - 07:21

Hello Jonathan,

I tried what you suggested, and filled the field "Phone Load Name" with SCCP42.8-5-2S" to tell the phone which load to use but I had the same results. Isn't that the correct place under device - phone to instruct the phone what file to look for on the TFTP?

Thanks.

John

rob.huffman Fri, 09/17/2010 - 07:31

Hey John,

That is the right location my friend

When you loaded the new 8.5(2) firmware on box via Software Upgrades

did you restart TFTP after? Then changed the Load info on the phones in question

and gave them a full re-boot?

Cheers!

Rob

j.mccartney Fri, 09/17/2010 - 07:33

Hi Rob,

Yes, I did restart the TFTP server when i did my upgrade a couple of months ago. I actuall did that a couple of days ago too just to rule that out. I think I'm going to reboot the cluser over the weekend and try it again on Monday.

Thanks for your help and have a great weekend.

John

Phillip Ratliff Fri, 09/17/2010 - 11:33

The next step would be a packet capture taken behind the phone (with span to pc port enabled) to see what the phone is doing when it gets stuck.

j.mccartney Tue, 09/28/2010 - 07:04

Hi Jonathan,

I finally got the phones to upgrade to 8-5-2SR1S, I've encountered some phones that for some reason reboot and get a blank screen. To get them back to normal I have to do a reset. So I think I'm going to upgrade them, have you found 8.5.3 or 8.5.4 to be more reliable?

Thanks.

John

shabbarbabrawala Wed, 09/15/2010 - 00:55

Hi

I have a similar problem wher one of our 7945 phones will not upgrade, phone keeps restarting saying upgrading but no luck for the past 10 days.

rob.huffman Fri, 09/17/2010 - 13:15

Hey John,

Just to be clear, it didn't seem like you would have had the 8.5(2)

firmware on box before this thread started, so after downloading it

from CCO and using the Software Upgrade etc. Did you stop start

TFTP at that point.

Sorry to be a pain

Cheers!

Rob

j.mccartney Fri, 09/17/2010 - 13:43

No I appreciate the help, I'm the one being a pain.

Here is what happened, we were at 6.1.3 and around Memorial day I upgraded to 7.1.3. The phones I'm having an issue with were put away beacuse their users were RIF'd or they left and the phones were put in storage. The firmware they had was SCCP42.8-3-5S. Let me try and upgrade to SCCP42.8-4-2S and see what happens.

Thanks again.

Actions

This Discussion