voice vlan - access mode / native vlan - mode trunk

Unanswered Question

Hello,

I'm having trouble splitting voip traffic from the data traffic.  I am using a 5505 asa and 3560 switches

ASA 5505 > catalyst 3560 > IP phone > laptop

on the ASA 5505

------------------------

I configured 4 Vlan's

1 for management

1 for outside

interface Vlan200 (data)
nameif Inside
security-level 100
ip address 10.0.31.15 255.255.255.0
!
interface Vlan400 (voice)
nameif VOIP
security-level 100
ip address 10.20.31.15 255.255.255.0

I configured one trunk port on a non-POE port 0/2

interface Ethernet0/2
description Trunk port to SW1
switchport access vlan 400
switchport trunk allowed vlan 200,400
switchport trunk native vlan 200
switchport mode trunk

On the 3560 switch

I configured one trunk on a POE port that connects to the ASA 5505

switchport trunk encapsulation dot1q
switchport trunk native vlan 200
switchport trunk allowed vlan 200,400
switchport mode trunk

I configured another POE port where I m connecting the IP phone (Cisco 7940 or Polycom soundpoint 501)

description Trunk port IPTEL_DATA
switchport access vlan 200
switchport mode access
switchport voice vlan 400

When connecting the IP phone to that port and connecting a laptop on the phone's switch port, the phone and PC get the correct Vlan and IP assigned but I'm not able to register the phone with our provider.

When connecting the IP phone directly on a different port on the ASA 5505 (default vlan 1) The phone immediately gets the config file and registers.

Did I trunk correctly using trunk mode for the asa 5505 to catalyst3560 and access mode for the catalyst3560 to ip-phone?

Any help is more than welcome

martin

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
dijohn Wed, 09/22/2010 - 13:39

I see config errors on the ASA and the switch

Sample TRUNK Config == have this on ASA and switch and make sure vlans exist on both the switch and ASA

Int fa0/1

sw trunk encapsu dot1q

sw mod trunk

On the port where the Phone is connected

Int fa0/2

sw mod access

sw ac vl

sw voice vl


Thats all you need to do

My 2 cents

Actions

This Discussion