IP Phones' time Not synchronized with NTP server

Unanswered Question
Sep 15th, 2010
User Badges:


Hello,


I am facing a problem with time synchronization; I have Call Manager 6.1.4.2000-2 and it is not synchronizing with the NTP server.

Our NTP server is windows based not Linux.


I checked all the NTP configuration, as you can see

NTP refrence.PNG



I chose the mode to be " Directed Broadcast"

In the Date/Time Group Configuration I added the NTP server (it is a domain controller in the network) as you can see



DateTime Group Configuration.PNG


Now when I check the Call Manager server, I find that Call Manager does not synchronize with the NTP ! it synchronizes with itself only ! as you can see




CM NTP Status.PNG


I have to restart the NTP server in order to resynchronize the time.



Please Can anyone help me?? is there anyway to use Windows server NTP or I should use Linux ?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Jonathan Schulenberg Wed, 09/15/2010 - 04:14
User Badges:
  • Super Bronze, 10000 points or more
  • Cisco Designated VIP,

    2017 IP Telephony

1) Windows is not an NTP server, it is an SNTP server. Try a real NTPv4 server. Any IOS router can also be an NTP server if configured properly.

2) Use Unicast instead of Directed Broadcast. The NTP server would have to be configured to do a Directed Broadcast and I'm sure Windows isn't.

yousefbustami Fri, 09/17/2010 - 01:59
User Badges:

Hello Jonathan,


Thank you for your reply .. I used Unicast instead of Direct Broadcast, but the problem was not solved !


Any other ideas please?

yousefbustami Mon, 09/20/2010 - 05:27
User Badges:

Thank you Mohammad,


I tried to apply the document you gave to me, useless !


Is there anyway to remove the NTP completely and use the Call Manager time, without any synchronization with any other server? in other worlds, all the extensions will read time/date from call manager itself ?

ifthi.cisco Fri, 05/17/2013 - 07:46
User Badges:

Dear Yousef,


Hope your problem is resolved. Bit late to respond you but I think other friends will try my advice if they happen to get the above problem.



In my setup, i didnt specified anything as the NTP preference. I used to Update the timings in our Core switch which I configured as the NTP server and all other Switches, Routers and call Manager as the NTP client for the Core Switch.


However, the reason why i came to this blog, we have rencetly installed dedicated, Sync Server which uses GPS to update the timings.


And right now Im pointing every device of mine towards the new NTP server.


How I added the New NTP configuration in Call Manager?


I went to Cisco Unified Operating System Administration, in Settings and NTP Server, go to Add New, Add the new IP address of the new NTP Server, Save....I have deleted the old NTP IP Addresses.


I dont have anything in the NTP preference since im using the only NTP server IP Address.


After half an hour, still the IP Phones didnt sync with NTP server.


However, whenever users are receiving calls on their IP Phone, it seems to refresh NTP timings with the new NTP server.

Nizam.Ahmed Mon, 06/27/2016 - 05:51
User Badges:

Hello,

I've configured ntp server in my voice gateway and cucm v10.5 is ntp client. I've added ntp server in cucm. but my IP communicator always getting time from my windows pc.

i've checked that, cucm is getting time from ntp server (voice gw). I want to IP communicator get time from cucm where cucm get time from ntp server(voice gateway)

please help me to resolve this issue.


thanks

nizam

Actions

This Discussion