7921 charging problems

Unanswered Question
Sep 15th, 2010

Hi there

I have a problem with anumber of the 7921 phones we have no longer charging in their docks.

If you put a fully charged battery in the phone then it will work fine, placing the phone in a dock to charge brings up a picture of a plug with a red crossed circle over it.

Any idea's? is this a common problem? It seems to be affecting our older handsets.



I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Matthew Kaufman Mon, 09/20/2010 - 19:03

Could be an issue with the hardware itself.  Do you have charging adapter, aside from the dock that you can try?

pjonessas1 Tue, 09/21/2010 - 01:58


No we only have the docks for them, I have tried other batteries and docks but get the same result.

We have sent a couple off for repairs to but they have failed each time and can not find anything wrong.

It is dissapointing that we are starting to see this cropping up more.

pjonessas1 Wed, 09/22/2010 - 07:04

Just thought I would give you an update, One of the most recent phones to develope this refusing to charge problem I have done a factory reset on it and it seesm to have cured it? the phone will now charge in the dock again!

This only seems to have worked on 1 though.

pjonessas1 Thu, 02/03/2011 - 07:18


Just thought I would bump this thread up again and see if anyone else is having similar problems.

We are still expieriencing the problem with the 7921 not charging, I currently have 5 of these in the cupboard all with the same problem, apart from not charging the devices are fine.

I do feel that this seems to be a high failure rate when we only have about 15-20 in total on site.

I have taken a picture and attached it to this thread to show you the what is being displayed.



Matthew Kaufman Thu, 02/03/2011 - 07:50

Hi Paul,

Please convert this thread to a TAC case.  We can provide you with RMA's for the devices if they're covered under contract.  If you're able to convert this case, let me know the SR number and I will pick it up for you.


pjonessas1 Tue, 02/08/2011 - 01:52

Hi Matt

Unfortunately we haven't taken out cover on the devices due to to environment they are in for example we've had one run over by a forklift and another dropped in water!

I assume the phones only come with a standard 1 year warranty? 

All the affected phones are over 12 months old, but like I said they are working fine in all other aspects apart from being able to charge and I would consider the failure rate to be quite high when you consider the cost of each handset. All in all very disappointing.

christiancihak Mon, 03/28/2011 - 06:47

Hi Paul,

we´ve got the same issue with our 7921. I tried upgrading and downgradin the firmware without effect.

Are you still working on the problem?

Thank you


pjonessas1 Tue, 03/29/2011 - 01:00

Hi Christian

I have actually managed to get the problem resolved on 4 of our phones.

In the end I again sent them into a repair firm we use who managed to fix them, they had tried on previous attempts and failed but this time they were successful.

I am not sure what they did to rectify the problem I seem to remember something about cleaning the contacts on the delivery note?

In anycase we are happy as it has only cost us £65 per phone repair (no fix no fee) as opposed to paying another £200+ for a new handset.

I would be happy to forward you on the details of the company I used?

Regards Paul

christiancihak Tue, 03/29/2011 - 01:35

Hi Paul,

thanks for the information. Please send me the contact details via pm. Hopefully they can fix our phones.

Thank you.

Regards Christian


This Discussion