Can't access Cisco CallManager Admin pages after upgrade to CUCM 8.0

Unanswered Question
Sep 15th, 2010

I upgraded one lab cluster from CUCM 6.1.2 to CUCM 8.0. The upgrade completed successfully but I cant access the admin pages after I booted from 8.0 partition. Here is what I see on ssh console for the services.

Cisco CallManager Admin[STOPPED]  Commanded Out of Service

Any thoughts/comments appreciated.

Thanks,

Mohit

Here is the list of all services on the box.

************************************************

Requesting service status, please wait...
System SSH [STARTED]
Cluster Manager [STARTED]
Service Manager is running
Getting list of all services
>> Return code = 0
A Cisco DB[STARTED]
A Cisco DB Replicator[STARTED]
Cisco AMC Service[STARTED]
Cisco AXL Web Service[STOPPED]  Commanded Out of Service
Cisco Audit Event Service[STARTED]
Cisco Bulk Provisioning Service[STARTED]
Cisco CAR DB[STARTED]
Cisco CAR Scheduler[STARTED]
Cisco CAR Web Service[STOPPED]  Commanded Out of Service
Cisco CDP[STARTED]
Cisco CDP Agent[STARTED]
Cisco CDR Agent[STARTED]
Cisco CDR Repository Manager[STARTED]
Cisco CTIManager[STARTED]
Cisco CTL Provider[STARTED]
Cisco CallManager[STARTING]  
Cisco CallManager Admin[STOPPED]  Commanded Out of Service
Cisco CallManager Cisco IP Phone Services[STOPPED]  Commanded Out of Service
Cisco CallManager Personal Directory[STOPPED]  Commanded Out of Service
Cisco CallManager SNMP Service[STARTED]
Cisco CallManager Serviceability[STOPPED]  Commanded Out of Service
Cisco CallManager Serviceability RTMT[STOPPED]  Commanded Out of Service
Cisco Certificate Authority Proxy Function[STARTED]
Cisco Certificate Change Notification[STARTED]
Cisco Certificate Expiry Monitor[STARTED]
Cisco Change Credential Application[STOPPED]  Commanded Out of Service
Cisco DRF Local[STARTED]
Cisco DRF Master[STARTED]
Cisco Database Layer Monitor[STARTED]
Cisco Dialed Number Analyzer[STOPPED]  Commanded Out of Service
Cisco DirSync[STARTED]
Cisco Extended Functions[STARTED]
Cisco Extension Mobility[STOPPED]  Commanded Out of Service
Cisco Extension Mobility Application[STOPPED]  Commanded Out of Service
Cisco IP Voice Media Streaming App[STARTED]
Cisco License Manager[STARTED]
Cisco Log Partition Monitoring Tool[STARTED]
Cisco Messaging Interface[STARTING]  
Cisco RIS Data Collector[STARTED]
Cisco RTMT Reporter Servlet[STOPPED]  Commanded Out of Service
Cisco SOAP - CDRonDemand Service[STOPPED]  Commanded Out of Service
Cisco SOAP - CallRecord Service[STOPPED]  Commanded Out of Service
Cisco Serviceability Reporter[STARTED]
Cisco Syslog Agent[STARTED]
****************************************************************

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
testeven Wed, 09/15/2010 - 11:46

Hi,

Have you tried to get access via CLI and restart the Tomcat Service manually?

utils service restart Cisco Tomcat

You can manually restart the services that way, but the access to the CUCM Admin page will depend on Tomcat.
Then you can get access through the serviceability page.

HTH

Regards,

Tere.
mohit12345 Wed, 09/15/2010 - 13:06

Thanks Tere for the response.

I tried doing it but the service keeps giving me message that its starting. However it never comes up. Intermittently I am getting following messages on my console,

Message from [email protected] at Wed Sep 15 12:39:57 2010 ...
ccm-pub local7 0 : 35: ccm-pub.clarussystems.com: Sep 15 2010 19:39:57.916 UTC :  %UC_CALLMANAGER-0-NoFeatureLicense: %[AppID=Cisco CallManager][ClusterID=CCM-PUB-Cluster][NodeID=ccm-pub]: No feature license found

Thanks,

Mohit

malnaima Wed, 09/15/2010 - 13:15

Hello Mohit,

Well the problem can be as the message says "NoFeatureLicense"...

If a "SW FeatureLicense" is not there services would have problems starting; they would start and stop after a couple of minutes.

Can you try the following:

- Remove all license files.

- Upload the licenses again (Node+Feature+DLU).

- Restart license manager and CM service or if feasable the server and test again.

Best Regards,

Mahmoud

mohit12345 Wed, 09/15/2010 - 13:21

Thanks Mahmoud for the response. I have uploaded licenses from admin pages. Is there a way to do it from CLI as I cant get to web server atll?

Thanks,

Mohit 

Jaime Valencia Wed, 09/15/2010 - 17:42

There is no way to install the licenses via CLI, and the fact you're missing the feature license should not affect your ability to open the CCMAdmin or any other page. It will only disable the ccm service until you load the license.

There might have been something wrong during the upgrade process, so you could review the upgrade logs or use the utils system command to switch-back to your old version and try the upgrade again.

HTH

java

If this helps, please rate

www.cisco.com/go/pdihelpdesk

kusatija Wed, 09/15/2010 - 23:55

Hello

I agree with Java, we might need to have a look at the upgrade logs..

but the first thing you need to focus on is on the "Cisco CallManager Admin[STOPPED]  Commanded Out of Service"

You would not be able to access admin pages if this is down..

Have you tried rebooting the box?

Reboot the box and if that does not fix the issue, after rebooting plz post the out put of:

utils service list

show status

also get us the upgrade logs.

HTH

Kunal

malnaima Thu, 09/16/2010 - 00:56

v\:* {behavior:url(#default#VML);} o\:* {behavior:url(#default#VML);} w\:* {behavior:url(#default#VML);} .shape {behavior:url(#default#VML);} /* Style Definitions */ table.MsoNormalTable {mso-style-name:"Table Normal"; mso-tstyle-rowband-size:0; mso-tstyle-colband-size:0; mso-style-noshow:yes; mso-style-priority:99; mso-style-parent:""; mso-padding-alt:0in 5.4pt 0in 5.4pt; mso-para-margin-top:0in; mso-para-margin-right:0in; mso-para-margin-bottom:10.0pt; mso-para-margin-left:0in; line-height:115%; mso-pagination:widow-orphan; font-size:11.0pt; font-family:"Calibri","sans-serif"; mso-ascii-font-family:Calibri; mso-ascii-theme-font:minor-latin; mso-hansi-font-family:Calibri; mso-hansi-theme-font:minor-latin; mso-bidi-font-family:"Times New Roman"; mso-bidi-theme-font:minor-bidi;}

Well i guess i will stick to what i said earlier 

As from what is provided so far:

- Call-Manager is reporting a problem with "feature license"

- From service list we can see: Cisco CallManager[STARTING]  not started...

But also we cannot neglect the fact that this should not render the services OOS; as i can see a number of services OOS.

I would suggest you to do the following:

1)      Remove all license files via CLI “file delete license *”.

2)      Reboot the box.

After that can you kindly update us if the you can access GUI or not.

If not I would recommend to do a repair via repair DVD and then proceed from there to solve any SW corruption that might have occured during upgrade.

kusatija Thu, 09/16/2010 - 02:46

Hello,

From what i understand, if we do not hv sw feature licenses for that version, the ccm service will not start, but that does not really effect web/admin pages..

Rebooting the box might help though, if that does not fix it, u might need to open a TAC case so that we can have access to the box to troubleshoot and fix the issue

Cheers!

Kunal

Actions

This Discussion