Only able to register one port at a time on ATA186 using SIP

Unanswered Question
Sep 15th, 2010

I have configured an ATA186 using SIP connecting to my centralized CUCM 7.1.3 cluster.  Everything is fine except for one problem; Only one port on the ATA will register at a time.  When I power it up, one port registers, while the other shows up as 'Unknown' in CallManager.  If I reset the registered port, the 'Unknown' port registers, but the first port doesn't come back from 'Unregistered'.  That is until I reset the second port, when port 1 is 'Registered' and port 2 is 'Unregistered'.

When I look at the Status page of the ATA's web interface, I can see the SIP Reg(0/1) value is either "ON,OFF" or "OFF,ON", depending on if the first port or second port is currently registerd.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Felipe Garrido Tue, 09/21/2010 - 10:52

What firnware version is running on the ATA? Can you collect detailed CUCM traces for when one of the ports goes from a registered to unregistered state?

-Felipe

CHRIS CHARLEBOIS Tue, 09/21/2010 - 12:34

I opened a TAC case, but I'm afraid I know more about this than the TAC engineer.  Looking at the CUCM traces, it would appear that the CUCM doesn't like two registration requests with different usernames coming from the same IP address and port.

09/20/2010 08:36:09.717 CCM|SIPStationD(2,100,47,102), SEP37A61619D901, 10.128.62.165:5060, primaryDN=7153, Registering line (7158) not configured|

09/20/2010 08:36:09.717 CCM|SIPStationD(2,100,47,102), SEP37A61619D901, 10.128.62.165:5060, primaryDN=7153, sendRegisterResp: non-200 response code 404, ccbId 100683, expires 4294967295, warning Line not configured|

09/20/2010 08:36:09.717 CCM|SIPStationD(2,100,47,102), SEP37A61619D901, 10.128.62.165:5060, primaryDN=7153, Phone doesn't support ExtendedRefer, not sending status line update|

09/20/2010 08:36:09.717 CCM|SIPLineRegistrationError - SIP line registration error. Device IP address.:10.128.62.165 Device Port.:5060 Device name [Optional].:SEP37A61619D901 Device type. [Optional]:336 Reason Code [Optional].:2 Connecting Port:5060 Registering SIP User.:7158 Configured DNs.:7153-Registered App ID:Cisco CallManager Cluster ID:StandAloneCluster Node ID:lo-ipt-ccm2|

Line 7153 is the one trying to register, but CUCM keeps bringing up 7158, which is the registered line on the other port.  Which begs the question; How is CUCM supposed to differentiate between the two ports?
Felipe Garrido Tue, 09/21/2010 - 13:35

Are  you adding the ATA is a third party SIP phone? If not, can you elaborate?

-Felipe

CHRIS CHARLEBOIS Tue, 09/21/2010 - 13:58

Yes, as a Third-party SIP Phone (basic).  This is, I believe, the only option for Cisco ATA's running SIP.  The firmware is version 3.2.1 (ATA030201SIP050616A.zup).

Felipe Garrido Wed, 09/22/2010 - 06:34

I've not been able to find a way around this limitation. Is there a reason the ATA is running SIP instead of SCCP? Running SCCP would allow both ports

to be registered at the same time.

-Felipe

CHRIS CHARLEBOIS Wed, 09/22/2010 - 06:48

Oh, I know.  We are running dozens of ATA with both ports humming along nicely.  However, the device that one of these ports needs to support is rather finicky.  It's a Fire Alarm panel and DTMF out-of-band doesn't work.  I think this is because it must use non-standard "DTMF-like" tones.  SIP will allow me to disable DTMF out-of-band on an ATA.  SCCP will not.

Felipe Garrido Wed, 09/22/2010 - 07:27

Have  you tried adding at as an "Advanced" SIP phone and just adding the two extension on separate lines?

-Felipe

Actions

This Discussion