Cisco 1841 Issue

Unanswered Question
Sep 15th, 2010
User Badges:

Hi,


I'm no expert in Cisco, but I wanted to get a simple config up and running so I can test a new connection that was just installed. Basicaly this router will connect one of the ethernet interface to the NTU and the other will just connect to a laptop so I can test the upload and download speeds of the new connection..


I have setup the router with what I hope is somewhat correct and also applied the 9.3Mb shapping policy that the ISP told me to. Now my problem is that once everything is hooked up I still cant access any the net, I believe that its has something to do with the routin. Also is it normal that when setting up the interfaces it doesn't ask for the Gateway IP??



Heres the running config





Building configuration...


Current configuration : 1060 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname router
!
boot-start-marker
boot-end-marker
!
no logging buffered
enable secret 5 $1$nPs.$B5pZUjaXaQPJ13d9RMi8T/
enable password xxxx
!
no aaa new-model
no ip routing
no ip cef
!
!
!
!
ip name-server 139.130.4.4
ip name-server 203.50.2.71
multilink bundle-name authenticated
!
!
archive
log config
  hidekeys
!
!
!
policy-map shape-all
class class-default
  shape average 9300000
!
!
!
!
interface FastEthernet0/0
description $ETH-LAN$
ip address 10.10.10.1 255.255.255.0
no ip route-cache
speed auto
full-duplex
no mop enabled
!
interface FastEthernet0/1
description $ETH-LAN$
ip address 120.xxx.xxx.10 255.255.255.252
no ip route-cache
duplex auto
speed auto
service-policy output shape-all
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 120.xxx.xxx.9 permanent (This is the GW IP that the ISP gave me not sure if this route is correct)
!
!
ip http server
!
!
!
control-plane
!
!
line con 0
line aux 0
line vty 0 4
password xxxxxx
login
!
scheduler allocate 20000 1000
end


As I said this is just a basic setup to get some quick testing done, I will get this setup by a professional once I'm happy that the connection is providing what its ment to


Cheers

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Jon Marshall Wed, 09/15/2010 - 17:07
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

You need to add NAT configuration to your router because 10.10.10.0/24 addressing is not routable on the internet. Add this to your config -


int fa0/0

ip nat inside


int fa0/1

ip nat outside


access-list 101 permit ip 10.10.10.0 0.0.0.255 any


ip nat inside source list 101 interface fa0/1 overload


Jon

Actions

This Discussion