Cisco 851 Wired Router and Nintendo Wii LAN Adapter Problem

Answered Question
Sep 15th, 2010

Here is my setup:

Hardware:
Cisco 851 Wired 10/100 Ethernet Router with latest IOS 12.4
Wii with 4.2U software version - bought in June
2 Wii LAN Adapters (One Rocketfish brand from gamestop, the other a Grey one from Ebay).
ISP: Cox Communications Motorola DOCSIS 3.0 Cable Modem
Error Messages I am getting from the Wii: 51420, 51422, 52120, 52122

What I have done already to troubleshoot:
1. Restarted Router, Wii, and Cable modem
2. Tried to ping the Wii itself on my local network while it was testing  connection - request timed out until 3 seconds before I receive the  error message
3. Port Forwarded the ports that the Wii uses (80, 443, etc...) using ip nat source static IOS commands
4. Directly connected the Wii to my cable modem, no luck
5. Tried both LAN adapters and USB ports.
6. Tried different ethernet (known good) cables.
7. Tried assigning static IP addresses to my Wii and created a static NAT policy on my router for it.
8. Hitting the Wii LAN Adapter with a hammer (just kidding.. but really, it's become this frustrating)

The MAC Address shows up on my Console Information for both adapters and  the LED on my LAN Adapter flashes when I test the connection as well as  on the router itself. I have never been able to get online at all.

Does anyone know any tricks or hacks that will get this thing to work?

- John

I have this problem too.
0 votes
Correct Answer by NickNac79 about 6 years 2 months ago

Hi John,

I assume your Wii is on 192.168.0.200?

You need to remove those "ip nat inside source static" commands as they are not needed and are opening your network up unnecessarily.

You can get rid of the ip nat pool as well, although as it isn't being referenced it isn't doing any harm.

Try also adding "spanning-tree portfast" to your ethernet 2 interface as your Wii may be getting impatient and timing out before your router transitions the port to the forwarding state.

Nick

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
mrmoothe Wed, 09/22/2010 - 06:23

John,

Could you upload the config of your 851 along with which interfaces on the router  are connected to the cable modem and which to the LAN adapter?

This would help clarify the exact setup a little.

-- Manas

NickNac79 Wed, 09/22/2010 - 07:58

Hi John,

The Wii doesn't require any ports forwarding to it, or any special NAT configuration.

If you are overloading all your LAN traffic to your public interface, then this is all that is required.

Essentially - if you are able to pull up www.google.com from a DHCP enabled PC or Laptop attached to the LAN port on your router, then that is all you need to do.

Nick

john03090309 Wed, 09/22/2010 - 11:16

My WAN Link to my cable modem is on Fast Ethernet 4 and my Wii LAN Adapter is on Fast Ethernet 2. I'm able to get out to the internet just fine on other computers. I omitted the "Password 7 235324ABA4123" lines for security reasons in my config, but they are there in my actual config.

Current configuration : 5568 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname ReeskeLAN
!
boot-start-marker
boot system flash c850-advsecurityk9-mz.124-15.XY2.bin
boot-end-marker
!
no logging buffered
enable secret 5 $1$Eydg$oAvcb8yt5yuoa.cs19ZQp/
!
no aaa new-model
!
!
!
crypto pki trustpoint TP-self-signed-4174690770

server name ads1.vip.scd.yahoo.com
server name radio1.launch.vip.dal.yahoo.com
server name in1.msg.vip.re2.yahoo.com
server name data1.my.vip.sc5.yahoo.com
server name address1.pim.vip.mud.yahoo.com
server name edit.messenger.yahoo.com
server name messenger.yahoo.com
server name http.pager.yahoo.com
server name privacy.yahoo.com
server name csa.yahoo.com
server name csb.yahoo.com
server name csc.yahoo.com

enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-4174690770
revocation-check none
rsakeypair TP-self-signed-4174690770
!
!
crypto pki certificate chain TP-self-signed-4174690770
certificate self-signed 01
  3082024C 308201B5 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 34313734 36393037 3730301E 170D3032 30333131 30323036
  31305A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D34 31373436
  39303737 3030819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
  81009EA4 E263051E C58A0518 C7292326 CB15D0A7 CC5D144C 5692595B 11F45842
  EEE90324 C600FFE7 835ACE80 5941811A 145165F4 4C0DE60C 78DC89B9 47C4201C
  D2C7FCC4 FEFE8300 11FF6D24 31518F55 70ED8089 B1CCE86C F8D2B3EB 7406532B
  B1372140 DDFD74F6 06AA0582 0B10B442 1C5A9D7D 8DCFE42A 7B9E1213 97551325
  962B0203 010001A3 74307230 0F060355 1D130101 FF040530 030101FF 301F0603
  551D1104 18301682 14526565 736B654C 414E2E73 642E636F 782E6E65 74301F06
  03551D23 04183016 801403DF F2C75E6F 79A700BF 550D4749 EAD02349 7277301D
  0603551D 0E041604 1403DFF2 C75E6F79 A700BF55 0D4749EA D0234972 77300D06
  092A8648 86F70D01 01040500 03818100 4E6598AB F53FF0E3 FBFCC376 DFDEFBEA

  79BAA632 64768B1A 6591DF89 7B75581E FD0F8B24 570D5216 D74E5C54 7F60CB11
  A0567E5E 87BF031E BBDD848B D5A35BEB BBE5C2AC 38318B1C 90E65D26 717BF796
  3C30ABCE E610D76B 75FF8982 7139101E 7A730DE6 030092DA 537C262F 6B05D7CF
  D41BAF6D B01A4545 12253332 47698BA7
        quit
ip dhcp smart-relay
ip dhcp relay information policy keep
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.0.1 192.168.0.99
!
ip dhcp pool reeskeLAN
   import all
   network 192.168.0.0 255.255.255.0
   dns-server 68.105.28.12 68.105.29.11 68.105.29.12
   default-router 192.168.0.1
   domain-name sd.cox.net
!
!
ip cef
ip inspect log drop-pkt
ip domain name sd.cox.net
ip name-server 68.105.28.11
ip name-server 68.105.28.12

ip name-server 68.105.29.12
!
parameter-map type protocol-info msn-servers
server name messenger.hotmail.com
server name gateway.messenger.hotmail.com
server name webmessenger.msn.com

parameter-map type protocol-info aol-servers
server name login.oscar.aol.com
server name toc.oscar.aol.com
server name oam-d09a.blue.aol.com

parameter-map type protocol-info yahoo-servers
server name scs.msg.yahoo.com
server name scsa.msg.yahoo.com
server name scsb.msg.yahoo.com
server name scsc.msg.yahoo.com
server name scsd.msg.yahoo.com
server name cs16.msg.dcn.yahoo.com
server name cs19.msg.dcn.yahoo.com
server name cs42.msg.dcn.yahoo.com
server name cs53.msg.dcn.yahoo.com
server name cs54.msg.dcn.yahoo.com

server name ads1.vip.scd.yahoo.com
server name radio1.launch.vip.dal.yahoo.com
server name in1.msg.vip.re2.yahoo.com
server name data1.my.vip.sc5.yahoo.com
server name address1.pim.vip.mud.yahoo.com
server name edit.messenger.yahoo.com
server name messenger.yahoo.com
server name http.pager.yahoo.com
server name privacy.yahoo.com
server name csa.yahoo.com
server name csb.yahoo.com
server name csc.yahoo.com

parameter-map type regex sdm-regex-nonascii
pattern [^\x00-\x80]

!
!
username john privilege 15
archive
log config
  hidekeys
!
!
!
!
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface FastEthernet4
description $FW_OUTSIDE$
mac-address 0002.3fb8.78a4
ip address dhcp
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
interface Vlan1
description $FW_INSIDE$
ip address 192.168.0.1 255.255.255.0
ip access-group 100 in
ip nat inside
ip virtual-reassembly
!
ip forward-protocol nd
ip route static adjust-time 40
ip route 172.19.0.0 255.255.0.0 192.168.1.2
!
ip http server
ip http secure-server
ip nat pool pool1 192.168.0.1 192.168.0.254 netmask 255.255.255.0
ip nat inside source list 1 interface FastEthernet4 overload
ip nat inside source static tcp 192.168.0.200 28910 interface FastEthernet4 2891
0
ip nat inside source static tcp 192.168.0.200 29900 interface FastEthernet4 2990
0
ip nat inside source static tcp 192.168.0.200 29901 interface FastEthernet4 2990
1
ip nat inside source static tcp 192.168.0.200 29920 interface FastEthernet4 2992
0
ip nat inside source static tcp 192.168.0.200 80 interface FastEthernet4 80
ip nat inside source static tcp 192.168.0.200 443 interface FastEthernet4 443
!
access-list 1 permit 192.168.0.0 0.0.0.255
access-list 1 remark SDM_ACL Category=18
access-list 100 permit ip any any
access-list 100 permit udp any any
access-list 101 permit udp host 192.168.0.200 any
access-list 101 permit udp any host 192.168.0.200
access-list 101 permit udp any any
access-list 101 permit ip any any
!
control-plane
!
banner motd ^C
Welcome to Reeske.net. If you're not authorized to be here, logoff immediately.^
C
!
line con 0

logging synchronous
login local
no modem enable
line aux 0
line vty 0 4

logging synchronous
login local
!
scheduler max-task-time 5000
end

mrmoothe Wed, 09/22/2010 - 14:28

Okay... so lets check a few thing here...

Once you connect your Wii to fa2 - do you get an ip address? (I'm not sure whether you can see the ip address of the Wii once you connect it... I'm a PS guy )

If you do get an ip address.... make sure that this address is in the range of 192.168.0.x

Check whether you can ping ping ip address from the router.

If all of the above happens, try a ping to the internet from the router sourced from the interface vlan 1.

ping 4.2.2.2 source vlan 1

And if that works... can you temporarily remove the access-list you have placed incoming on vlan 2 and try again?

Just do a 'no ip access-group 100 in' on interface vlan 1.

Let me know how this goes.

Cheers.

Correct Answer
NickNac79 Wed, 09/22/2010 - 22:58

Hi John,

I assume your Wii is on 192.168.0.200?

You need to remove those "ip nat inside source static" commands as they are not needed and are opening your network up unnecessarily.

You can get rid of the ip nat pool as well, although as it isn't being referenced it isn't doing any harm.

Try also adding "spanning-tree portfast" to your ethernet 2 interface as your Wii may be getting impatient and timing out before your router transitions the port to the forwarding state.

Nick

john03090309 Thu, 09/23/2010 - 00:06

It was portfast, the thing just was timing out, since the connection wasn't warming up fast enough. It's weird though how the Wii LAN adapter doesn't always turn itself on, it's only on when you are online, or testing the connection. It works now nicely though! Thanks!!

mrmoothe Thu, 09/23/2010 - 17:43

Hi Nick,

I just wanted to congragulate. you on that catch...

Such a simple thing... slipped my mind completely...

Portfast... lol...

Cheers,

Manas

Actions

This Discussion