SRST Configuration Help

Answered Question
Sep 15th, 2010
User Badges:

Hi All, I need some help from the experts. I had an outage today where are CUCMBE server went down. Long story short I had to hard reboot Call manger via ILO. For some reason call processing stopped. Calls coming in and going out failed. I've contacted TAC to find out if there is a bug with the version of Call Manager I'm using.


Anyway I had configured SRST several months ago but, never tested. Obviously today it did not work. Can someone take a look at my config and tell me why SRST did not work?


CUCMBE Version System version: 6.1.3.2000-1


Thanks....Dan


hostname 2821
!
boot-start-marker
boot system flash:c2800nm-spservicesk9-mz.124-22.T.bin
boot-end-marker
!
card type t1 0 1
logging message-counter syslog
logging buffered 51200 warnings
enable secret 5 $1$bI38$x3cLxcrrJNiXqIzTSrxZghghghh0
!
no aaa new-model
clock timezone AZ -7
network-clock-participate wic 1
network-clock-select 1 T1 0/1/0
!
dot11 syslog
ip source-route
!
!
ip cef
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.11.1 192.168.11.20
ip dhcp excluded-address 192.168.11.150 192.168.11.254
ip dhcp excluded-address 192.168.1.1 192.168.1.49
ip dhcp excluded-address 192.168.1.250 192.168.1.254
ip dhcp ping packets 4
!
ip dhcp pool IP-Phones
   network 192.168.11.0 255.255.255.0
   default-router 192.168.11.1
   option 150 ip 192.168.11.10
   dns-server 192.168.2.6
   domain-name xxx.local
!
ip dhcp pool Local-LAN
   network 192.168.1.0 255.255.255.0
   default-router 192.168.1.1
   dns-server 192.168.2.6
   netbios-name-server 192.168.2.6
   netbios-node-type h-node
   domain-name xxx.local
!
!
ip domain name xxx.local
ip name-server 192.168.2.6
no ipv6 cef
multilink bundle-name authenticated
!
!
!
!
isdn switch-type primary-ni
!
!
!
voice service voip
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!        
!
voice-card 0
dsp services dspfarm
!
!
crypto pki trustpoint TP-self-signed-2474435094
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-2474435094
revocation-check none
rsakeypair TP-self-signed-2474435094
!
!
crypto pki certificate chain TP-self-signed-2474435094
certificate self-signed 01
  3082024B 308201B4 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 32343734 34333530 3934301E 170D3038 30383233 32323233
  32345A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D32 34373434
  33353039 3430819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
  8100C9DE 4EACE946 780D15E2 22F094A1 6A8B1126 E01EF3A7 166126C4 015FA887
  5EA52BC9 D5D8648C 2CD7DB0A 6BEB953B 9509CB08 8C4DC4C1 BEC6C8CA 5A46A1AA
  4E5172AC 0259A6E0 53B5D25F 7FB56F21 ACA53797 2ED3AA1C 5931265C C3261CFF
  D5AA119C 1B1A5547 B3877947 CA45E4DB 9CA24FD4 060FBE57 29AE2EF1 D9423CDB
  B3690203 010001A3 73307130 0F060355 1D130101 FF040530 030101FF 301E0603
  551D1104 17301582 13456173 74323832 312E7465 6E742E6C 6F63616C 301F0603
  551D2304 18301680 14972886 677AC2F9 6F4B7EA4 CEF3F930 9E81E205 9F301D06
  03551D0E 04160414 97288667 7AC2F96F 4B7EA4CE F3F9309E 81E2059F 300D0609
  2A864886 F70D0101 04050003 8181008C 2CF25ED7 9745A48D 385290A0 6F3A950D
  D9183EB6 0A160273 59CFB764 F10C12D9 B4BB1820 F5629119 B719EBC5 87FDE2BF
  B30D6A09 1F891753 7E5EB205 254AED61 2DF561F0 9DA94107 9BC5F4C9 882558CE
  0B7A7AD7 D7C4810D C9B6E0BF 90DE69A8 74CCF23D A29CD7A7 98477863 0B640902
  BA7837C3 4101D19A E3429C4D B24A14
        quit
!
!
archive
log config
  hidekeys
!
!        
controller T1 0/1/0
cablelength long 0db
pri-group timeslots 1-24 service mgcp
description PRI
!
!
class-map match-any VOIP-SIGNAL
match ip dscp cs3
class-map match-any VOIP-VOICE
match ip dscp ef
!
!
policy-map QOS-Policy-100mb-Child
class VOIP-SIGNAL
    priority percent 1
  set cos dscp
class VOIP-VOICE
    priority percent 5
  set cos dscp
class class-default
    fair-queue
     random-detect
policy-map QOS-Policy-100mb-Parent
class class-default
    shape average 100000000
  service-policy QOS-Policy-100mb-Child
policy-map QOS-Policy-10mb
class VOIP-SIGNAL
    priority percent 1
  set dscp cs3
class VOIP-VOICE
    priority percent 50
  set dscp ef
class class-default
    fair-queue
     random-detect
!
!
!
!
!        
interface GigabitEthernet0/0
description Trunk to LAN for Voice/Data
no ip address
ip flow ingress
ip flow egress
duplex auto
speed auto
!
interface GigabitEthernet0/0.1
encapsulation dot1Q 1 native
ip address 192.168.1.20 255.255.255.0 secondary
ip address 192.168.1.1 255.255.255.0
!
interface GigabitEthernet0/0.5
bandwidth 100000
encapsulation dot1Q 5
ip address 192.168.11.1 255.255.255.0
ip flow ingress
!
interface GigabitEthernet0/1
description Connection to MetroE Circuit
bandwidth 10000
ip address 192.168.253.1 255.255.255.0
ip flow ingress
ip flow egress
duplex full
speed 10
service-policy output QOS-Policy-10mb
!
interface Serial0/1/0:23
no ip address
encapsulation hdlc
isdn switch-type primary-ni
isdn timer T310 10000
isdn incoming-voice voice
isdn bind-l3 ccm-manager
no cdp enable
!
interface FastEthernet0/3/0
description Link to ASA
ip address 192.168.254.2 255.255.255.0
duplex auto
speed auto
!
router eigrp 1
redistribute static
network 192.168.1.0
network 192.168.11.0
network 192.168.253.0
network 192.168.254.0
auto-summary
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 192.168.254.1
ip route 192.168.100.0 255.255.255.0 192.168.254.1
no ip http server
ip http secure-server
!
!
!
control-plane
!
!
!
voice-port 0/0/0
!
voice-port 0/0/1
!
voice-port 0/0/2
!
voice-port 0/0/3
!
voice-port 0/1/0:23
!
ccm-manager mgcp
no ccm-manager fax protocol cisco
ccm-manager music-on-hold
ccm-manager config server 192.168.11.10 
ccm-manager config
!
mgcp
mgcp call-agent 192.168.11.10 2427 service-type mgcp version 0.1
mgcp dtmf-relay voip codec all mode out-of-band
mgcp rtp unreachable timeout 1000 action notify
mgcp modem passthrough voip mode nse
mgcp package-capability rtp-package
mgcp package-capability sst-package
mgcp package-capability pre-package
no mgcp package-capability res-package
no mgcp package-capability fxr-package
no mgcp timer receive-rtcp
mgcp sdp simple
mgcp fax t38 ecm
mgcp fax t38 inhibit
mgcp rtp payload-type g726r16 static
!
mgcp profile default
!
!
!
dial-peer voice 9999999 pots
description *For incoming DID calls*
incoming called-number .
direct-inward-dial
!
dial-peer voice 911 pots
description *Emergency 911*
destination-pattern 911
port 0/1/0:23
forward-digits 3
!
dial-peer voice 6911 pots
description *Emergency 911 dialed with 6*
destination-pattern 6911
port 0/1/0:23
forward-digits 3
!
dial-peer voice 607 pots
description *local 7 digit dialing*
destination-pattern 6[2-9]......
port 0/1/0:23
forward-digits 7
!
dial-peer voice 6011 pots
description *outgoing 11 digit long distance*
destination-pattern 61[2-9]..[2-9]......
port 0/1/0:23
forward-digits 11
!
dial-peer voice 6520 pots
description *Dial peer for 10 digit 520 dialing*
destination-pattern 6520[2-9]......
port 0/1/0:23
forward-digits 10
!
!
!
call-manager-fallback
max-conferences 8 gain -6
transfer-system full-consult
ip source-address 192.168.11.1 port 2000
max-ephones 52
max-dn 192
system message primary Phone System in local mode
default-destination 1101
!
!
line con 0
line aux 0
line vty 0 4
password 7 0942191E1A01914020B457B
login
transport input telnet ssh
line vty 5 15
password 7 05055118224400F10025643
login
transport input telnet ssh
!
scheduler allocate 20000 1000
ntp source GigabitEthernet0/0.1
ntp master
ntp server 69.25.96.13
ntp server 192.43.244.18
ntp server 132.163.4.101 prefer
ntp server 64.147.116.229
end

Correct Answer by dksingh about 6 years 6 months ago

Hi there!


This appears to be a mgcp GW...


What u didn't clarify is if the IP phones did fallback and register with the SRST router but u said...


"Calls coming in and going out failed."


which makes me think that ip phone<-->ip phone internal calls were working?


If phones did not register with SRST router during CUCM outage then u need to check if the

CallManager X parameter is populated properly (using phone display/menu or http) on the

phone.

This shd be the SRST router's IP source-addr (192.168.11.1) as specified in SRST reference

on CUCM phone dev pool.


Assuming phones did fall back fine, for PSTN/external  in/out calls to work properly, both

MGCP fallback as well as SRST has to kick in which are two independent features.


You are missing two basic IOS/GW  commands related to mgcp fallbk :


ccm-manager fallback-mgcp


application
global
   service alternate default


Ref:
http://www.cisco.com/en/US/tech/tk1077/technologies_tech_note09186a0080144630.shtml


Hope this helps.


DK

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Correct Answer
dksingh Wed, 09/15/2010 - 19:53
User Badges:
  • Cisco Employee,

Hi there!


This appears to be a mgcp GW...


What u didn't clarify is if the IP phones did fallback and register with the SRST router but u said...


"Calls coming in and going out failed."


which makes me think that ip phone<-->ip phone internal calls were working?


If phones did not register with SRST router during CUCM outage then u need to check if the

CallManager X parameter is populated properly (using phone display/menu or http) on the

phone.

This shd be the SRST router's IP source-addr (192.168.11.1) as specified in SRST reference

on CUCM phone dev pool.


Assuming phones did fall back fine, for PSTN/external  in/out calls to work properly, both

MGCP fallback as well as SRST has to kick in which are two independent features.


You are missing two basic IOS/GW  commands related to mgcp fallbk :


ccm-manager fallback-mgcp


application
global
   service alternate default


Ref:
http://www.cisco.com/en/US/tech/tk1077/technologies_tech_note09186a0080144630.shtml


Hope this helps.


DK

dan hale Thu, 09/16/2010 - 08:03
User Badges:

Wow Thanks for the info. I assumed that by entering the "call-manager-fallback" command that I was also enabling SRST.Now when I show the "sh ccm-manager fallback-mgcp" command it shows that MGCP fall back mode is enabled but, off where before it had nothing.


   Do I need to configure any type of load information and DN info for the phones, or will the phones keep there DN's and load info unless they get rebooted? Is there a way that I can test SRST on a single phone, I could shut down the switchport that CM is connected too but, that seems extreme.


Thanks,

Dan

dksingh Thu, 09/16/2010 - 08:33
User Badges:
  • Cisco Employee,

U r welcome!

No  load or DN related commands are required and phone will retain the DN info

while operating in SRST mode.


You can use an access list on the router acting as default GW for the phone

to block it from reaching the CCM.

But all that would do is confirm whether the phone is capable of falling over and

registering with the SRST router.

To properly test SRST and mgcp fallbk which is the case here, you'd need to

prevent GW from reaching the CCM as well which can be accomplised with

an acces list as well or a static route (something like...)


ip route   255.255.255.255 Null0


Hope this answers you ques. on this thread.


Thanks.

DK

Actions

This Discussion

Related Content