ASA Firewall blocks a PPTP VPN session

Unanswered Question
Sep 3rd, 2010


I have a VPN PPTP session on my PC, however as soon as I have installed a firewall ASA 5505 ver. 8x on

my company's network I'm NOT able to connect outside on my PPTP server.

Please see my configuration below and let me know for any suggestions. Thank you very much for your time.

ASA Version 8.2(1)
enable password xxxxxxxxxxxxx encrypted
passwd xxxxxxxxxxxxx encrypted
interface Vlan1
nameif inside
security-level 100
ip address
interface Vlan2
nameif outside
security-level 0
ip address x.x.x.45
interface Ethernet0/0
switchport access vlan 2
interface Ethernet0/1
interface Ethernet0/2
interface Ethernet0/3
interface Ethernet0/4
interface Ethernet0/5
interface Ethernet0/6
interface Ethernet0/7
ftp mode passive
clock timezone EEST 2
clock summer-time EEDT recurring last Sun Mar 3:00 last Sun Oct 4:00
dns domain-lookup inside
dns domain-lookup outside
same-security-traffic permit inter-interface
same-security-traffic permit intra-interface
access-list outside_access_in extended permit tcp any host x.x.x.45 eq pop3

access-list outside_access_in extended permit tcp any host x.x.x.45 eq https

access-list outside_access_in extended permit tcp any host x.x.x.45 eq www
access-list outside_access_in extended permit tcp host x.x.x.146 host x.x.x.45 eq 3389
access-list outside_access_in remark RMD DN
access-list outside_access_in extended permit tcp x.x.x.192 host x.x.x.45 eq 3389
access-list outside_access_in extended permit tcp any host x.x.x.45 eq ftp
access-list VPN_splitTunnelAcl standard permit
access-list inside_nat0_outbound extended permit ip
access-list inside_nat0_outbound extended permit ip
access-list REMOTE_splitTunnelAcl standard permit
access-list 101 extended permit gre any host x.x.x.13
access-list 101 extended permit tcp any host x.x.x.13
pager lines 24
logging enable
logging asdm informational
mtu inside 1500
mtu outside 1500
ip local pool VPN mask
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 1
static (inside,outside) tcp interface 3389 3389 netmask
static (inside,outside) tcp interface pop3 pop3 netmask
static (inside,outside) tcp interface https https netmask
static (inside,outside) tcp interface www www netmask
static (inside,outside) tcp interface ftp ftp netmask
access-group 101 in interface outside
route outside x.x.x.46 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
dynamic-access-policy-record DfltAccessPolicy
http server enable
http inside
http inside
http x.x.x.192 outside
http x.x.x.146 outside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac
crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac
crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac
crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac
crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set transform-set ESP-AES-128
crypto map outside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
crypto map outside_map interface outside
crypto isakmp enable outside
crypto isakmp policy 10
authentication pre-share
encryption 3des
hash sha
group 2
lifetime 86400
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd auto_config outside

threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
group-policy REMOTE internal
group-policy REMOTE attributes
dns-server value
vpn-tunnel-protocol IPSec
split-tunnel-policy tunnelspecified
split-tunnel-network-list value REMOTE_splitTunnelAcl
username xxxx password xZ16ZWBXZLVt4Tfb encrypted privilege 0
username xxxxx attributes
vpn-group-policy REMOTE
tunnel-group REMOTE type remote-access
tunnel-group REMOTE general-attributes
address-pool VPN
default-group-policy REMOTE
tunnel-group REMOTE ipsec-attributes
pre-shared-key *
class-map inspection_default
match default-inspection-traffic
policy-map global_policy
class inspection_default
  inspect pptp
service-policy global_policy global
prompt hostname context
: end



I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Federico Coto F... Fri, 09/03/2010 - 07:21

Hi Leon,

What error do you see on the client?

The ASA is doing PAT therefore handles the PPTP session with the PPTP inspection (which you have already).


leonnikolaou Fri, 09/03/2010 - 10:42

Hi Federico,

I have attached you the error.

However, I'll also o a capture as you told me to see where exactly is blocking the session.

Thanks a lot.


Panos Kampanakis Fri, 09/03/2010 - 07:23

Your config looks good Leonida.

I would suggest to capture packets in and out of the ASA using the "capture capin interface inside match ip any host

There was a PPTP inspection issue on the ASA in 8.0, but it is fixed in 8.2.

I hope it helps.


leonnikolaou Fri, 09/03/2010 - 10:44

Hi PK,

I 'll do a capture to see more in depth what's going on.

Thanks a lot for your suggestion.


leonnikolaou Sat, 09/04/2010 - 01:08

Hi Manish,

The sh run all nat-control command shows:

no nat-control




This Discussion