1130AG and XP sp3 file copy problem

Answered Question
Sep 16th, 2010

Hello, we just deployed a cisco wireless solution with WLC4404-100, WCS, and a bunch of 1130AP and I experience some problem with file copy under windows xp. The file copy is working fine with my Ethernet connection however.

The symptom is as follow. I cannot copy large file from a share to the computer. The copy starts then after a while (let's say 30MB copy over a 100MB file) it stops with the error 'File copy error: The network name is no longer available'. When this occurs, I still have my wireless card connected and I can ping my computer from the controller.

I tried to adjust some radio settings (channel, power on the AP I'm connected to) because we have a large wireless network here, but no success. I also update the wireless card driver, create a new SSID, etc. No success at all. However the copy went fine for small file size.

Does anyone here had this issue in the past?

Thanks to all for your help

Theo

Correct Answer by Nicolas Darchis about 6 years 4 months ago

Hi theophile,

This command was introduced in 6.0 and later.

4.2 is "old" in date but for sure the most stable currently.

Since the transfer stops in the middle with a reference to the share name not being available I would think about broadcasts. By default, broadcasts are blocked on the WLC and this is how windows mostly do file transfers.

If you try to transfer the same file via FTP, would it work ? If yes, I really think the windows network share protocol traffic should be inspected to see if there is a problem with resovling a name or with broadcasts or sth.

Nicolas

Correct Answer by Serge Yasmine about 6 years 4 months ago

Hi Theophile,

1- What version of WLC you are having?

2- Is your server from where you are copying having a 1 Gig interface?

If answer to (2) is yes please try to enter on WLC CLI:

config ap tcp-adjust-mss enable YOURAPNAME 1300

keep us posted.

Serge

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
Correct Answer
Serge Yasmine Wed, 10/13/2010 - 13:57

Hi Theophile,

1- What version of WLC you are having?

2- Is your server from where you are copying having a 1 Gig interface?

If answer to (2) is yes please try to enter on WLC CLI:

config ap tcp-adjust-mss enable YOURAPNAME 1300

keep us posted.

Serge

theophile Thu, 10/14/2010 - 00:09

Hi Serge,

First of all thanks for your answer.

We're using version 4.2.205, I know it's an old one but we are in a process to move to a 7.0 version. The server is connected with its gigabit interface so I'll try the command you gave me, and i'll keep you posted of course

Thanks

theophile Fri, 10/15/2010 - 01:58

Serge, the command does not exist on  4.2.205. Is there a similar one to adjust the mss?

Thanks, best regards

Correct Answer
Nicolas Darchis Fri, 10/15/2010 - 02:15

Hi theophile,

This command was introduced in 6.0 and later.

4.2 is "old" in date but for sure the most stable currently.

Since the transfer stops in the middle with a reference to the share name not being available I would think about broadcasts. By default, broadcasts are blocked on the WLC and this is how windows mostly do file transfers.

If you try to transfer the same file via FTP, would it work ? If yes, I really think the windows network share protocol traffic should be inspected to see if there is a problem with resovling a name or with broadcasts or sth.

Nicolas

glen.grant Sat, 10/16/2010 - 17:35

  Check things like  speed/duplex between the ap and the switch it is attached to . It should be set as auto and not hardcoded.  Verify the path from the subnet that the ap's are attached  in does not have a network issue between them and the WLC .   Can't imagine anything in the wireless setup that would put that kind of delay in the application.  Just something to check...

theophile Mon, 02/14/2011 - 04:29

Hi all, I finally found the solution by setting the mtu

in the windows registry. Was set to default (1500), and it worked fine when set at 1400. Thanks to all for your help.

theophile Thu, 08/04/2011 - 03:07

Serge, we finally upgrade the controller to version 7, and the tcp-mss command fixed the problem too, like setting the MTU in the windows registry.

Best regards

theophile Mon, 02/14/2011 - 04:35

Can someone explain me how to close the dioscussion as the problem is now fixed? thanks

Serge Yasmine Mon, 02/14/2011 - 04:39

You need to choose the answer that was most appropriate to your problem and mark the thread as answered.

Actions

This Discussion

Related Content

 

 

Trending Topics: Other Wireless Mobility

client could not be authenticated
Network Analysis Module (NAM) Products
Cisco 6500 nam
reason 440 driver failure
Cisco password cracker
Cisco Wireless mode