EPM Question

Unanswered Question
Sep 16th, 2010
User Badges:

Hello Everyone


I'm seeing the following on EPM connections and was wondering if this is normal. Version 4.2.1.


D:DRE,L:LZ,T:TCP Optimization RR:Total Reduction Ratio
A:AOIM,C:CIFS,E:EPM,G:GENERIC,H:HTTP,M:MAPI,N:NFS,S:SSL,V:VIDEO


ConnID        Source IP:Port          Dest IP:Port                      PeerID      Accel           RR

234938    172.27.131.75:1077      172.20.204.3:135               N/A          E               00.0%

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Bhavin Yadav Fri, 09/17/2010 - 16:28
User Badges:
  • Cisco Employee,

Hi John,

Do you see lot of connections with "E" as AO being used for connections? If yes, you may want to disable and enable EPM accelerator. This will clear up any remainders and will save connections for you.

CLI commands:

no accelerator epm enable


accelerator epm enable


To help you further, we will need show stat connection and show version output from the WAE.


Regards.

johng231 Fri, 09/17/2010 - 19:02
User Badges:

I'm seeing tons of connections like this on our core . I don't want to display the  entire show stat conn output on here as we are using public IP addresses on the LAN. I did turn off EPM from the CM and re applied it, still shows up with N/A on only TCP port 135.



407007    172.27.131.75:4867      172.21.51.72:135               N/A E     00.0%


Cisco Wide Area Application Services Software (WAAS)
Copyright (c) 1999-2010 by Cisco Systems, Inc.
Cisco Wide Area Application Services (WAAS-ACCELERATOR-K9) Software Release 4.2.1 (build b38 Jun 16 2010)
Version: oe7371-4.2.1.38

Compiled 23:16:05 Jun 16 2010 by damaster

Device Id: 00:1a:64:ca:17:9c
System was restarted on Sun Jul 18 05:57:22 2010.
The system has been up for 8 weeks, 5 days, 19 hours, 55 minutes, 18 seconds.




Accelerator     Licensed        Config State    Operational State            
-----------     --------        ------------    -----------------            
cifs            Yes             Enabled         Running   
epm             Yes             Enabled         Running   
http            Yes             Enabled         Running   
mapi            Yes             Disabled        Shutdown  
nfs             Yes             Enabled         Running   
ssl             Yes             Enabled         Running   
video           No              Disabled        Shutdown  
wafs-core       Yes             Disabled        Shutdown                      
wafs-edge       Yes             Disabled        Shutdown
   

Bhavin Yadav Fri, 09/17/2010 - 23:04
User Badges:
  • Cisco Employee,

Hi John,

MAPI AO is shutdown and disabled. Is there any reason why it is like that? Can you turn on MAPI and then reset EPM again to see if you come across this issue?

This is because EPM is tied up and depends heavily on MAPI. The EPM application accelerator must be enabled for the MAPI application  accelerator to operate. EPM is enabled by default. Additionally, the  system must define an application policy of type EPM, specify the MAPI  UUID, and have an Accelerate setting of MAPI. This policy, MAPI for the  Email-and-Messaging application, is defined by default.

EPM traffic, such as MAPI, does not normally use a predefined port. If  your Outlook administrator has configured Outlook in a nonstandard way  to use a static port, you must create a new basic application policy  that accelerates MAPI traffic with a classifier that matches the static  port that was configured for Outlook.


Please try enabling MAPI and see how it goes, if you can.


Regards.

johng231 Sat, 09/18/2010 - 11:20
User Badges:

We are using Lotus Notes. I enabled the MAPI services and it's still happening.



683678    172.27.131.75:2106      172.21.51.72:135               N/A E     00.0%


Accelerator     Licensed        Config State    Operational State            
-----------     --------        ------------    -----------------            
cifs            Yes             Enabled         Running   
epm             Yes             Enabled         Running   
http            Yes             Enabled         Running   
mapi            Yes             Enabled         Running   
nfs             Yes             Enabled         Running   
ssl             Yes             Enabled         Running   
video           No              Disabled        Shutdown  
wafs-core       Yes             Disabled        Shutdown                      
wafs-edge       Yes             Disabled        Shutdown

Bhavin Yadav Sat, 09/18/2010 - 18:21
User Badges:
  • Cisco Employee,

Hmm. After enabling MAPI and resetting EPM, if the issue continues, there is something else going on. I will need to do some research and get back to you on this one.


One quick question: If you are not using MAPI, do you really need EPM? As I mentioned before, EPM is heavily tied with MAPI with these appliances.


Regards.

johng231 Sun, 09/19/2010 - 14:42
User Badges:

I probably don't really need it but If I'm hitting a policy that is using it by default, it should work by design. There are other default WAAS policies that are not related to Microsoft Exchange using EPM; such as MS-SQL-RPC, MS-AD-Replication & MS-FRS.

Actions

This Discussion